Showing results for 
Search instead for 
Did you mean: 


Journeyman III

MSI B450 Tomahawk Max BIOS woes

Hey all,

This post was originally made on Reddit r/HPReverb and was suggested to repost to AMD to spread awareness and information.


If someone can help, that would be awesome, but if not, this is more of a root cause log for those looking.

I bought my G2 about a year ago and it was working fine via my USB-C connection on my motherboard. At the time I was running an AMD 1700x CPU and my current AMD 5700XT.

I decided to update my CPU to a 5600 and performed the required BIOS update to get the motherboard to recognize the CPU. The BIOS update was not the latest version available but the version that supported 5600 by default.
On booting into Windows 10, I found that the G2 was no longer being recognized by Windows and thought perhaps I needed to update my chipset drivers. After a quick install and reboot, Windows still failed to recognize the G2. However, I will note that Windows does "see" the G2 as it comes up in the device manager for the Hololens sensors and controllers. However, the G2's HP light never luminates.

Reading over the Windows VR support, they suggest plugging in via USB A with an adapter, not ideal, but I try. Voila, Windows now sees the G2 properly and the HP light now luminates.
However... It would appear something is not quite right as Windows keeps beeping and I see the volume controls flash in the VR and in SteamVR, I lose visual tracking. My control focus also keeps switching between Windows and the VR with an in VR prompt saying press 'Win+Y' to change focus.
In short, the VR experience doesn't really work.

Thinking perhaps MSI fkd something with their BIOS (not unheard of - and this being proof of), I decided to update to the LATEST BIOS that MSI has to offer, as it does mentioned latest AGESA support.
After BIOS update and install of the chipset drivers I reboot and hope for the best.
It goes from bad, to worse.
Windows still only slightly sees the G2, the HP light does not luminate and I am back to square one.
I've tried all different USB ports my motherboard has to offer and nothing.

I have tried what I believe are all different options to troubleshoot outside of changing physical hardware or reinstalling Windows itself.

Not that I should have to do that since it was working on all the same hardware that I have now, except with an ancient Ryzen 1700x cpu and old BIOS.

As I said at the start, if someone else has run into this issue and have found a solution that doesn't require being additional hardware, then I am all ears.
Until I decide to reinstall Windows 10, I think my G2 will be sitting here on my desk doing SFA for quite some time.

Not Happy MSI.


UPDATE: Contacted HP and having them send me rev. 2 of the data cable that can potentially solve the issue. However this data point could still be quite valuable in identifying and existing problem or help resolve a currently known problem.

0 Replies