Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Moving raid from one AMD FM2 board to a FM2+ board

I've run into a snaffu.  My older AMD FM2 system bit the dust when my A8-6600 died.  I replaced the board with an FM2+ and a A10-7890.  I have the following setup:

1)  A primary SSD for the OS

2)  A 3TB single drive used for program files and TV recording (Yes I use media center)

3)  A 3 disk RAID 5 array consisting of 3 2TB drives.

The RAID array is giving me fits.  I had configured it with the AMD raid on the FM2 system.  I moved the disks and performed the following in order:

1)  Plugged the SSD and Program drive into ports 0 and 1 in the motherboard

2)  Plugged the old raid disks into the new GA-F2A88X-D3HP motherboard in the same order using ports 2,3, and 4. 

3)  Turned RAID for the SATA settings

4)  Tried using "CTRL-R" to get into the AMD RAID setup "Bios".  The system comes up, shows all of my drives, but shows that my 3 2TB drives are non raid.

5)  Installed Windows 10 x64 to the SSD and used the RAID driver provided by Gigabyte. I can load into Windows 10, but the system rapidly becomes unstable and crashes with an odd color shift to the display.

So as an alternative setup I've tried:

1)  Disconnect the SATA connections from my 3 2TB drives

2) Reinstall windows 10 x64 while in RAID mode in the BIOS

3) load all AMD driver packs (Crimson, and the optional RAIDXpert pack with chipset drivers)

4)  Run the system for a while to verify everything is running correctly.

5) shutdown and reconnect RAID drives.

The end result of this is that I cannot boot into windows.  The board cannot find the boot disk.  Disconnecting the 3 raid drives will allow the system to boot.

Any assistance here would be appreciated.  Luckily thanks to google photos and google music my personal photos and music are all backed up.  I'm just worried about my other random data on the drives I would like to recover.  Is this recoverable via some trick or should I be looking at either a recovery tool or a new low end FM2 processor to get my old board working?

2 Replies
Journeyman III

Re: Moving raid from one AMD FM2 board to a FM2+ board

I cannot boot into windows. The board cannot find the boot disk.

General answer:

0.) For the Windows setup take care to use the UEFI-boot-device.

1.) Boot from the installation medium into the PE-Environment. Enter the branch installation -> custom. Follow it, up to the disk configuration step.

2.1) Load the RAID drivers. Check whether your RAID is shown as a compound logical drive, now.

2.2) If you don't see your RAID as a compound logical drive here, you can trash it and build a new one from scratch. Yes, this was quite disappointing since the idea, why to have the RAID5, was to have a fail proof (logical) disk. That's not exactly true, though. The second idea was: because it is cheaper (larger and faster) than a software RAID1 (Dynamic Disk mirror). Well, cheaper in the short sight ...

3.1) Enter Shift+F10 to get a command prompt (and use `start` to get further ones).

3.2) Use `diskpart` to ensure there is exactly one System Partition (EFI) and no MBR marked active.

3.3) Use `bcdboot` to instruct the board/UEFI which system where to boot. Optionally use `mountvol /s` to mount the system partition.

3.4) Use `bcdedit` to edit the 'description' of the {bootmgr} to give a hint whether the board/UEFI got the right boot configuration.

3.5) Abort the installation procedure, reboot into the board/UEFI-Setup, and select the appropriate boot device (select the description given to the {bootmgr}).

Adept I

Re: Moving raid from one AMD FM2 board to a FM2+ board

hello im just curious to know how you resolved this issue? i had a raid 0 on a asus 970 mb. then i bought a asus b350 prime.  their raid drivers are not the same, so i just backed up everything important and started a new raid in the new board.