Showing results for 
Search instead for 
Did you mean: 


Journeyman III

kernel-power 41 errors

I my board is a Mag x570 tomahawk wifi, with a ryzen7 2700X, NZXT C850w psu, G.Skill F4-2400C15D-32GFXR 32gb (16gbx2) ram, xpg sx8200 512gb nvme drive (m2_1), wd sn750 1tb nvme (m2_2), radeon rx 580 8gb. I updated to the newest bios 1.5 (Agesa yesterday evening. I have xmp, CBP, PBO, PSS disabled. Here is my system info:



This happened around 7am today:


this is the error info from bluescreenview app:



Any help would be appreciated, thank you.

2 Replies
Adept III

Hello i have the same error after i bought a cpu 5900x and 6900xt graphics card.

I have changed most of my hardware and tried to see if i could find the reason.
Long story short i tried changing all of my hardware except the cpu and no matter how i mix my hardware i have the same error. So either the cpu is defective or its the software/drivers
I even tried with two different x570 motherboards and i have excact same problem.
I change ram, i change psu, i tried using an old graphics card ect.. and computer crash with kernel power 41 again and again.
My computer only crashes in games but not when i do stress test for many houres.
Example hitman 3 crashes all the time with a kernel power id 41.
My computer does also not overheat.

Personaly have given up fixing the problem and so to speak suck it up and hope for a driver fix during february that fix it.
Problem is if i send it for repair or anything then there are 0 new hardware until april and maybe longer time after that.

The hardware have a great performance but I cant play any game for more than example 2 houres in best case.
So something is clearly wrong.

Im extremly unhappy with my faulty hardware and instability and have sufferede from it since i got it 22 december.
Before that my 3900x cpu, x570 motherboard, and ram, and 2080rtx had 0 crashes.
Everything started when i got the 5900x and 6900xt hardware.


I have the same kernal 41 power errors when overclocking on 6900xt/3800x/x570 board.


Only difference` is my system completely reboots, and then wattman says there is an issue. Not an eloquent way to fail, in my opinion