Showing results for 
Search instead for 
Did you mean: 


Adept I

Issues with Ryzen 3700x and ASUS X570-F Gaming

Starting off, before this issue there was no issues other than having to undervolt my board and uses ASUS tool within bios to “Auto Clock” my CPU turning down the Voltage from 1.44v (DEFAULT) to 1.11v (AUTO) and turning the boost off...and setting at 3899Mhz which made games run faster and cooler where as previously it was running between 45/55 degrees on idle and which the boost off and lowered voltage it ran between 28/32 degrees at Idle. Any ideas? This isn’t my main issue...please read below?


So my build has been perfectly fine up until when I updated the BIOS the other day, I was on version 1404 previously and I made a big leap as I was behind too 3405 which installing the BIOS went all smooth and my first day on it everything was normal....then the next day I came to the PC, it posted, booted, loaded windows and then restarted randomly. Had me so confused thinking it was a faulty PSU but then I figured it’s a new PSU and worked fine before the BIOS update....anyway I downgraded to the 3001 update and it works perfectly fine again apart from a few registry issues but due to do a fresh install for Windows anyway...I can’t figure it out why doesn’t the new BIOS work properly? I updated all the chipset drivers, and Raid driver when upgrading to 3405 it was just super buggy, it’ll do it like 3 times and then I’ll load up call of duty to test and be able to have a 5 hour gaming session with no turn offs but on first boot it usually restarts once or twice which it did why in BIOS update the first time had to run recovery mode....what is wrong with the AGESA? The error I was getting on 3405 was “WHEA LOGGER 19 on core” but since downgrading to 3001 that error isn’t there no more and PC works fine? Any thoughts on both of these subjects?

11 Replies

Thanks for the heads up on the issues you are having with the Ryzen 3700X and Asus Gaming motherboard.

I have a Asus TUF X570 Gaming Pro WiFi motherboard that seems to use the same BIOS as your motherboard. I am on BIOS version 2802 and will now update to BIOS version 3001 which you indicated is stable.

All BIOS  Settings are on "Default" except I have my RAM O.C,. to match my RAM Speed of 3600Mhz.

I would avoid updating to any BETA BIOS versions since they may be full of bugs and even Asus Support doesn't recommend to do so.

My Ryzen 3700X idles and under loads runs between the mid 40C to around slightly higher than 60C (CM Hyper212 EVO) which is fine with me since it is way below the 95C Max. Operating Temp.

When I stress test the CPU using OCCT is never goes above 62C.

Note: I recently upgraded my PC from a AM3+ Motherboard with a FX8350 processor to the AM4 X570 Motherboard with a Ryzen processor. Which is why I haven't updated the BIOS since everything seems to be working fine but a little slow at times.

No worries we all need to share our experience right! So the issue I had I was on an outdated BIOS which was working fine and I know they say “don’t update BIOS if your build is working fine” but I seen I was out of date by like a whole year so I decided to get up to scratch, I jumped from an early 2020 BIOS to 2021 Feb update 3405 which weirdly IS NOT A BETA VERSION but caused so many problems!

I have also contacted ASUS regarding this BIOS update for the board to find out what’s going it down to the AGESA or is the BIOS just not optimzied for the 3000 series CPUs due to 5000s being there main focus right now? I don’t know but I don’t think you can roll back once you’re at the 3001 stage either as I tried to go back to where I was before and wouldn’t even go under I could only go from 3405 to 3001...very strange and some are having the issue of what I’m having but with the the 5950x restarting randomly etc. 

it’s very strange trying to pinpoint the issue..I have to do more further tests regarding to the CPU itself as I used EZ Tuning to set up CPU and selected Game Mode, and AIO cooler etc. And it automatically configures it but because it’s turns voltage down and clock speed up with boost off it becomes more stable and cooler for gaming, if I leave stock it sounds like a plane about to take off at 55 degrees but I know I can’t adjust the fan curve etc. 

something to look into but need to find out what exactly went wrong and where? Is it down to the BIOS or an AGESA or what?

Just updated my motherboard's BIOS  version to 3001.

Unfortunately I had no video output again like the first time I powered up my pc after new PC built.

Luckily I was able to get video on my HDMI connected Smart TV and found out that BIOS "default" for my motherboard is UEFI Mode which is incompatible with my LG monitor in the respect I have no Video Output until Windows starts loading up. Then I have video output.

Changed it back to CSM Mode (Legacy) and I had video output on my PC Monitor again during POST. Asus Support did mention that all Asus motherboard needs to be on CSM Mode for best compatibility.

Also found out that Asus DOCP is buggy and doesn't work well. I enabled it for the first time and my computer wouldn't boot up. Finally after several times it booted up into BIOS again and I disabled DOCP and enabled RAM Speed to 3600Mhz and FLCHK to 1800Mhz like last time and had all other RAM Settings on Auto which switched to the proper timings for my RAM like DOCP did except no problems with booting.

Also found out, like you did, that I can't revert back to previous BIOS Version 2802. I tried using my Motherboard's USB FLASHBACK feature and it blinked 3 times which means the feature is enabled but it didn't update or downgrade the BIOS version installed. But it did give me video on my Smart TV set that I didn't have before.

I used Asus EZ Bios update which it seems it not the best method to update the BIOS on my motherboard. The USB FLASHBACK seems to be better.

I had the same issues...I tried DP and it’ll display, then turn off then display again..very weird!


I’ll have to check out the CSM mode for sure I can’t find anywhere with any tips or tricks with Ryzen and this current motherboard..not many people reporting bugs or issues?

I don’t know if once you go to 3001 or above bios you can’t flashback before than? It’s all entirely confusing if I’m honest! I haven’t had a chance to dig deeper into my issues but last time I tried it booted as normal only with the display being very buggy by turning on with boot; then off then on? I’ll try Display Port again and CSM! 

Make sure your chipset driver is up to date also?!


Yes I find it strange too that I couldn't downgrade my BIOS version. Normally in other Manufacturer's BIOS download page it will mention if you are able to downgrade or not to a previous BIOS version.

At Asus BIOS download page it doesn't mention anything about not being able to downgrade and install a previous BIOS  version.

My 4K LG Monitor is connected via DP which I had no video during POST when UEFI mode is enabled. I also have no video with HDMI connected. Only my 2k Samsung Smart TV has video with HDMI connected directly to my GPU card.

But once I disable UEFI Mode and enabled CSM Mode I got video on my DP port from my 4k LG Monitor.

My LG doesn't have a feature where I can run the Monitor on 1980x1080 Resolution manually which might be the reason why I have no display during BOOT and only works on CSM Mode.

NOTE: Chatting with Asus Agent I mentioned if the BETA BIOS difference from the regular BIOS was the AGESA Patch b & C. He said that was the only difference between the BETA and Regular BIOS.

He also recommended not to install BETA BIOS since it was buggy and not stable.


Very strange indeed; keep me updated in your findings I’d love to find out what exactly to do as with me my monitor is a AOC AGON 24inch 1440p and tried both DP and HDMI BUT with me it shows post, all the way up until the Windows log-in where it  where it goes black for a second then back to normal...very confusing but next time I get a chance I will check the CSM Mode..I never turned it off so surely it should be on? 


My previous AM3+ Asus Motherboard I had my Windows HDD set for MBR which is Legacy or CSM mode in BIOS. But with my new AM4 Asus Motherboard I converted the Windows HDD to GPT which is UEFI Mode in BIOS.

So whenever I install a BIOS Version it will automatically enable UEFI Mode since that is what my HDD is set for. So now I will need to go into BIOS and disable UEFI Mode and enable CSM Mode which is also compatible with UEFI Mode.

Possibly if I get a new Monitor it will be compatible in UEFI Mode during BOOT and I will have video. But this LG Monitor is fairly new.

Could also be your GPU Card causing the problem.

The Asus CPU SUPPORT LIST just mentions the minimum BIOS Version you need installed for a specific Processor to be recognized and able to boot up with your motherboard.

In this case the R7-3700X needs BIOS version 706 installed.


Yeah I figured that; I’ve got a 2070 Super tho and only owned it since November 2019 and hasn’t had much use on it really other than gaming...temps look all fine and once it’s running it’s perfectly fine it literally is on first boot when monitor turns on for the first time like it’s adjusting and finding the’s only started since BIOS update so it’s very confusing! 

Im not sure as if you are having the display issues to may be similar? Also my OS is on an M2 so not HDD used unless it’s for games or storage


Your SSD can be either MBR or GPT. Most likely it is GPT so it is UEFI Mode in BIOS.

If your SSD was MBR Partitioned it wouldn't boot if BIOS is in UEFI Mode. It would need to be in CSM Mode to boot.

But Asus CSM Mode is compatible with both MBR and GPT Partitions.

In my case, my HDD is GPT and in Windows it says it is UEFI Mode compatible even though I have it set for CSM Mode in BIOS.

Note: I have a Nvidia GTX1070 GPU card.


Although BIOS 3405 isn’t a BETA it’s a full release?


It also states via the 3700x that the latest BIOS recommended is 3405 also?