Showing results for 
Search instead for 
Did you mean: 


Journeyman III
Journeyman III

Is X370 chipset a terrible platform or is ASUS implementation completely @$^*&%#!?

First of all I don't expect the issues to be solved, however I will be pleasantly surprised if it turns out otherwise. I believe the issue is bad hardware (not a specific motherboard, but the chipset in general) and the issue would have to be fixed by either AMD (if it's bad design) or ASUS (if it's bad implementation). I've reported the issues to ASUS months ago and they have done NOTHING. Their support is useless. And that's for all the cases that I ever opened with them. No surprise here. I only want to report the issues to AMD in the case somebody from engineering cares to investigate and fix them.

So, I've bought ASUS ROG Crosshair VI Hero motherboard several months ago to have a 8 core platform on the cheap and I regret doing this. The first motherboard sample was without Wi-Fi and the second one had that built in. Both had exactly the same issues, so it wasn't a bad motherboard. Here is the motherboard review that I posted and it describes the issues in detail. Sorry for being blunt, but sugar coating serves no purpose.

Stay away! It looks good on paper, but the implementation of certain features and even basics like SATA is horrible. I blame this on the AMD X370 chipset more than what ASUS did, but their support is useless, so if really want the same platform (think twice!), get it from a different vendor.

So, initially I thought this would be a great platform, but soon I regretted the purchase. The CPU has the potential (8 cores, 16 threads) for high end systems, but the accompanying chipset has so many issues (I believe that issues come from poorly designed chipset) and ASUS support hasn't done anything in months to resolve the issues. I'd hoped that they would reach out to AMD, present the issues and work with them to address the problems. I had hoped that AMD would fix the chipset and ASUS would have another version of the motherboard that they would give me as a replacement under warranty. Nothing like this has happened. Mostly canned responses to the cases I've opened with ASUS support that help nothing and only indicate that they have zero understanding of what the issues are. For example one response to the RAID controller issue (more on this later) was "For RAID install IRST driver". IRST driver? Really? IRST is Intel Rapid Storage Technology and this is AMD and not Intel based board. There is no Intel chipset on this motherboard that IRST driver is needed for. That's how lousy ASUS support is. They have no technical understanding whatsoever, so they read from some script and give canned (and mostly completely irrelevant) responses.

So, let's hear about the issues. First the aforementioned RAID issue. The RAID implementation is horrible in the chipset. There is no option in the BIOS to assign only certain SATA ports to the RAID controller and leave others in AHCI mode. It's either all ports in AHCI mode or all ports in RAID mode. So even if a drive is not part of a RAID array, but hanging off the RAID controller (shown as legacy drives in RAID setup), it's somewhat shielded from the OS by the RAID driver. I have 2 spinning disks in RAID0 array, so all remaining drives that are not part of any RAID array still have to go through the RAID controller. For example Samsung Magician, which is an application to control Samsung SSD drives, can't properly communicate with one of the SATA drives (Samsung 850 EVO) that is not part of any array due to this ridiculous requirement.

Worse, the optical drives are also hanging off the RAID controller and due to a bug in the RAID controller firmware I can't boot in non-UEFI (legacy) mode to install Windows on MBR partitioned disk. When I switch SATA mode to AHCI (and lose the RAID array then) there is no such issue. Both, legacy and UEFI boot modes work. This is an obvious problem with the RAID controller (firmware issue), but ASUS support instead of reaching out to AMD to have the firmware fixed, sent me among other tips the one to install IRST driver. Shame on you ASUS support!

Then there is USB issue, or actually 2 different issues with USB implementation. The first one I've noticed was that when I was running a daily backup to USB 3.0 drive that was connected to USB 3.0 port on the motherboard, almost every time ALL (yes all, USB 2.0 and USB 3.0 ports) were disappearing from the OS. At that time the backup was obviously failing, but also I was losing control of the system as my keyboard and mouse are USB ones connected to USB 2.0 ports. Using remote control software I was able to get on the system and confirm in the Device Manager that Windows didn't see any USB 2.0 or USB 3.0 ports anymore. And that was pretty much a daily event. The only recovery was to reboot the system.

Also, when I was imaging my system partition to a different USB 3.0 drive I was getting tons of errors related to file system or disk operation in the event log. The ports for some reason were not disappearing from the system, but the images were failing MD5 checksum making them completely unusable. So, 2 different operations (user data backup and full partition imaging) to 2 different external USB 3.0 drives, however both connected to USB 3.0 ports on the motherboard were failing. That couldn't be a problem with drives or their cables as ASUS support has suggested. Especially that both of them were working fine connected to my old system. So, I took out a Fresco Logic chipset based USB 3.0 controller from my old system and installed on the new motherboard. Then I moved the USB 3.0 drives from the onboard USB ports and plugged them in to the ports on that controller. Voila! Problem solved. No more disappearing USB ports, no more failed backups, no more errors, no more failed MD5 checksums. However ASUS support can't grasp the idea that this was a PROOF that the problem wasn't with the external drives, but with the USB implementation in the AMD chipset. They did nothing. Well, they asked me to contact AMD. Excuse me?

But wait, this is not all that's wrong with USB implementation. In addition to issues with USB 3.0 ports there is something wrong with USB 2.0 ports. I couldn't use an old multifunction printer that I have for either printing or scanning with USB connection. Just seconds after either operation started the system was losing connection to the printer. And the memory card reader in the printer was disappearing and reappearing in the system every 2 to 3 seconds constantly. I had to disable it in the Device Manager. Again, all of those problems went away after moving the printer connection from USB 2.0 port on the motherboard to USB 3.0 port on Fresco Logic based controller.

And if somebody thinks that this could be a problem with just individual motherboard sample I have a spoiler. Before I found a workaround with the Fresco Logic based USB controller I had the same though, so I returned the first board I've bought to Amazon within 3 weeks or so and I've got another one. The second one (for which I'm wring this long overdue review) has the built in Wi-Fi, but the first one didn't have this option. Guess what? BOTH have the same issues, so it's not an individual sample that was bad.

To summarize, the terrible design of RAID support and the serious issues with USB implementation disqualify this motherboard. I'd hoped that I'd have a high end system on the cheap. Well, you've got what you've paid for. How true.

I forgot to mention in that review that with this SATA implementation there is no hot plug-ability in RAID mode. Another shortcoming that I've fixed by installing a SATA controller in PCI-E slot. So, for all those issues I found a workaround. Except one. There is a BSOD when cold booting (after powering up), but not after warm boot (reboot) and the implicated driver is rcraid.sys (AMD driver for RAID). The error message on the BSOD is DRIVER POWER STATE FAILURE and the messages from the debugger from the BSOD dump file (if that matters):

BugCheck 9F, {3, ffffb20ca97c0060, fffff801e3e5b8f0, ffffb20cb83c46e0}

*** ERROR: Module load completed but symbols could not be loaded for rcraid.sys

Probably caused by : rcraid.sys

This crash is a daily event except a very rare occurrence (actually happened this morning) when the system booted up without a crash from the power up. Normally, the system crashes the first time after powering up, then takes a memory dump, reboots on its own and then warm boots just fine. I'll report the driver issue in the drivers section as well.

I really hope that somebody from AMD development dept. reads the forum and will take the issues presented seriously as I believe these are design issues and not just botched implementation of the X370 chipset by ASUS.

To summarize, the issues reported are:

1. Horrible SATA implementation where all ports have to be either AHCI or all ports RAID.

2. No hot plug-ability in RAID mode.

3. RAID firmware bug preventing booting from optical drive in non-UEFI mode.

4. All USB ports disappearing from Windows when backing up or imaging to external USB 3.0 drive.

5. Unable to scan or print to Canon MX850 printer using USB connection.

6. BSOD in the RAID driver on cold boot.

Sorry for this extra long post, but these issues are serious (to me at least).

0 Kudos