Showing results for 
Search instead for 
Did you mean: 


Journeyman III

I need serious help...Ryzen 5 3400g...memory issues

Here is my issue, I really hope some one can help, This started December 2019. My wife got me all the components for a new build for Christmas.

Everything was going fine for a few months, when I started having memory issues. I thought it might be bad ram, So I replaced my original Crucial Ballistix Sport LT 3200 MHz with Corsair Vengeance LPX 3200 MHZ. Within a day or two memory issues again. To make this short, I found out it might have been a BIOS issue. So I rolled back the BIOS to the last one I knew worked which was version 7C37vA7. No issues since then, for the last few years everything good.

Two weeks ago I decided to get froggy and update the BIOS to the most recent Version 7C37vAI. Everything was fine until today. My daughter was playing SIMS 4 and the computer blue screened with a SYSTEM_SERVICE_EXCEPTION error. This was the error from a few years ago. So I thought great this sucks, I'll just reflash 7C37vA7 and be back to good. However after flashing I tried to enable XMP to get 3200mhz the system now crashes on boot, and resets the RAM to 2666mhz. I cleared the CMOS and re-flashed 7C37vA7 again, the XMP still won't take, also manually setting the RAM to 3200 and Memory Try it won't work either.

After I was able to get the PC to boot again with stock ram and bios settings I went to bed, over night the pc crashed and did not have a log file or bsod was just frozen. Rebooted again did some errands came back to a froze pc again.

Later on today I I decided to try resetting the CMOS again, but instead of using the jumper, I just pulled the battery and let it sit all day unplugged. Once I was able to get back into the BIOS I was able to enable XMP and it booted fine. I was also able to run 10min of Cinebench and 10min of AIDA64Extreme stress test. Rebooted and instantly blue screened SYSTEM_SERVICE_EXCEPTION NTSF.SYS, after rebooting from that got Page Fault in Non-Paged Area blue screen. After rebooting from that, it rebooted 2x and reset ram again to 2666mhz, and while typing this update the pc just randomly rebooted no blue screen.

Noticed something weird as well, when it reboots it's turning on the IGPU even though it's disabled in the BIOS, not of the other BIOS setting other then XMP are restting, and my current GPU seems to work fine.

Any ideas what I should try next?

What could be Wrong?

CPU: AMD Ryzen 5 3400G 3.7 GHz Quad-Core Processor

Motherboard: MSI MPG X570 GAMING PLUS ATX AM4 Motherboard
Memory: Corsair Vengeance LPX 16 GB (2 x 8 GB) DDR4-3200 CL16 Memory

Storage: Samsung 970 Evo 500 GB M.2-2280 PCIe 3.0 X4 NVME Solid State Drive

Storage: Western Digital Caviar Blue 1 TB 3.5" 7200 RPM Internal Hard Drive

Storage: Western Digital Caviar Blue 1 TB 3.5" 7200 RPM Internal Hard Drive
Video Card: Gigabyte GAMING 8G Radeon RX 590 8 GB Video Card

Case: Fractal Design Focus G ATX Mid Tower Case
Power Supply: Corsair RM650x (2018) 650 W 80+ Gold Certified Fully Modular ATX Power Supply
Optical Drive: Asus DRW-24B1ST/BLK/B/AS DVD/CD Writer

Operating System: Microsoft Windows 10 Home OEM - DVD 64-bit
Generated by PCPartPicker 2022-11-20 22:41 EST-0500

0 Replies