Showing results for 
Search instead for 
Did you mean: 


Journeyman III

I have a Ryzen 7 3700x and am having RAM issues.

I can only install one stick of RAM. I am using GSKILL Ripjaws 16 gig 3200. I keep getting a C5 Q Code on my ASRock B550 TAICHI motherboard. I also tried using Corsair Vengeance PRO RGB 8gig x4 with the same results. I can put one stick in A1 or A2, but cannot put any more than that or I get C5. Sometimes it will stop at F9 then go to 0d QCode. No post at all. I've tried all sticks individually and they all work. Is my CPU bad? Thanks for any and all help. 

1 Reply

First big question is are both those sets of ram on your motherboards QVL list as compatible with the board and the CPU you are using?

Second, are you running at "Bios Defaults" and this is happening or does this only happen if you for instance turn on PBO or XMP?

Next does one stick work no matter which stick it is as long as it is in the 1st slot?

I would talk to AsRock about the problem and see what they think you have going on. 

You certainly would not be the first to complain of going to 4 sticks being problematic. Why some boards have issues is beyond me but if that proves to be the case and you are using QVL ram then they either owe you a board that works or your money back. 

They should however be able to help you figure it out. If worst comes to worst you can just demand an RMA of both CPU and Motherboard if necessary. 

If this is a new build that is in its return period then get ram that is on the QVL if it is not already. It your ram is right then exchange the board and or cpu if you can without going through RMA hassle. 

If you end up asking for an RMA AMD will void your CPU warranty if tell them you used XMP, PBO or manually overclocked.