Showing results for 
Search instead for 
Did you mean: 


Adept II

How do i enable smart access memory for my system?

So I recently bought a new Radeon GPU, I bought Powercolor Red Devil RX6700 xt. I do have a Ryzen 7 3700x with a Asrock B450M/ac R2.0 Motherboard. I have been trying to enable Smart Access Memory, but it will not enable. I have updated the BIOS and when I enable 4g Coding and Resizable Bar in my BIOS and disable CSM it will not boot to Windows it loops back to my BIOS.

I am a little confused, as for my BIOS has multiple versions of the required patch, is there a certain version i should download to have SAM enabled for my system or do I need to get a MOBO that has the SAM access feature already in the BIOS. Some clarification on this will help me so much. Thanks


3 Replies
Adept II

It could be because Windows has been installed in Legacy mode, instead of UEFI, and therefore needs CSM to load. I've just upgraded to Windows 11 and had to format disk to GPT, as the previous Windows 10 was on an MBR disk. I had  exactly the same problem.


Well a friend sent me a link and helped me get through. I went ahead and updated my board as well I feel that the board was outdated anyways. I got a MSI B550 MAG Tomahawk. I never knew that Windows had this tool mrb2gpt, not sure how long its been there but man if thats all i had to do to get SAM to work then my new board is a bonus. thanks for the reply 

Community Manager

Information here on the requirements and how to enable Smart Access Memory.