Showing results for 
Search instead for 
Did you mean: 


Adept II

Help! No post with Aorus Ultra x570 and to 3900x

Just like the title says, and I keep trying to get ANY KIND of BIOS to just work, or for that matter to at least act like it's being installed.

I keep thinking I'm just really stupid and am missing something, like maybe not doing it right or using the wrong bios or something else.

The lame videos out there always just skim through this tricky part and just tell you to update BUT NEVER actually say which thing to update.

They make out like you just go to the mobo site and download the BIOS file and simply install using the little button on the board.

But then when you get to the mobo site there is like a dozen or so bios updates.

I find myself just guessing from that point on.

AND the tutorials always show them using just ONE file, yet the bios zip always comes with like 3-4 files in them.

If you aren't supposed to use them other files then why are they there?

None of this makes sense and I'm still sitting here with all my killer new system and not being able to use it.


1 Solution



I just moved the card to the other slot and all of a sudden I see the screen pop up and doing something!!!

It's telling me to NOT turn the power off and is somehow doing a BIOS update.

Must of stored the BIOS stuff in the board some how.


You all can take a look at the BIOS as it stands right now and if you have any thoughts please feel free to let me know.

Image Link bellow: (soon to come)



So was up in the middle of the night, but got the OS installed and am in the process of updating everything as well as getting a few basic apps installed.

Then I can just put it all in and be done.

I'll be sure to post a final image of my awesome new system.

Thanks again for everything guys.




View solution in original post

39 Replies

No need to update the BIOS at this time since according to Gigabyte Support CPU SUPPORT LIST the original first BIOS version for your Motherboard supports the 3900X Processor which was F3:

AMD Ryzen 9 3900X 12C/24T 3.8GHz / 4.6GHz 6MB 64MB N/A Matisse 7nm B0 105W F3


So your processor should work on your motherboard out of the box.

What Motherboard Trouble LEDs or Digital Codes are showing?

When you power up the computer is the HDD/SDD LED light, in front of your computer case, flickering or on steady all the time? If it is it indicates the computer is booting into Windows but without Video Output.

How is your Monitor connected to the Computer?  To the GPU Card or to the Motherboard?

If it is connected to the Motherboard Video Output you won't have any Video Output during post since your processor isn't a APU or processor with Integrated Graphics installed.

So your monitor must be connected to the GPU card in your computer.

NOTE: The BIOS Download does come with more then one file. But generally one file is to convert the BIOS Version to work and be recognized by the motherboard.

I download the latest BIOS version for your Motherboard and extracted it using 7-Zip:

Screenshot 2021-03-24 172051.png

The file with the check mark is the actual BIOS file to install. The EFIFLASH.exe is the program used to install and update the BIOS.

You need to read the README.TXT to see what procedure you need to prepare the BIOS to be installed and updated on your motherboard.





Hey thanks for replying, I was really concerned I might have to wait a long time for an answer.

Basically, yes I know about most of what you mentioned, i.e. I know I need a graphics card and I, at the moment, only have my old card which is an old nvidia card but it should work just fine for now.

The sad thing was I never found out about that the board came CPU ready till I had already started to try BIOS updates.

So not sure if I ruined things now or not, though I don't see how, since you should be able to install what ever update you want as many times as you want in theory.

I currently don't have any OS installed cuz it's a new nvme card and I assumed I would be able to do like normal and just install once the thing got going, but maybe I'm wrong on that?

I am connected to my monitor via the HDMI port from the card, not the board as I am aware that this CPU does not have APU.

The only lights I see are the CPU light and it isn't blinking just stays on red.

Only once have I ever managed to see the qflash light ever come on while trying to get a bios to install and it only blinked for maybe 5 or so seconds.

I do the renaming deal they tell you to do, to GIGABYTE.BIN and I've read the little text file.

I haven't noticed any light at all for a HDD but maybe I just didn't think to thoroughly check my front panel lights, but I will now.

The front panel power button used to be able to turn OFF the power when I started things but now can only turn things on, not off.

While in the early goings I originally ONLY seen the VGA LED light on and not the CPU light.

But once I got the graphics card in then things changed to only showing the CPU light on.

I don't think it was anything to do with the card but me updating the bios thinking I was supposed to.

I have to say, they sure do leave a lot to your imagination about what to do on that site.

P.S. When I did actually see the BIOS light come on, was when I decided to first press the qflash button and while holding it down I THEN powered up the system.



Try Gigabyte support and start an RMA now. 
You are likely in for a bad experience though.
I would not go near Gigabyte for anything. 

Which revision of the Motherboard do you have?

Try a different CPU in the motherboard if you can. 
Buy an Asus motherboard instead.
Good Luck. 


BTW, there wasn't any text file to read with the f3 file, so that was why I was just guessing on things.

I'm on rev. 1.1 is what it says on the mobo.

As for Gigabyte, I thought it was a good choice since it's what I had several years ago until I went to an EVGA motherboard, which was awesome but they don't do AMD. But my old Gigabyte mobo was truly a great board and really flawless and in fact what was my base guide for my EVGA board.

So I "thought" they would still be a great board, but wow, I never had any of these issues whatsoever.

Guess I'll be calling Amazon today for a refund.

Uhg, and I had everything sooooo nice and setup clean and tidy and all.

Okay well thanks for the help, I'll be sure to come back here with whatever I do that gets this working.




Yeah I've reviewed that video, doesn't much help though for my problems.

I am working on some other solutions and I will for sure get back here to update.

I had bad thoughts it might actually be the RAM, I took it to a shop and he came back with the same thoughts and someone else I trust for this kind of knowledge also had the same thoughts.

I bought 3600 RAM and nothing says it supports that.

It DOES however say it will support 3200 RAM and this is what the CPU also claims it uses.

So new RAM comes in tomorrow and we'll all find out then.

Fingers crossed.



So, gonna return to Amazon, which is a lot easier to do then a RMA.

So I have to go with Asus?

MSI is no good too?

Most of the Asus boards I'm looking at for the same budget look really ugly to me or too much chrome on them.

Or none of the boards I'm looking at seem to have as many nice features as the Gigabyte board does.

That's what really annoys me too.



I purchased the Asus TUF GAMING X570 Pro (WiFi - $220.00) and going by the specs between the Gigabyte Aorus and Asus I believe the Asus has comparable specs but Gigabyte might have a more powerful VRM and maybe some more features though:

My Asus has the following specs:


2-BIOS FLASHBACK button (No CPU needed to update BIOS)

3-WiFi and Bluetooth

4-Supports the latest 5000 Series CPUs

5-4 PCIe Slots

This board came out In September of 2020.

Just thought I give my Asus motherboard a little advertisement since you mentioned about getting a Asus Motherboard.


Hey, thanks trillions, and I have started the return process.

So maybe by the end of the month I can have my new stuff.


And yes, that actually is one of the boards on my list.

Now that I have to wait, it gives me some time to mull things over more.



Yes, your board supports 5000 series but the upgrade path is one gen limited as the next gen AMD is expected on a new platform. Going from a very powerful 3900X to an equally powerful, but slightly faster, 5900X will have limited noticeable impact on your current experience unless you do specific workload tasks to make money and getting done a little faster matters. Generally a one gen upgrade in CPU speed matters little unless additional cores are needed for multi-tasking, content creation, rendering, etc..

That board has dual BOIS backup, why not revert to the original good BIOS using that before an RMA? You should easily be able to find instructions on resetting the original BIOS from the onboard backup BIOS chip. Messing up a BIOS update is so common most boards have the dual BIOS fail safe these days.


Good luck.


Okay, this was some truly awesome info.

I thought I might be able to try the BIOS reset but couldn't seem to find any info on it.

Can you please maybe give me some clues as to where and how to do such a thing?



I was looking at your Aorus Manual and couldn't find anywhere to run manually the Dual BIOS on your motherboard. From what I read the backup BIOS on your Motherboard runs only when it detects that the current BIOS is corrupted. When you reboot it will automatically run the Backup BIOS on your Dual BIOS motherboard.

But normally, I believe, the Backup BIOS is the Original Motherboard BIOS version that came with the motherboard. So if the Backup BIOS doesn't support your Processor you will need to update the regular BIOS version.

From Aorus Special Features PDF:

Screenshot 2021-04-21 073647.png

Gigabyte does have a very recent BIOS update:

Screenshot 2021-04-21 073647.png

Your Motherboard has Q-FLASH Plus which is the same as Asus BIOS FLASHBACK button on Asus Motherboards.


Yeah, I seen all those BIOS updates but to be honest, I could never really tell which one I was supposed to use?

I mean they don't exactly explain any of that there.

And if you follow the video tutorial they have, it of course doesn't tell you ether.

And the video tells you to actually delete all but the one file and then to rename it.

None of this makes sense.

Why don't they just give it the right name in the first place?

And am I supposed to first do something with the files on another computer using the exe and bat files or something else or what.

None of these things are made clear.

I know I was told to read the readme file, but again, I can't make heads or tails of it.

Thanks BTW, the help here has been ten trillion times better than the so called help I got from Gigabyte so called support person.




There should be a CMOS reset on the board. It is two pins that look like fan pins. Usually they are on the lower right side of the mobo. You will need a metal object like a flat head screwdriver or a coin to touch both at the same time. When you are ready to do this:

Turn off the system, then unplug the power supply. Then push and hold the power button on the case until you see the fans spin a sec or the RGB to flash a sec. They may not do anything but push and hold it down a few seconds anyway. This drains all power from the board. Then touch the two pins at the same time with the metal object. If for any reason you cant find the pins you can take out the round battery that looks like a quarter instead and then put it back in. This should reset to a good BIOS. Power back up ad you should have a fresh original BIOS.


Updating BIOS should not be done unless your totally secure doing it. It may take you some research time to learn for certain.

Doing what I say here is at your own risk. Otherwise, seek outside help. This is the number one reason boards go to RMA.

I always use the latest BIOS out and that is the norm but only if you need to. Some BIOS are for specific issues that may not include something your system needs so read up on what the new BIOS is for. If you don't need anything in it it why risk update from a perfectly working BIOS?The file to use should be the only one in the folder to have the BIOS number as the file type on it. I believe the latest BIOS is F51a for Gigabyte at this time and it should look something like this:


Notice the file type is the BIOS number. 

The other files will be .exe or .BAT or some other type.

I have always done my BIOS updates in Windows using the Gigabyte @BIOS app in Gigabyte App center. Not sure if that is an option for you but if it is just make sure you unzip the BIOS download before you use the file I have shown above in the @BIOS app.

@bodasactra  Actually updating BIOS via Windows is probably the most risky way of updating.

The reason why is that too many things can go wrong, like the computer freezing or crashing or interrupting the BIOS update. Granted doing the BIOS update via Windows is the easiest way but also, in my opinion, the riskiest way of updating BIOS.

Best method is using the Motherboard's Q-Flash Plus and second method is using Q-Flash.  Less chance of the computer interrupting the BIOS update.


Yes, it s the most risky. That said, I have done all my BIOS updates in Windows for near15 years and never once had a failure. Must have been near 50-60 BIOS updates not one problem.


Thanks for the info guys.

I had tried the pulling the battery out method but still nothing seemed to change, but with the better understanding now about which and what BIOS to use, I'll give things a try again.

That said, ANYTHING involving Windows doing anything is obviously out of the question, since of course I can't even get it to post in the first place and it's all brand new and I haven't even been able to get to the installing Windows stage yet.

I'd love to just see the BIOS screen show up.

I'd love to NOT see the stupid little LED light go on for the CPU every time I power up.

Okay, hoping this last attempt works for trying to reset the BIOS and see what ever.

**bleep**, I have to say, my experience with Gigabyte years ago was COMPLETELY different than it has been this time around.



And my apologies to the group for the **bleep** word there.

I didn't think the word I used was a bleep word lol

I'll know next time






Hmmmm.. well for the very first time, I got to see the little BIOS light DO something.

I pulled the mobo out of the case and tested things and still the same story, but then I pulled out the CPU and memory so that all that was left was just the mobo and nothing else installed.

I only plugged in the 24pin power connector and only one 8pin (did not use the optional extra 4pin next to it).

Then I took the USB stick with the only file being the one from the F33 BIOS that I had renamed to be GIGABYTE.BIN and stuck that in to the proper spot and powered on the PWS and while holding down the little qflash button I manually turned things on with a screwdriver.

To my amazement, I seen the 4 tiny LED light set blink for a second on the CPU spot and then went off and the memory light came on and at about this point the little qflash button LED began blinking and this went on for a couple of minutes or so and near the end it blinked a little faster and then it self powered off.

Is this all what I should have expected to see?

Also, yes, I forgot to mention that I did indeed touch the two wires on the clr-cmos and held that that way for several long seconds before doing everything else listed above.

I won't proceed any further by putting the CPU or anything else back in till I hear from you guys.



Not sure how Q-Flash Plus works but seems to be similar to Asus Flashback BIOS button.

For my Asus Motherboard Flashback BIOS feature, all I need to do is have power connected but not on. Then install the USB Flash Drive with the new BIOS in it after being renamed in the special USB BIOS UPDATE Port. I don't need to remove any hardware from the motherboard.

Then I simply hold the Flashback BIOS button for about 3 seconds. The Flashback BIOS LED Light flashes 3 times then starts flashing steadily until the flashing stops.

Once it stops the new BIOS is installed. I then hit the Power the power on button to start booting up. Once I see the POST and BIOS screen I then enter BIOS and check to make sure it is the one that I wanted to install and then I set whatever BIOS Settings I need to set up.

That it.

Gigabyte Q-Flash Plus might be slightly different but it seems like it did install the BIOS you had. You can Reassemble the computer again and power up and see if you can enter the BIOS Menu and check to see if you have the correct BIOS installed.

Found this website that shows you the steps on using Gigabyte Q-Flash Plus feature:

Screenshot 2021-04-21 073647.png

Well it seems you followed the directions correctly.  So boot up and see if the new BIOS is installed.

NOTE: Take a look at the YouTube video on the link and it will show you how it looks when Q-Flash Plus is working correctly.


Okay, guess I just haven't been being clear, sorry.

Like I've said at the start I've already done TRIED to do all what you just said, of not taking things out and just doing EXACTLY as the methods told me to do and as you just reiterated again, but like I've mentioned the BIOS would never do anything.

No blinking light no acting like something was happening no didly squat.

So since things have been NOT going in a good direction I was taking things apart anyway to return and thought I'd give the BIOS deal one more try before I shipped everything back.

So, was that the normal amount of blinking time and kind of blinking to expect?






Oh and thank you very much and the others as well for all the help here.

I wanted to make sure you guys know this.


Well, sadly when I put the RAM back in and the CPU and the heatsink and turned it on, the CPU light went right back on like I hadn't done a thing.

Should I just try every stupid BIOS they have listed on the Gigabyte website and just hope one of them works?

I'm actually just at the burn out stage and don't see any signs of life coming any time soon.

Guess now I also need to send the stupid CPU back as well, since I have no real way to confirm anything about anything.



were you successful in updating your BIOS using Q-Flash Plus?

Do you have the correct BIOS version installed?

I  wouldn't update or mess with the BIOS anymore. But you need to check which version you have installed. If by any chance the update failed and corrupted the current BIOS, the Motherboard might be using the Backup BIOS which is the Original BIOS version when you purchased the Motherboard. If the original BIOS Version doesn't support your Processor then it wouldn't boot up. So you would need to use Q-Flash Plus again to install the correct BIOS that supports your Processor.

Yes, when it comes to the computer not booting up the best method is to RMA both CPU and Motherboard unless you have the time to wait for each hardware to be replaced. But in doing so the other hardware might go past the Return date but if RMAing then you can wait but you will be out of the use of the computer.

Before you RMA the CPU or Motherboard I would open up a Gigabyte Support and AMD Support ticket and see if they feel you need to RMA the Motherboard and the CPU.

Otherwise replace both at the same time it is the best method since you don't know if it is the CPU or the Motherboard that is defective.

NOTE: When you updated the BIOS using Q-Flash Plus did it look the same as the YouTube video when you were flashing?

When I purchased my first Asus Motherboard (DOA by the way) when I tried to use the BIOS Flashback button it would flash 3 times telling me the feature was enabled but it would never start flashing continuously indicating that it is flashing the BIOS. So the motherboard was defective and I sent it back.


When you power up the PC there is no video output correct?

So you can't tell which BIOS version you have installed until you are able to get Video Output from the GPU.

What Motherboard Trouble LED lights are lit and or Motherboard Trouble Digital Code is showing?

Are all the fans except possibly the GPU fan running?

When you power up the PC, Does the HDD/SSD Computer case LED flashing constantly or on solid?

If the HDD/SSD Computer case LED is flashing or solidly on that indicates that it is booting up into Windows. If the HDD/SSD LED comes on than off and stays off than it isn't booting up.

Try connecting your GPU to another Monitor or Television and see if you get video Output.

When I upgraded my computer to a Ryzen PC I had no video output on my HD Monitor. But later after hours of troubleshooting I found out that I can get video output to my Smart Samsung Television. Thus I was finally able to enter BIOS to get my PC Monitor to work. Just an example.

Of course this was after I replaced both my CPU and Motherboard and took my GPU and PC to a Computer shop to see if my computer would boot up with video output.  At the computer shop when the tech hooked up my GPU card it immediately had video output. So I knew my GPU card was good. Then finally I took my entire PC computer case and the Tech hooked it up and it also had Video Output.  Now I was positive my problem was with my Monitor thus using my Television set to test my PC video output.

Luckily the computer shop tech didn't charge me anything just to check my hardware to see if it booted up or not.


It's always just the CPU light and when I had everything out of the board, and after I did the F33 BIOS and it looked like it worked the board powered off.

Now since all that "appeared???" to have been successful I assumed it was.

But after reinstalling the CPU and memory then it just went back to showing the CPU light.

And I am referring to the code lights on the board.

I will try some of the other things I just read here and see if there is any luck.



One way to eliminate the Motherboard or the CPU is by installing another Processor in your motherboard. If it boots up then you know the CPU is the problem if it doesn't boot up than it most likely the Motherboard.

You do have the CPU Power (8 or 6 Pin Power connector) connected correct?

Your RAM is listed as being compatible with your Ryzen and Motherboard right?

Also try to boot up with just One RAM Stick installed until you are able to boot into BIOS.

EDIT: So basically the computer doesn't boot into BIOS and gets stuck with the CPU TROUBLE LED lit on.

Try booting up with just the CPU and Motherboard with no other hardware installed. If it stops with the RAM TROUBLE LED lit that would indicate that the CPU and Motherboard is passing POST test and it is some other hardware causing the CPU Trouble LED to light up.

If it stops at the RAM Memory Trouble LED then install just ONE STICK OF RAM and see if it boots into BIOS.


Not even the cooler heatsink?

Which BTW is the really cool one that came with it.



Sooooo, okay, get this, maybe things are going to work after all..

I did what you said and put the stuff back in and I touched the pins to power up.

It did and THIS TIME no stupid CPU error LED.

Instead it does like a short cycle check and starts with VGA then the CPU and then the memory LED and then skips lighting for the boot and then ends up back at the VGA LED light.

Gonna try some other slot but also I think I might try to install windows 10 on the NVMe and see if it checks that light next time round.

And if it does maybe it'll try and boot to my 4k TV set which is what I am currently using for a monitor which works just fine for my tiny LarkBox.

Am I on a right track?

EVGA Geforce

GTX 650 Ti

Yeah I know, crummy old card but it still works for everything else so it should work on this too, right?







I just moved the card to the other slot and all of a sudden I see the screen pop up and doing something!!!

It's telling me to NOT turn the power off and is somehow doing a BIOS update.

Must of stored the BIOS stuff in the board some how.


You all can take a look at the BIOS as it stands right now and if you have any thoughts please feel free to let me know.

Image Link bellow: (soon to come)



So was up in the middle of the night, but got the OS installed and am in the process of updating everything as well as getting a few basic apps installed.

Then I can just put it all in and be done.

I'll be sure to post a final image of my awesome new system.

Thanks again for everything guys.




I'm glad you got everything working. 

Long shot question, but did you happen to plug any RGB cables into your Aorus Ultra motherboard? 


You mean like a LED light strip or something?

Cuz actually I was looking into something like that since I'm big into LED light strips.

I have them around my house setup to give color atmosphere to the place.

I always set mine up so they do that the lights are behind something or similar to give a nice smooth diffused light.

So as I've been doing this I've been studying to see if and where I might want to add a little extra to the case.

Now my case comes with a lot of nice features in this regard, but I'm still in the making sure everything is ok mode before I get things back in.

I can try and do a test if you want, I mean if I am understanding you?




I'm asking if you specifically plugged in any RGB cables into the motherboard itself. Something that looks similar to this: 


Yeah I know what they are and all.

Just wanted to make sure if you were asking about the lighting, i.e. adding extra LED lighting that can run from the board.

The answer would be not yet, but I'll test that out for you today.

There is a LED plug right next to the CPU area that lets you plug the LED fan part of things right there, though obviously it can be used for how ever you want to.

And they have several all around the board as well of course.

When I get up later today I will first thing test all that out and get back to you.



Okay, here ya go.

And I also wanted to once again give A HUGE THANKS to all of you here who chipped in with all your thoughts, suggestions and advice.

I am officially finished and can put the glass on the case and the other side and start playing some Battlefield and do some fishing in Ultimate Fishing.

I put a sample light strip in for so you can see that it does have plugs for those, though for my setup I would be connecting things like that to the case controller.

All done!

Final images below:






Hey man.

I just baught my x570 Ultra and I am experiencing the exact same issue of having to sit and stare at a CPU red light...

Can I ask what you did exactly to make it work? I am at a loss myself...


Forgot to ask, and this board you got, it will run not only my current 3900x but it's future proof at least through the 5xxx series, correct?


Yes, it will run the 5000 series CPU Processors.

It is the same as the more expensive Asus Hero VIII WiFi.

Here is a good  review from TechPowerUp website on the Pro Motherboard: and from Tom's Hardware:

Asus’ TUF Gaming X570-Pro WiFi is one of the cheaper X570 options available, giving it an early edge as it vies for a spot on our best motherboards list. At $219.99, the board includes a capable VRM that handled our power-hungry AMD Ryzen 9 5950X at stock speeds and while overclocked. In our testing suite, the board performed OK, on average running slightly slower than the other boards, though there were few significant outliers on either side of average.

From TechPowerUp Review:

The ASUS TUF Gaming X570-Pro (WiFi) did extremely well in my VRM torture test, with the hotter probe maxing out at around 65 °C. While the lack of a heatpipe between the two VRM heatsinks leads to a larger than normal delta between the two probes, both readings are easily within component tolerances.

There should be no doubt that this board can handle anything AMD has to offer.