Showing results for 
Search instead for 
Did you mean: 


Adept I

Help 7950x random game crashes

I have a amd ryzen 9 7950x on a asus rog strix x670e e gaming wifi and games keep crashing at random when I Check event viewer I get this error

The program _program name here_ version _version number here_ stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.

Event id 1002

Please help

18 Replies

List used hardware/software accurately:

- Motherboard (BIOS, chipset driver downloaded from where and version is?)
- PSU (brand, model, wattage)
- GPU (brand, model)
- Memory (how many sticks, XMP/DOCP/EXPO enabled?, any other tuning?)
- Every piece of hardware connected to computer including USB-devices, web cams, printers, harddrives, wifi-adapters, anything
- Every piece of software that isn't part of Windows including antivirus, web cam, RGB control, overclocking, monitoring, everything.

Did you follow the instruction to remove old driver before intalling the new (chipset driver) which was mentioned in Asus web page?


sorry for the late reply here is what I have

Asus ROG Strix X670E-E Gaming Wi-Fi

Bios Ver. 0805

Chipset driver Ver.

CPU is a Ryzen 9 7950X

PSU is a Corsair RM1000X

GPU is a EVGA RTX 3080 LHR FTW3 Gaming Ultra

I have two sticks of 16GB memory no overclock

Connected devices:

Razer Huntsman Elite

Razer Mamba Elite

Razer Nommo Chroma

Razer Nari Ultimate

Razer Raptor monitor

Xbox one controller wireless adaptor


Asus Armoury Crate

Lian Li L-Connect 3

Corsair Icue 4


All drivers and BIOS were installed from Asus's website, and I did follow the instructions for the chipset driver.

Could be just some early adopter issue and get fixed with some BIOS, chipset or Windows update, but...

Are they specific games which crash, or pretty much everything?

Are you using Win10 or Win11? Did you do a clean installation of Windows or used a previous installation and let it adapt to new machine? Definitely a new installation is a better option.

Have you tried disabling Multiplane Overlay Support (MPO), hardware acceleration from Windows and/or from web browsers and other software you use?

About MPO:

About hardware acceleration in Windows:

How are your temperatures and what CPU cooler do you use? Maybe install HWINFO64, run as adminitrator, sensors only. Play some game for maybe 5-10 minutes and then check what your max CPU temperature was during gameplay.

Two stick of what MHz with what latency? EXPO? XMP? Could be memory compatibility issue. You could try running it with XMP/DOCP/EXPO disabled for testing. Perhaps even just one stick at a time.

At least for testing, I would uninstall Armoury crate, Lian Li L-connect, Corsair Icue and every USB device except keyboard and mouse. Use speakers or headphones with 3.5mm plug during testing.

Does it look like your VRAM or system memory is filling up, like with some memory overflow problem?


I am running Win10 and the games that are crashing are halo infinite and spider-man remastered

the RAM I use is this

Corsair VENGEANCE RGB 32GB (2 x 16GB) DDR5-5600 PC5-44800 CL36 Dual Channel Desktop Memory Kit CMH32GX5M2B560B - Black

I Do not have EXPO/XMP/DOCP enabled

highest CPU temp was 87c

GPU was 65c

I am using a custom water-cooling loop


I can't find those sticks from Asus QVL-list and while this normally would not be a thing, maybe Ryzen once again is picky with what sticks you use until BIOS matures.

If you have not tried EXPO yet, try it. Maybe it runs better with EXPO enabled.

I'm curious, because I have exactly the same CPU and motherboard. I just don't have rest of the components, so can't test anything or do anything. My memory kit is on the QVL list, not that it normally matters.

I would also try some manual all-core underclock... Like set everything to 4.0GHz or something. Could also be that it works better with Win11, though I would have wanted to stay with Win10 for a while, waiting for "Win12" or somehing as I feel Win11 is a step down.

And I would really remove every other software than Windows, drivers, browser and Steam or what you use for games. Many RGB software and similar doesn't get updated often and it might take time before they become stable and compatible with a new architecture.

I hope I get rest of my parts soon so I can put it together and start testing.


This is not what I have encountered ever before. Watch this: maybe it is the reason for your problems. Could possibly be easily solved.

Also... I'm starting to get scared. I got a good deal on Hynix M-Die, but it's dual rank. I think my Christmas will mostly consist of trying and failing

Well... My kit is on QVL list, so... Interesting times.


This might fix your problem too 


My issue isn't that my system is rebooting it's that games keep crashing to the desktop. I don't have the amd igpu driver installed and nothing seems to be wrong with the memory physically.


LevelOneTechs mentioned there can be a variety of problems if DDR5 memory is not seated perfectly. They did not mention any visible problems. 


I reseated the RAM still have games crashing to desktop 


I have the exact same cpu and mobo. I had problems with ArmouryCrate and bad descriptors for the USB hubs. It started happening after I updated the bios to 805. I reverted and everything went back to normal. Mostly. I suspect there will be a new bios out soon. New hardware brings new bugs.

Good to know as I think I finally get my components (same CPU and MB) tomorrow. This information really helped.

EDIT: If case you have EXPO memory kit, any chance you could take some screenshots/pictures of memory settings (brand/model, clockspeed, timings, subtimings) and post them here. My kit is non-EXPO and would like to try them out and try to optimize further and maybe start a thread if I can find good settings.

I am using DOCP 1 @ 36-36-36-96 1.35v. I assume I don't have EXPO ram.

Trident Z5 RGB 32GB (2 x 16GB) DDR5-6000 PC5-48000 CL36 Dual Channel Desktop Memory Kit F5-6000J3636F16GX2-TZ5RK - Black

I replied with all the specs but the mods deleted the post. Good luck with your mobo.

Ok. Thanks.

I wonder why. Could some moderator comment? Subtimings are hardly a secret as they were available with Dramcalc with 2000 and 3000 series. Also these thing are talked about in youtube videos, other message boards and so on. Would be just handy to have it all in here.

I have encountered less than stellar BIOS-versions, but I doubt it will be a long time issue. Next version will likely be much better.



I actually got Asus B650E-E Strix Gaming WIFI, not X670E.

Seems like 0821 of B650E-E has same description as 0805 of X670, so maybe I avoid that.

Does anyone know if 0705 (or 0809 with B-series boards) is any good?

Journeyman III

I have the same motherboard and cpu. I’ve been having the same issue. My bios is updated to the latest. It just dawned on me that I have amd expo enabled. I’m gonna try and turn it off when I get back to the pc. Do you have amd expo on? Also, what GPU do you have?

Adept III


Maybe a problem with the graphics card, i had a similar problem with my RX 6900 XT and after testing with another PSU, RAM, CPU, the problem was the graphic card, i change it, RMA it and everything is fine.

Can you try another graphics card?