cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

Highlighted
Journeyman III
Journeyman III

Hello, my ryzen 5 1600 stopped working after two weeks of usage

Hello, so i have just built my first ryzen tower and everything was working just fine until yesterday. I tried to boot up my pc but it gets me directly to the bios. So i thought that resetting my bios would sove it but instead i can't even access my bios anymore (when i boot up my pc there is just a black screen....) . So i opened the case and i found there is a red led on (See picture attached). Can anyone here help me please?

Just in case here is my entire build :

CPU : ryzen 5 1600

MOBO : gigabyte GA-AB350 gaming 3

GPU : msi gtx1070 gaming x 8g

RAM : g.skill ripjaws v 16 gb

SSD : samsung 850 evo 250 gb

HDD : western digital caviar blue 1to

PSU : seasonic g650

Thank you for your help

0 Kudos
2 Replies
Highlighted
Forerunner
Forerunner

Re: Hello, my ryzen 5 1600 stopped working after two weeks of usage

According to your motherboards manual, you have a bad processor.

18) CPU/VGA/DRAM/BOOT (Status LEDs) The status LEDs show whether the CPU, graphics card, memory, and operating system are working properly after system power-on. If the CPU/VGA/DRAM LED is on, that means the corresponding device is not working normally; if the BOOT LED is on, that means you haven't entered the operating system yet. 

If you have access to another processor, swap it out to see if the old process is really the problem.

Or take it to a service center to have the processor and motherboard checked out.     

Highlighted
Adept III
Adept III

Re: Hello, my ryzen 5 1600 stopped working after two weeks of usage

Arctic is right, however I would try reseating the processor first.

0 Kudos