Showing results for 
Search instead for 
Did you mean: 


Adept I

Half RAM labeled as 'hardware reserved'

The system:
Ryzen 7 2700 (non-x)
ASRock Taichi x470
RX-580 8G
16G (2x8) Corsair kit CMK16GX4M2Z2933C16

The RAM is listed on the QVL for this motherboard/CPU combo.

From Feb 2019 to March 28, 2021 the system ran fine, all ram was usable and would clock to 3300. The machine was stable.
On March 28 the system crashed. I pulled the entire thing apart for a thorough cleaning and inspection. Processor, RAM, and al other components were reinstalled/reseated. The existing thermal compound was cleaned off and replaced.

At this point, the system slowed significantly and would not handle workloads it previously shrugged off. After several weeks of troubleshooting, I noticed that the RAM was down-clocked to 1333mHz (2666) and would not post if speeds were pushed up at all. Additionally, I noticed that Task Manager's Performance tab showed 8.1G of RAM as 'Hardware Reserved'.

I have done all the troubleshooting you can find on this issue.
I ran MEMTEST and it showed one stick racking up over 200 errors in a single pass. However, the system would post and run fine on either stick of RAM installed in _any_ slot. When run like this, Task Manager correctly reported 8G installed RAM with 7-10m 'Hardware Reserved'

I contacted Corsair Support and they agreed to RMA the RAM. I have since received the replacement RAM and the issue persists.

Close inspection of the CPU, CPU socket (as best as I can see), the RAM sockets, and all board traces in the vicinity of the CPU and RAM appear fine.

The research I've done on this issue shows that the most common cause of this problem is incompatible RAM. Since the system _worked) with this RAM for just over two years and is on the QVL for this specific combo, I doubt this is the cause.

Another cause seems to be a bent pin on the bottom of the CPU - I have verified that this is not the problem.

Less common, but possible (I saw at least one case) is that the memory controller on the CPU may be damaged.

Then, of course, the motherboard may be bad. I will contact ASRock about an RMA on the motherboard if I can't sort this out.

I've looked at the Maximum Memory box under Advanced Boot options in System Configuration. It's set to '0' and unchecked.
The pagefile is currently set to automatic, but I've had it set as a static file of various sizes on various drives trying to figure this out. So far, how the pagefile is configured has had no impact on the issue at hand.

Does anyone have any experience with this issue? How did you fix it?

I've already replaced the RAM, and I'm willing to RMA both the CPU and the motherboard if I can't find another solution.


Any help would be greatly appreciated.


8 Replies

Anything in here you have not tried,

The tutorial itself, not any app download.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., G5 27in..

Thanks. I'll check it out....

Yeah, I've done that one. I'm good on all counts. RAM has been replaced, msconfig.exe is good to go, Windows is 64bit, latest version, BIOS is the latest version recommended for my CPU and it's been reset to factory defaults numerous times.

I've been to the ASRock Discord FWIW. The hooked me up with a BIOS roll-back to 3.50 and suggested replacing the RAM.

So I've done more testing with the replacement RAM, and it seems that if I stick the modules in A1/A2 or B1/B2 I get 16G in single channel mode with the correct 74MB "hardware reserved"


Sticks were originally in A2/B2 ?

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., G5 27in..



Last i can think of is cmos reset, or reflash bios (sticks in correct slots).

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., G5 27in..

I've done both. wish that wasn't the case.

Journeyman III

I have the same problem with 2xRyzen 2700x systems. Both have 32 Gb of 3200Mhz Corsair LPX memory (DDR4). Windows 10 Pro shows 32Gb installed 15.9Gb usable. (1X mine, 1xcustomers). Everything suggested on many forums have not worked. CPU's changed, memory changed. memtest run on Ryzen systems.


I also have 2 x FX9590 systems, Corsair LPX 1600Mhz 32Gb(DDR3) 32Gb installed, 32Gb usable. (Both mine) I put the FX boot drive in the Ryzen systems, 32Gb installed 15.9 usable. I put the Ryzen boot drive in the FX systems, 32Gb installed, 32Gb usable.

I thought it was a Windows problem, looks like it is a Ryzen problem. All motherboards are Asus. Crosshhair 6 Hero for Ryzen, Sabertooth for the FX systems. All running Windows 10 Pro, 21H1 version. Looks like I am going over to the dark side(Intel)


Dannix Computer Systems



Had the same problem on a extra Ryzen 1700 system One Pin on the cpu was bent down used a needle and tweezers to straighten it back and reset the CPU wala all of RAM available