cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

Blackf0rd
Journeyman III

Flickering models in Unreal Engine games

Good day everyone! So the last 5 months I am having glitches in all Unreal Engine based games (I've tried Fortnite and Stray) with my Ryzen 5 5600G. You can see the glitches in the following video: Link to YouTube 
My rig:
CPU: Ryzen 5 5600G
MOBO: Asus TUF B450M-Pro S
RAM: 16GB G.skill Ripjaws 3600Mhz CL18 (2x8, dual-channel mode)
GPU: MSI RTX 3060 12GB
SSD: Crucial P2 500GB NVME

Troubleshooting steps I've already tried that didn't help:
1) Clearing DirectX cache
2) Reinstalling games into other directory and checking for file corruption
3) Running SFC scannow in Windows Terminal
4) Running DISM repair command in Windows Terminal
5) Installing chipset drivers
6) Disabling RAM D.O.C.P. profile
7) Changing the graphics card (when I first started encounering such an issue I was using integrated graphics then bought Nvidia graphics card but still have the same issue)
Clearing videodrivers with DDU inside Windows Safe Mode
9) Repairing Microsoft Visual C++ Redist for both 86x and 64x
10) Running games in compatibility mode and with Admin rights
11) Changing videogame APIs (Vulkan, DirectX 11, 12)
12) Reinstalling Windows
13) Turning off the PSU with the power cord for 10 mins and turning the PC on again
14) Reseting UEFI settings to default (through BIOS, not by removing the battery)

The thing is when I built the rig for the first time everything was working fine in Unreal Engine based games and I didn't have any issues, then I started having these glitches. No other games have any issues nor rendering any video in DaVinci Resolve 18 now, only UE games. 
The only method that helps me get rid of the glitches is by turning the #4 and #5 threads off for the game's process through Task Manager with the affinity feature.
I've also found someone on Reddit with the same problem and he has totally different build with Ryzen 9 5900X and Asus ROG STRIX x570-e Gaming WiFi II. The affinity feature helped him too. 

0 Likes
4 Replies
rekoj
Adept II

thats a weird one

0 Likes
kingchimp
Journeyman III

@Blackf0rd thank you so so so much! I have been trying to fix this glitch in Unreal games for well over a year, and disabling the two highest-numbered CPUs in CPU affinity settings of task manager for the game process has fixed this glitching for me in both Deep Rock Galactic and the new System Shock Remake.

Stranger still, I am not running an AMD system at all, here's my specs:

Intel Core i7 4790K @4.00ghz
MSi GeForce RTX 2070 4gb
MSI Z97 Gaming 5 Mobo
16gb DDR3 
Windows 10 Pro N 64-bit 

It would great to try and found out what's the common problem between our systems, and maybe find a fix that doesn't involve reducing the CPU's performance for the affected games though, as I think this does a bit. I'm pretty sure it's some thread-safe code going wrong and reading/writing data in the game's process when/where it shouldn't. 

Here's a link to my solved issue at Tom's Hardware: 

https://forums.tomshardware.com/threads/graphical-glitching-in-unreal-engine-games-system-shock-rema...

Thanks again anyway!

0 Likes

Hello,

I am having this issue in multiple different UE5 games, just like you. Though when trying to fix with the recommended fix, adjusting the cores in Task Manager is doing nothing. The core checkboxes I have available are from Core 0 to Core 23. To clarify, are you keeping the game running while unchecking cores, and to follow your directions, I would have to uncheck core 22 and 23? Thank you

0 Likes
camirl
Journeyman III

Hello,

I am having this issue in multiple different UE5 games, just like you. Though when trying to fix with the recommended fix, adjusting the cores in Task Manager is doing nothing. The core checkboxes I have available are from Core 0 to Core 23. To clarify, are you keeping the game running while unchecking cores, and to follow your directions, I would have to uncheck core 22 and 23? Thank you

0 Likes