cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

Journeyman III
Journeyman III

Disable CPU turbo

I have spent awhile looking at different forums and places trying to figure this out and yet to learn anything that is helpful. With this newly built computer of mine I have discovered that the CPU is running above the base stock GHZs normally about 4.4 ghz from windows 10 task manager or 3600mz to 4499mhz according to MSI CPU-Z. I am running a AMD Ryzen 7 3800X on a MSI 570x motherboard everything is up to date and I am sure this is the windows 10 cpu turbo causing me problems. 

I wouldn't worry so much if it wasn't for the reving up and down of my cpu fan and the added heat while idling. Is there a way to disable this easily without voiding my warranty? Also I've been having issues getting into windows 10 bios to fix this. 

0 Kudos
5 Replies
Exemplar
Exemplar

Re: Disable CPU turbo

steelwolf19, there is noting called 'turbo' in AMD Ryzen.  Please download and run Ryzen Master (RM) and post a screenshot - simply drag-n-drop the image into your response.  Post all your components and read the RM Quick Reference Guide.  Thanks and enjoy, John.

0 Kudos
Adept I
Adept I

Re: Disable CPU turbo

First thing i need to tell you how to get UEFI settings in Windows 10.

Just type "advanced startup" to search bar of windows. Then restart it under Advanced Startup title.
When computer reboots, select Troubleshooting, you will see something like *** firmware settings of *****.
After selection of that, you will get to UEFI BIOS. Then you should search for turbo things. I will restart my computer when my tasks done, i will try to lead you step by step.

Big Boss
Big Boss

Re: Disable CPU turbo

the bios on my x570 has options to enable or disable several cpu features

you can find it with the advanced options

Esteemed Contributor III

Re: Disable CPU turbo

PBO and XFR are BIOS settings that boost the CPU.  Similar to Overclocking your Ryzen safely. You can disable both if either or both are enabled in BIOS/UEFI.

Also in some BIOS/UEFI they have Core Boost. You can enable or disable that also.

0 Kudos
Journeyman III
Journeyman III

Re: Disable CPU turbo

It took me some time, longer due to being out of town thanks to the holidays, but I was able to figure out what was 'overclocking' my cpu. MSI Motherboards come with Performance boost, this ramped my 3.9 base to the turbo setting of 4.5. I use turbo as that is what Intel's cpu uses for its mild overclocking. After disabling the boost, my pc is running cooler, quieter but a tad bit slower. This is a good trade off. 

For those wondering you need to hold Del key down during restart to access a msi uefi should the windows shortcut not be there. From there you can find the setting in Advance, Cpu configure, Precision boost and disable it and enable AMD cool and quiet. This took me calling MSI to figure it out. 

I apologize for spending so long away and not giving more information but the Holidays were a bit rough this year and I was without a computer.

0 Kudos