Showing results for 
Search instead for 
Did you mean: 


Adept II

CPU stuck at 0.39ghz speed

After a windows update I'm facing cpu speed issues after few mins of usage it drops to 0.39ghz and stays like that on restart as well. Tried windows update, bios update,Windows format, Amd Radeon drivers update. No solution found ..

I've been using this laptop since 1 year never faced this issue. Not a gamer.. I use it for Music Production and Mixing. Bust with issues everything lags and disrupted the flow.

From other external threads people are suggesting Ryzen controller, disabling modern stand by option....Not touched yet.

Today I came to know about there's something called Ryzen Master. ...not used yet

Im running System on High Performance plan with Minimum and Maximum processor state as100% 

System info

OS Name Microsoft Windows 10 Home Single Language
Version 10.0.19043 Build 19043

System Manufacturer ASUSTeK COMPUTER INC.
System Model VivoBook_ASUSLaptop X512DA_X512DA
System Type x64-based PC
System SKU
Processor AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx, 2100 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. X512DA.316, 02-02-2021
SMBIOS Version 3.2
Embedded Controller Version 255.255
BaseBoard Manufacturer ASUSTeK COMPUTER INC.
BaseBoard Product X512DA
BaseBoard Version 1.0
Platform Role Mobile
Secure Boot State On
PCR7 Configuration Elevation Required to View

Installed Physical Memory (RAM) 8.00 GB
Total Physical Memory 5.95 GB
Available Physical Memory 3.12 GB
Total Virtual Memory 7.57 GB
Available Virtual Memory 3.20 GB
Page File Space 1.63 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Not enabled

59 Replies

Ok, I know this thread started a year ago, but I know the issue.  It appears that MSI Afterburner causes this.  I don't know why, but as soon as you overclock your PC, it starts tripping.  Even if you clock everything down to 0+, it still happens.  Uninstall it, and only use AATU (AMD APU Tuning Utility) for overclocking.  If it doesn't solve the issue immediately, restart your pc, obviously.  Good luck to other people who come here!

after many months...


would you say this is the best fix?


Thank You


Hey @LurcK  I have the same Brand and CPU model, did you solved this completely?


I cant do this as my battery wont take any charge it stuck at 3% charge so same time as i unplug it turns off this cpu problem started the same time with the battery stop taking charge


Attention AMD team!

Please guide/help for this issue.


maybe Thermal Sensors or EC/BMC have problem

Adept II

попробуй откатить обновления windows может поможет!


It has got nothing to do with Windows, I installed Ubuntu on my device and checked. The same thing happens there also

Journeyman III

i guess u guys need to update certain amd component driver manually.. i mean not only from windows update, they not add the new ones on their list.. just like AMD GPIO Controler, AMD PSP, ACPI Virtual Controler, AMD I2C, AMD SMBus, etc, and make sure u download it from your OEM.. a optional u can download it from 3rd app if your manufacture already doesnt provide it anymore, just like driver identivier(im using), driverpack, etc

my problem is same as yours(solved)

mostly on game loading screen or switch scene, my cpu clock drop to 0.4ghz + gpu clock and utilitation drop also.. and power consumption both of cpu and gpu is drastically drop and big impact on fps to..


my laptop spect

ryzen 7 2700u

radeon 540

8gb ram

Lenovo LNVNB161216 mobo

this is my cpu work now after a hours gaming, cpu temp is high but never go to 0.4ghz again (minimum only 1542mhz )  


feel free to give your feedback


I had this happen before and it was a corrupt registry entries that forced my cpu down to .39.  Once I clean installed windows everything was good to go.


I don't mean to make light of such an issue.

But you could try changing your handle to Commodore 64.JK

Outside of broken/missing pins from the CPU or a damaged CPU socket.

Perhaps some thermal compound made its way under the CPU when installing the CPU cooler.

Could even be a bad or loose CPU power cable on the MOBO PSU or both.

May even be the PSU CPU power port.

Then windows 10 has turned out to be an annoying pest for AMD builds.

Try a Command Prompt as Admin sfc /scannow to check your OS for missing or corrupt files.

Update your MOBO CPU chipset driver.

Check your MOBO BIOS lists for BIOS versions that specifically mention solving CPU throttling issues with the series of CPU you are running.

May have a defective PSU MOBO or CPU. Unless you have compatible parts around to swap out there's really no way to know if it's a hardware issue. 

Anyway hope a solution is found. I've never experienced first hand a CPU being throttled like that outside of a major hardware fault/failure.



After a lot of trial and error I finally identified the source of this weird problem, at least on two Ryzen (3500u and 2500u) laptops

When any Ryzen laptop is powered on and charging, and the battery is below a certain level (usually 50% or less) and you start any kind of high demanding cpu app like a game or maybe compressing a file, the laptop BIOS and motherboard power control unit will send the PROCHOT EXT signal to the CPU, locking its speed to the lowest possible (Usually around 400mhz). This seems to be a failsafe mechanism so you cant exceed the max allowed power consumption that the AC-Adapter or the Motherboard itself can handle.

My OEM HP laptop Ac- power adapter is just a mere 45w unit, using power hungry apps like gaming can raise the CPU well above its rated wattage, for example. my Ryzen 3500u has a rated wattage of 15w, but it can go as far as 23W while gaming or compressing files (you can check that using hwinfo in your own laptop).

23W is  about half the power the ac adapter can give to the entire laptop. charging the battery can use as much as 20w so you can hit the 45W limit very easily and the laptop bios/motherboard will lock the cpu speed temporarily,  until you reach at least a 70% battery charge.

Restarting the laptop will kinda "fix" this issue, but as soon as you combine high cpu usage + charging the CPU speed WILL drop again until charging stops or you reach a certain level considered safe by the motherboard firmware. 

Thats why some people claim that uninstalling drivers, programs or devices, will "fix" the problem, because uninstalling any driver o device implies restarting the system, and by the time you finally restart the laptop after messing with it for a few hours the battery is finally charged.

The same "fix" applies when someone wipes out an reinstall windows trying to solve this problem, by the time you finally reinstall windows, drivers and programs the battery will be totally charged and the problem will not appear... you guessed it: until you charge the laptop and do any cpu demanding task, even for a few seconds.

Selling laptops with weak-cheaply made power adapters seems to be pretty common these days. Almost any recent laptop will exhibit this behavior when power stressed.

Kinda miss the good old days with those Brick-like 150W power adapters that were overkill for almost any laptop, nowadays you cannot use the laptop full potential if your battery is not fully charged and the moon is on the right phase. *sighs*


i also have a hp laptop with a ryzen 7 (3700u) and the issue always happened when i do intense tasks while charging or when the battery is below 7% and is charging, hp NEEDS to fix their adapters so that we can use our laptops stress free

Adept I

how i fixed my problem is that i did a battery check and found out that the battry wasn't working. So i disconnected it  and it stopped doing that but it does have 1 and 2 times where it happens

Journeyman III

I found the solution it has to do with the current Amps from the charging port, watch it here:

Adept II

Now got the golden words from ASUS Service Center "Motherboard needs to be replaced" and that'll cost around 24 thousand INR( me thinking Why would I ever go for faulty motherboard again). Somehow I managed to use this laptop for 2 years. Since Purchase twice it has gone to service center, parts got replaced. It has been a worst experience to use Asus vivobook x512da laptop. 


AMD is the culprit here, In the beginning i thought is was an AMD 3500U specific issue but later  I have seen people reporting the same issue on devices with AMD 4500H processors and there is no fix for that. AMD has got some issues with their SOC that they never gonna address. I'm planning to get a new device without the AMD **bleep**. Better to stay away from AMD devices in future.



Hello sir, iam recently facing this issue with my amd ryzen5 4600h, on lenovo legion 5 , did u find a fix? please reply i tried everythin but still the problem persists

Journeyman III

Greetings from Venezuela...

I have the same problem: my ASUS VivoBook x512DA is stuck in 0.39 GHz while charging, but I have another problem too: my battery isn't charging.

If I unplug the charger, the processor speed up to his normal levels but if I plugged it the processor's speed decrease and don't charge the battery.

I'll try to repair/fix/change the charging port. I changed the battery but this don't fix the problem...

See this video, it was helpful:

Journeyman III

Update in 2024:

Work in ROG FLOW X 2022

  • Charge PC to about 25%
  • Shutdown laptop
  • Unplug your charger
  • Wait 1 min
  • Plug your charge
  • Start your laptop again