Showing results for 
Search instead for 
Did you mean: 


Adept II

CPU stuck at 0.39ghz speed

After a windows update I'm facing cpu speed issues after few mins of usage it drops to 0.39ghz and stays like that on restart as well. Tried windows update, bios update,Windows format, Amd Radeon drivers update. No solution found ..

I've been using this laptop since 1 year never faced this issue. Not a gamer.. I use it for Music Production and Mixing. Bust with issues everything lags and disrupted the flow.

From other external threads people are suggesting Ryzen controller, disabling modern stand by option....Not touched yet.

Today I came to know about there's something called Ryzen Master. ...not used yet

Im running System on High Performance plan with Minimum and Maximum processor state as100% 

System info

OS Name Microsoft Windows 10 Home Single Language
Version 10.0.19043 Build 19043

System Manufacturer ASUSTeK COMPUTER INC.
System Model VivoBook_ASUSLaptop X512DA_X512DA
System Type x64-based PC
System SKU
Processor AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx, 2100 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. X512DA.316, 02-02-2021
SMBIOS Version 3.2
Embedded Controller Version 255.255
BaseBoard Manufacturer ASUSTeK COMPUTER INC.
BaseBoard Product X512DA
BaseBoard Version 1.0
Platform Role Mobile
Secure Boot State On
PCR7 Configuration Elevation Required to View

Installed Physical Memory (RAM) 8.00 GB
Total Physical Memory 5.95 GB
Available Physical Memory 3.12 GB
Total Virtual Memory 7.57 GB
Available Virtual Memory 3.20 GB
Page File Space 1.63 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualization-based security Not enabled

59 Replies
Adept II

Please reply. what can be done?

Not applicable

It is triggered by BMC on the platform (due to high temp) and it is not a processor initiated. So, if the processor experienced it, it is highly likely that it is a platform thermal issue. Could you pl. check?


Thanks for replying.

I cannot sense laptop is heating ..its some kind a bug or process interrupted. I've been using this laptop for a year now and never encountered such lags low cpu issue. Even the asus engineer is not responding my calls, cust care response is also delayed. Can you please help me isolate this issue if anything to be enabled/disabled. From my side I tried clean boot option, registry intelppm to 4, disabling microsoft acpi compliant method battery from device manager. Nothing is helping.

BTW Ryzen master is not supported on my system. How can I post the cpu readings screenshots here. 

observation If keep laptop shutdown for 1hr and start, the cpu speed be like 2.50-2.69 ghz and within few mins it'll come down to 0.39ghz 


Not applicable

//observation If keep laptop shutdown for 1hr and start, the cpu speed be like 2.50-2.69 ghz and within few mins it'll come down to 0.39ghz //

This points to thermal issue.   May be due to clogged air intake vents on the laptop.


Thanks gnanakumar,

If its a thermal issue can you please guide me whats to be done. Any tips? Last option is always there to go to service centre with Laptop. But anything I can try before proceeding. 





Last week I also experienced the same thing.
I disabled drivers in Device Manager "system firmware", "device firmware" and uninstalled "System CMOS/real time clock".
I also disabled services, you can see here (method 2)

It's been a week since the laptop is running smoothly again.
I hope this method works for you

Adept II

Bro i'm having the same issue with the same laptop. This throttling is caused due to "PROCHOT EXT" being triggerd, you can use a software called Hardware info to monitor that. For our device it is not because of CPU or GPU being over heated but some other issue. Now my device is literally useless cos of that throttling please let me know if it got fixed. Thanks


It didn't get fixed yet, the problem is upon fresh start for some mins the speed is good and then it drops. I've been doing my Rnd following other threads. People have tried utility like Throttlestop, registry edit for intelppm, Ryzen controller, Ryzen master. Sad but none works for my Laptop.

Why Ryzen Master doesnt work for my laptop ..Not Supported....why whwyw hwywhwykjssh

fed up


This is the third time i'm having this issue, usually it would last for about a week or so then it disappears for about two to three weeks and starts re appearing. and strangely my device also stops charging during the throttling event, is it the same for you? Can you provide that Asus engineer contact number?. Talking about Ryzen Master, i think it isn't supported because our device is a notebook which is not supposed to be tweaked for high performance due to its poor thermal design.


Bro its the same thing happen to me like for 3 days now my cpu stuck at 15% usage and the speed at 0.39Ghz  and then my battery wont take any charge my battery is 95% wear so it its still good



Does your device charge its battery while throttling?


I have diabled my "Microsoft ACPI Compilant control method Battery" from device manager. as it used to charge but at very slow speed not like how it actually came like fresh. Technician told me to new battery will also responding same so you need to replace motherboard. I didnt go for motherboard relacement. I've disabled it. you can contact Asus vi MyAsus app through chat or email.  


Motherboard replacement?  for what battery issue or for throttling?


Issue is resolved, I took it to service center, They said thermal paste worn out  and applied new, did some cleaning, formatted System and they removed my custom partition as well. observing since 2 days no issues. 


Mine also seems resolved since past 5-7 days but i didn't do anything. I did update my graphic drivers from AMD website and it installed a custom power plan along with some other drivers after that throttling never appeared. I strongly suspect the default Windows Power plan had some issues because during throttling device simultaneously stops charging as well, so it has to be something related to power. In your case i don't think it has got anything to do with thermal paste, considering you device is not so old and there is little to no chance that the thermal paste could wear out. Fresh install would have fixed it. I was about to report you then i thought i would wait if it reappears, but as of now it didn't.explorer_kW5iqlHOsk.png.


Guess what! the issue has resurfaced, I really dont understand what to do about it. Tried Ryzen balanced plan as well and after 1hr of usage the cpu speed hits 0.39ghz and then everything lags. 

At the moment only these two options running in my mind

Feeling like switching to windows 7


some tweaks in Bios.

Anybody from AMD staff/community who can help ? 

Even my 10-12 year old 32bit laptop never gave me such problem.. whats the point of buying Quadcore ?


mine also re appeared. I think it's time to consider hardware faults. Are you under warrenty?


No! its been 1yr warranty expired. Will switching back to windows 7 help?


I have no idea. But if you can please try that. I think may be this has got something to do with BIOS update. it would be better to contact service team and do a BIOS downgrade, I don't know whether its possible or not. Since the issue not being persistent it's not easy to consider a hardware fault.


I found something. when this cpu 0.39 ghz drop issue occurs do this 

remove charger pin from laptop

shutdown >> then start 

login >> put the charger back 

you have 2.67 /2.90 ghz back again




if you are connected with the charger pin and shutdown or restart the processor speed will still show 0.39ghz


Charger or battery seems to be the culprit.

Note: In this forum community, I'm not getting anybody else's reply, only you and me are interacting. I was expecting if AMD guys could help here. 

1) I tried using the device completely on battery and throttling happened multiple times which means charger has nothing to with throttling.

2) I opened the laptop and physically removed the battery and powered it completely on adaptor and throttling happened, which means it has nothing to do with battery.

I even removed the additional ram and it didn't make any difference.

And yes the throttling stops momentarily when the device is turned on after a shutdown while charger not being connected. But still it's un reliable

The reason is because something is triggering PROCHOT_EXT but can't track it down. Maybe a faulty sensor, a glitch or a BIOS bug.


I took my device to service centre and they said most probably it would require a motherboard replacement 


  • How much are they charging you for motherboard replacement? 

And what if same issue comes in the replaced motherboard after bios update then. 

How is the next motherboard different from the current one. 

Does your battery charges slow as compared to when it was new? Coz see in the 2nd page of this thread. I told u technician asked me to replace motherboard and i didn't  allow him. Anyways u let me know


i haven't considered replacement coz motherboard costs half the laptop, email me on im planning to contact asus and report our issue. 


Hello, I have a lenovo notebook which has a ryzen 4800H and it will also randomly stuck to 0.38GHz occasionally when plugged in. I found a solution to that issue from the internet, it seems like disabling AMD SECURITY PROCESSOR in BIOS can eliminate this problem.


Can you share some screenshot or link. Before doing this, I need to be well aware what I'm doing.


His processor as he said is 4800H which are usually found on Gaming/performance devices so it will have extra tweaks in BIOS on the other hand our device is a notebook and there is nothing we can tweak in BIOS otherthan upgrading / downgrading the BIOS itself.



Another reported case



Look at his ram 20GB. This model is expandable up to 12 gb ram only .4 gb soldered and room for only one 8gb slot.


Try uninstalling everything related to GPU. AMD Chipset Drivers, Radeon SOftware and Display adaptors from device manager and report.

if you have telegram account ping me on @etsachin


Hi, I'm not using telegram, Tried something yesterday and since morning I didn't experience any cpu drop.

Go to my asus app


Battery Health Charging select Maximum Lifespan mode which allows charging only upto 60 % to extend battery lifecycle.

Otherwise daily it was a routine after 1hr cpu drops and I have to remove charger pin from laptop>>shutdown>>start >>connect charger back to get cpu speed back.

Today I didn't experience any drops and continuously my charger is connected


it hasn't got anything to do with throttling i have already tested that a few months ago, it will reappear after few weeks.


I've got this same problem. 
Short term fix is to unplug the charger and wait until it goes back to 3ghz+
Then plug it back in.

It's got to do with the sleep trigger, where it thinks your laptop is still sleeping.

if anyone knows how to fix it long-term, let us know!
AMD RYZEN, I'm really considering moving back to intel or Mac forever because of this issue.

as ppl has said, its not a windows10 issue, I've got a few other devices on win10 and they're all fine. it's a Ryzen issue. 


Hi, if you are on Asus Laptop then try this:-

if your battery is full then drain it and

Go to my asus app


Battery Health Charging select Maximum Lifespan mode which allows charging only upto 60 % to extend battery lifecycle.

This is a set instruction to never charge your battery full and only at 60%.

I was badly affected by this cpu issue and now after keeping my battery charging only upto 60% there's no issue. its been more than a week I'm using my laptop comfortably. Check if this works for you.



i'm on HP laptop though.
And plus that solution seems very arbitrary, i probably wouldn't believe that to be to the long term fix.

this issue needs to be properly addressed from AMD and i'm havent seen anything yet... 


i have created a telegram group to discuss issues related to Asus Vivobook 15 x512da, Join Telegram Group  


thank you for this message

this is def what's going on.