Showing results for 
Search instead for 
Did you mean: 


Adept I

CPU Diagnostic software?

I'm trying to diagnose a memory issue to determine if the problem is CPU or motherboard.
The system is a Ryzen 7 2700 on an ASrock x470 Taichi Standard.
RAM set 1: CMK16GX4M2B3200C16
RAM set 2: CMK16GX4M2Z2933C16  (purchased for diagnostics, not to run in conjunction with Set 1)
The system refuses to run in dual-channel mode. It worked correctly when I built the system, but no longer does.
List of Symptoms:

  • When known-compatible RAM (2x8G) is installed in a dual-channel configuration (A2-B2 or A1-B1), the BIOS recognizes both sticks, but Windows 10 reports 1/2 RAM capacity (8G) as 'hardware reserved'
  • In a dual-channel configuration, memtest will fault on the second stick of RAM - however, swapping the position of the two sticks results in memtest still faulting on the second stick. (while this looks like a bad slot, please continue reading)
  • When installing RAM in single-channel mode (A1-A2 or B1-B2) with one set of modules, the system recognizes both modules properly and both pass memtest, even when one of the modules would have failed in dual-channel mode.
  • Testing any one stick of RAM in any slot where the PC will boot, the stick (and socket) passes memtest.
  • Where the original set of 2x8G sticks was clockable from the base 2133 to 3300mHz, the system will now fail to boot at any setting higher than base value. This is true of both sets of 2x8G modules.
  • Installing both sets of RAM (two sets of 2x8G, 32G total) results in 16G of single channel RAM and 16G 'hardware reserved' - the difference between installing 4x8G and 2x8G in single-channel mode is the second option results in the correct  574MB of 'hardware reserved' RAM.

Steps taken so far:

  • I've performed a number of steps the remedy 'hardware reserved' RAM posted on the internet. None of them have worked.
  • The original RAM was RMA'd to ensure it wasn't faulty. The replacement RAM experiences the same issue.

  • I purchased a second set of known-compaitble RAM to use while the first set was being RMA'd. This RAM also experiences the same problems.


This seems to be an issue specific to the memory controller. The system refuses any attempt to use RAM in a dual-channel configuration. Given that the memory controller is integrated into the CPU, I suspect that the CPU is faulty. Can anyone with pertinent experience confirm or refute this?

Is there a software package from AMD that can diagnose this issue or at least run tests on the CPU?

Would AMD be willing to ship a Ryzen 7 2700 or similar CPU to me for diagnostics? I have no one with whom I can swap CPUs to verify whether this is a CPU or motherboard problem.



4 Replies

First is this the first time you use this processor and motherboard or was it working normally before?

If both the processor and motherboard are new because you are building your own PC I Suggest you RMA both to find out which one is defective to save time. Especially if you don't have another PC to test with.

If you purchased the Ryzen 2700 processor from a Retailer in a official AMD Retail box then you have a 3 year warranty on it.

IF the processor is less then 3 years old you can open a AMD Warranty and see if they believe the processor needs  to be RMAed to be checked or not from here:

If it is older than 3 years than you can open a AMD Support ticket and see what they say from here:

Personally I believe if it is a defective hardware it probably would be the motherboard since Processor are pretty sturdy hardware unless it came DOA from the factory.

So I suggest you open a ASRock Support ticket also and asked them if they believe your motherboard is defective or not.

Yes it is tough to troubleshoot a CPU/Motherboard issue without testing the hardware separately in another computer system.

I don't know how much a Computer Repair shop would charge you just to install the processor in their shop and see if Dual Channel works or not.


The system worked correctly for about the first year. I've been contemplating RMAing both the CPU and motherboard for exactly the reasons you gave. I am just hoping that someone had seen this issue before and would have an idea which part was faulty.

Thanks though. If I don't have a better idea by Wednesday, I'll start the RMA on both.

Journeyman III

I dont know if it is too late to help you with this, I just found this post.  

 I just made a post with the exact same issue as yours, but with two different architectures: an old FX-8320 and a newer Ryzen 7 2700. So note also that one is DDR3 and the other is DDR4 RAM.   Both system correctly detect the installed ram in the BIOS,  but in the OS only half. Doesn't matter if I am using Windows or Linux.  it doesn't matter how I arrange the memory in dual channel mode (2x4 and 2x8 GB pairs),  I have spare memory to test with also.

I have taken the Ryzen CPU and motherboard  (MSI B450M-DS3H) to a shop. At first they said it was the Motherboard. But then I convinced them to try a different CPU on that motherboard, and they said "Wow! it works.."   ( Hmmm so much for their diagnostic skills)...

So, as you also surmised it really seems to be a CPU problem.