Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Computer shuts down saying CPU is over temp while at 50C generally

I built my PC recently and bought the Ryzen 9 5900x on a whim due to a sale. However, when I try to open up a software, play games, or even have multiple tabs open, the computer shuts down. It did work a bit before when I first completed the setup but noticed that the CPU was idling at 80 celsius until I tried to log in and the computer shutdown. I tried to manipulate the BIOS according to similar problems shared here but still have the same problem. I'm open for suggestions and methods to fix my issue, thank you for your time.


Asus Prime X570p

Ryzen 9 5900x

TeamGroup Delta 64gb RAM

Samsung 970 evo 1tb

Radeon RX 6600 XT

Corsair Icue H150 Elite Capellix + 5 case fans

Evga 650w Gold Power

7 Replies
Big Boss

PalkiaSinnoh, with so little information it is hard to even guess but I will. I suspect your pump is not turning. Please post screenshots of Ryzen Master (RM) Basic view and Advanced view just idling. Thanks and enjoy, John.


Indeed, sounds like pump is not running. With a running pump and without running fans (only case fans) I can keep a 5950 cool.

Does the H150 100% power (I have connected it to PUMP on the motherboard and set that on 100% fixed.


Hi John,

Won't be able to screenshot at the moment, but I can confirm that the AIO is running with 2100+ rpm. It's just that the radiator rgb isn't lighting up. When idling, the cpu stays at 40c. I also tested this out where I fixed the rgb of the block but the cpu heats to 80c when idle. So I decided to sacrifice the lights for better cooling. As of now, my pc works with multiple tabs and heavier documents. But with any software or game initiation, the cpu instantly goes up to 100c and shuts down.

I also tried to lower the voltage of the cpu where it was initally 1.088. Same issue occurs.


Like others say, likely the pump is not running

OR CPU block is installed incorrectly.

Are you sure there is no thin plastic shield between CPU and CPU block?

Did you  use thermal paste?

Did you follow installation instruction step-by-step, so you didn't for instance use wrong parts meant for other CPU sockets?

Have you checked BIOS to see that AIO pump is running and is not for instance disabled? And you have connected the pump to AIO pump connector on motherboard, close to CPU and not just to some fan connector around motherboard? Or if your model supports connecting straight to power supply.

Do not connect pump to a regular fan header on motherboard.


AIO pump header inside yellow circle



Installlations is correct and AIO seems to be running. However, the block of the radiator doesn't light up. I had this problem before and tried to fix it. I fixed it and it wasn't cooling the cpu at all, causing it to shutdown. So as of now, I have it not lit up and it seems like the cpu is being cooled to the point my pc works and I can open hundreds of tabs and heavy documents. However, when I try to use any software or try to initiate a game, the cpu heats up to 100c which makes it shut down.


Thanks, PalkiaSinnoh. The maximum temperature is 90C, so it is NOT getting to 100C unless you have disabled PROCHOT which I strongly advise against. I recommend you stay out of BIOS except to set to default settings after doing a Clear CMOS using MB manual instructions. What is your ambient temperature? We need to see the RM SSs. Enjoy, John.


Hello, i had a similar problem with temps with my 5900x. When playing the tems were going almost 90ªC with aio NZXT Z53 240mm at full power. I was only able to have normal temps after changing to 360 aio. Now im playing with temps between 55-60 C