Showing results for 
Search instead for 
Did you mean: 


Adept I

Computer crashing constantly, 3600X

Hi recently 2 months ago I had upgrade my pc a bit, I bought a new CPU Mobo Ram and through some troubleshooting bought a new psu.

My current build- 

CPU - Ryzen 3600X

GPU-GTX 1060 3gb

Ram-Corsair Vengeance LPX 8GBx2

PSU- Cooler master masterwatt 750W Bronze

Mobo- ASUS Prime x570-P

SSD and 2 HDD's can find the names if It is relevant I have been having crashes for a long time now, and I have made several posts on different forums and not been able to get my problem fixed. Gaming or not gaming I still crash, I have checked temps my cpu under load hits in the 70ish area usually max is 76. I have ran Memtest to see if it is my ram did 4 passes 0 errors, Tried didn't frequency's. I have installed fresh copies of windows several times, I have updated my bios twice now. I did CHK check on my drives to see if they were making errors. SFC /scannow came up with a few errors and fixed them and every scan after does not find errors. People started saying it was my power supply so I swapped that out still no dice. I really don't know what to do I am a pc noob I can put them together but don't understand all the logs and stuff. Upon further investigation I found a error in Event Viewer

A fatal hardware error has occurred.

Reported by component: Processor Core
Error Source: Machine Check Exception
Error Type: Cache Hierarchy Error
Processor APIC ID: 0

The details view of this entry contains further information.

Event ID 18

I need help I don't know why this is happening and no matter what I do it doesn't fix.


45 Replies

Okay I have ran the scan again I did repair corrupted files but I have done this multiple times,  sometimes after crashes nothing fixes. I also downloaded the Bluescreen viewer and found me and that post have the same file that are causing problems I have this in my bluescreen viewer.

On the first dump the highlighted red program is 

ntoskrnl.exe ntoskrnl.exe+44f5ae fffff807`04e00000 fffff807`05e46000 0x01046000 0xed9dc31e 2096-04-29 7:01:34 AM

and the second dump I have 3 here are the following 

dxgmms2.sys dxgmms2.sys+a7a05 fffff801`35b10000 fffff801`35bf1000 0x000e1000 0x81055c4e 2038-08-05 4:09:34 AM

ntoskrnl.exe ntoskrnl.exe+2de1f7 fffff801`26c00000 fffff801`27c46000 0x01046000 0xed9dc31e 2096-04-29 7:01:34 AM

watchdog.sys watchdog.sys+3ad0 fffff801`351b0000 fffff801`351c8000 0x00018000 0x4493508b 2006-06-16 7:44:59 PM




May not help but have u tried to do a clean install of video card drivers.


I have tried at one point my friend set me an application that wipes the current gpu drivers and I reinstalled, I did a bit more research and I downloaded an app from AMD because my friend told me that armoury crate is trash so I tried downloading the chipset drivers straight from the site and it came with a bunch of other stuff. Ever since I have done that I have been stable so fingers crossed. Currently all my problems are pointing towards faulty cpu or bad drivers. So I will see if what I have done fixes my problem and update later.


Ok wanted to check because I was looking up some of the things in your dump file and a lot of what I found linked back to nvidia driver issues.Hope it all works out.


Alright well seems I was on a bit of a luck streak there, I just ran DDU wiped my video card drivers and reinstalled my nvidia geforce experience will update if it fixes.


I just replaced my motherboard still no dice... I dont know what is up with this piece of junk...