Showing results for 
Search instead for 
Did you mean: 


Adept II


By default edc limit 140A.

By default Core Perfomance Boost enabled in bios. 

Bios at factory default settings. 

Any idea? 



8 Replies

Sure if that's the error you got. Can you go in BIOS and turn down LLC or just set the EDC to the max manually? Is your cooler working properly? What CPU? Ryzen 5 is 90A. Chip should stop drawing mobo power at EDC limit without tripping an error by built in defaults. I've seen BIOS set the EDC to 999 and the CPU will only pull what it's limit is. Either way check that out and cap it.

"It worked before you broke it!"


Default bios settings

I am afraid to change the BIOS settings, as this may damage the processor.

At stock settings WHEA_UNCORRECTABLE_ERROR(run any game for 15-30 minutes)

Can power current spike > 140A(default bios settings for EDC) cause random reboot?

What causes the current surge:



3.Agesa bios?

How to find out which component is faulty?



I'm a noob at theories, but YES, it CAN and it DOES cause WHEA_UNCORRECTABLE_ERROR in X570 chipsets. At least in the present AMD ecosystem, with "BETA" (I'd say pre-ALPHA) versions of  MB bioses with which the system crashes at default BIOS settings.

Why - I have no idea. But the EDC current limit set to 200A is the only setting (besides turning off Core Performance Boost which turns the "best CPU on tha market" into a $100 crap) that eliminates BSODs and reboots at otherwise default settings. 

I don't think you'll destroy the CPU by giving it the "food" it wants, and if this destroys the MB then such an MB doesn't deserve the right to live. To be at the safe side, simultaneously set the power limit to 130W and the temperature limit to 83-85C.

Dear AMD, please look into this problem. It's very widespread, is a total shame and really spoils your image.

Heating is an important supplement factor to this issue, so please take your wonderful 5900x, some MB (an ASUS ROG Strix X570-E would be a good specimen, you'll enjoy it;)  some apartment-heater GPU (a RTX 3090 will do) , some below-average cooled case, put it all together, set the default settings in BIOS, make simultaneous CPU and GPU burn-ins, turning them off and back on every 5 minutes, and see what happens. Surprise surprise. Also please watch the chipset temperature in the process, you'll admire the wonderful design of MBs based on your most advanced AM4 chipset.

You can't damage the CPU if the CPU was made correctly. The board's VRM will shutdown first. Not knowing your motherboard make/chipset, etc. doesn't help narrow anything down. Ignore the warning in BIOS, it's a scare screen, means nothing. All Ryzen chips have a micro code to limit power draw to their specific max, so it doesn't much matter what the board is set to. Safe settings if you wan to use it is what @tim716  said. Put it at 130W, see what happens. This is sounding more like a bad motherboard. The CPU will be fine. It's nothing like the old days where it was easy to fry a CPU with one overvoltage setting.

The one setting to leave alone is Vcore for stability reasons mainly and never manually set that to 1.5v, that's an overclocking type thing you need advanced know how to mess with that. Your PC should run with pure defaults, setting the EDC to 130W is just a test, will harm nothing. Watts =Amps so that will lock the board into 130A max if the CPU asks for it, within safe limits. 

"It worked before you broke it!"

Dota 2 game testing:
Default BIOS settings(just changed EDC limit)

EDC(CPU) 80A - reboot in 0.5 minutes
EDC(CPU) 100A - reboot in 1 minutes
EDC(CPU) 110A - reboot in 0.5 minutes
EDC(CPU) 120A - reboot in 2 minutes
EDC(CPU) 130A - reboot in 0.5 minutes
EDC(CPU) 140A - reboot in 25 minutes
EDC(CPU) 150A - reboot in 14 minutes
EDC(CPU) 160A - reboot in 19 minutes

This only reboots during a game or load but boots fine? If so you have some RAM issue. Sometimes the error might show a CPU related error when it's RAM timing or the Infinity Fabric set above 1800. Some CPU's can only handle 1600 IF. Usually half the RAM speed is what to set IF at manually because leaving it on "auto" seems to do this type of thing. For instance I had my 3600X set at 1866 IF to match my 3733, so called "sweet spot" RAM and had CPU errors/crashing a lot. Sliding the IF to 1800 and setting timings for 3600 RAM, partly using DRAM Calc to get a "safe" setting fixed the issue 100%. You should really run Memtest 64 for 8 hours or 800% coverage minimum with no errors to validate the RAM no matter what.

Then we can look more at the CPU. Crashes with a CPU error during a game or mixed stress is usually RAM. I know, it doesn't make logical sense.

"It worked before you broke it!"

its not RAM - bios default settings. 


Did you run Memtest 64 for several hours error free? If not, can't rule out some kind of RAM issue.

Also what BIOS version are you using? Agesa Patch C is an issue and in such case you need to go back a BIOS to Agesa or 5000 series support, which ever is stable, or Agesa is stable for all Ryzen 3000 series CPU's. 

If none of these are helpful answers, and your RAM is on the QVL, contact your motherboard manufacture for further diagnosis. They can help you figure out if the board might be defective or the CPU, at which time they can recommend an RMA for either component.

Alternatively if you feel the CPU is at fault, ask the vendor for a return or AMD for an RMA. I'm not trying to give you an answer you want to hear, I'm trying to give you an answer that makes sense, and might solve the issue.

Motherboard defaults do not mean the RAM is "ok" or anything else is "ok", it means the board is running at default voltage, default settings and isn't a diagnostic tool unless an overclock was causing some issue.

Since none of us have "hands on" access to your PC, this is the end of the road. Anything else is "hip shot" diagnosis at best. 

So as to the original question "Can EDC(CPU) limit cause WHEA_UNCORRECTABLE_ERROR", we've all said "yes". Why you are getting that error is the next issue. I can pretty much ensure you it's  not a defective CPU. 

In any case, check the BIOS revision, noting that the "patch C" in particular has been a known issue for many. Run Memtest64 no matter how inconvenient or not making sense it seems to you for several hours to rule it out. It might run less than a minute and produce an error or it might take 300% coverage in 3 hours and hit an error, that means it's an issue. Even one error is bad. 

We've tried the manual voltage thing and one part is common, it doesn't seem to matter much and the game is when it errors, as per your saying. All you can do is eliminate reasons, like a poor BIOS revision, faulty PSU, bad RAM, bad GPU, defective motherboard, unlikely defective CPU, damage to the motherboard (scratched PCB by the CPU socket is common), some other short (bad fan even, power button). 

I'm sorry we have no "magical" answer to this. Too many variables at the moment. However, you must follow some diagnostic flow chart, written or your own to get to the root cause. Just saying "its not RAM - bios default settings" doesn't cut it and I've more than explained why previously. Good Luck! 


"It worked before you broke it!"