Showing results for 
Search instead for 
Did you mean: 


Adept II

Cache Hierarchy Error

Hello guys. Recently bought new pc parts. But after that pc randomly restarting itself.

I bought new PSU, still restarting.
PC Specs;
Amd Ryzen 5 5600x
Motherboard: Asus B450-f Strix Gaming 2
Ram: Corsair Vengeance RGB PRO SL 4x8 32 GB
Graphic Card (OLD): AMD R9 290 Sapphire Tri-x (Except GPU everything new on the system)
PSU (New): MSI MPG A750GF 80 GOLD 750 WATT (This is new PSU, system also restarting on my old PSU)
Cooler: freezer 34 esports
2 Sata SSD 3 Harddisk
Windows 11 (also tried on 10 still same)

Till today, i learned there is a Event Viewer in Windows which shows you issue. Well whenever i look up there i found the issue;

A fatal hardware error has occurred.

Reported by component: Processor Core
Error Source: Machine Check Exception
Error Type: Cache Hierarchy Error
Processor APIC ID: 0

The details view of this entry contains further information.

I searched on google and found lots of topics about this error, looks like im not alone, and looks like it's possible with couple of bios changes. Problem is i don't know bios setting well and i don't wanna broke my system more. Does anyone have this problem before and fixed by using bios? Thanks a lot!

4 Replies

Is your ram model on the asus qvl for 4x8gb sticks.

Also ask on asus forum for optimal (non oc) bios settings for your combo.


Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

No my rams not on the list. Oh i also tried with dual  ram single ram and no changes.


replace cpu by amd warranty - RMA cpu.


I'm thinking to do that, i was so hyped about new system that's really not cool