Showing results for 
Search instead for 
Did you mean: 


Journeyman III

brand new 5900x crashing

My old spec was

Ryzen 5600x

Rog strix b550-f

2x8 gb ddr4 corsair vengeance pro 3200mhz cl16

Corsair aio h100i pro (240mm rad)

Corsair rm-750x psu

Rtx 3080

2tb nvme wd black

With this build I had no issues ever. Then I decided to upgrade my cpu to cope with the bottleneck în warzone 2.


Bought a brand new 5900x and installed it. Only crashes came afterward. Even in idle or during windows startup. The error is mostly WHEA 46 but sometimes WHEA 18 aswell.


What I tried to do. Update bios to latest version, update Windows, update all drivers, reinstall windows. Replace ram with a 2x8gb forza 3200mhz cl15.


In the end I sent it back to the amazon seller and bought a another one from another seller (this was was AMD uk vendor)


Installed the second one and the same errors.

Bear in mind they were with stock settings. Even ram was at default 2133mhz

I fixed the idle crashes by changing the SoC Voltage from 1v to 1.1v but the gaming crashes were still happening.


I managed to make it more stable by changing several things:

Set fmax enhancer to disabled

Set pbo on manual and give the values of

Ppt 170, tdc 107, edc 160

Using OCCT and extreme 15 min test and using the results to configure a manual curve optimizer per core and ended with the following values:

-10 (this is core 0)
+1 (this is core 1)

With these settings the system is somewhat more stable. It still crashes once every 5 days while playing warzone.

Temperatures are alright. Average 75c while playing warzone with the aio fans and pump on balanced (around 2000fan rpm).


What would you suggest? Rma this one too and try again or just go for the blue guys?

2 Replies
Adept I

Signed up specifically to see this, i just today sent my 5900x Off for warranty check/service/replacement, i keapt getting very strange symptoms such as rapid browser crashes and freezing including upwards of 500 memory hard faults a second.

I suspect* my memory controller on the cpu has failed or is beginning to fail.

i cannot determine which, all i can tell you is after a fresh install of windows Sfc /scannow returned Corrupted files no matter how many times i formatted and reinstalled the drive and changed drives (I Reinstalled windows six times) same errors, if it where me, i'd contact AMD support and ask them.


Adept I

Kinda same thing here also WHEA 46&18. Brand new 5900X upgraded from 5800X, BIOS reset and clean install Windows 11.

BIOS is on latest stable version. With stress testing everything seems fine untill system is idle or starting a game.  Last thing I tried was setting RAM to manual speed DDR4-3200 FCLK 1600Mhz timings on auto. My game starts but with the 5800X everything worked fine.



Asus ROG Strix X570 E-Gaming

AMD Ryzen 9 5900X

Corsair DDR4 3600Mhz CL18 4x8GB

850W PSU