cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

theacclaimed1
Adept II

Avermedia Live Gamer 4K fails to wake on X670E Aorus Master

I think this is a UEFI/BIOS bug on X670E. When using the Live Gamer 4k capture card with the new X670e motherboard, the capture card does not wake from sleep/S3 standby. This also happens with hibernate/S4 standby. The only way to re-detect the card is to reboot or cold boot the PC. This card was tested and works fine with an older AMD X570 based motherboard as well as a Gigabyte Z690 board. The capture card is connected via a PCIe gen 4 x4 expansion slot connected to the X670e chipset. I tried manually setting the PCIe slot speed to Gen 2 in the motherboard bios since that's what the capture card actually uses (PCIE Gen 2 x4) but the issue persists.

System Specs:

CPU: Ryzen 9 7950X
Motherboard: Gigabyte X670E Aorus Master  | UEFI version F7e
RAM: Gskill Flare X5 32gb (2x16gb) EXPO profile 5600mhz
PSU: Corsair HX1200

I also tested with an older Live Gamer 2 in the 3rd PCIe slot which is only Gen 3 x2 and that card wakes from sleep with the rest of the PC just fine.

I curious if there this anyone else with an X670E motherboard running into similar issues with PCIe Add-in cards, specifically with an Elgato 4k pro card.

0 Likes
4 Replies
theacclaimed1
Adept II

Anyone else on AM5 and running into this sort of problem? I think there is a firmware bug with the X670 dual chipset design where if a PCIE add-in card is connected to the secondary chipset it will disconnect if the PC goes to S3 standby. Upon waking up the PC the AIC remains disconnected until a reboot.

0 Likes

No experience, but I would try this setting as it is supposed to affect how PCIe devices for instance wake up from sleep:

MADZyren_0-1666158046596.png

I would set this to Off for testing

0 Likes

Mine has always been set to Off.

0 Likes

Then disable sleep and hybernation

0 Likes