Showing results for 
Search instead for 
Did you mean: 


Journeyman III

Any way to turn off this stupid power-saving feature? (Ryzen 2200g)

So I've bought a 2200g and it's doing good, but has a seriously annoying feature, my problem in an example:

I'm playing Forza Horizon 3 on my 2200g APU, with unlocked framerates my fps is around 40-60, gpu clock is running at 1100mhz (sometimes drops to 1000 making the fps drop too, but not too noticable)

I figure that fix 30 fps would be better than jumping between 40-60, so I set my fps limit to 30 and boom, I can barely hold the 30 fps because this stupid power saving mode kicks in, the gpu clock is only running at 400mhz ruining the whole thing.

The same thing can happen with unlocked framerates, for example I'm playing wow with 80 fps then suddenly it goes down to 30-40 fps, and when I check the gpu clock it's 400, then it goes back to 1100 and I get my 80 fps back.

I've a gigabyte 320 mobo with newest bios, I have the newest amd chipset driver, the newest apu driver. I've tried setting the gpu clock in bios to 1100 hoping it would force it but no, it doesn't make it keep it, it still goes down to 400 when not under heavy load. I've tried ryzen master, nothing. There is no option in bios that would turn off this stupid power saving mode.

Any solution? The best one would be a way to force this stupid thing to don't go into idle mode unless I let it.

Describe your system:

  • AMD Graphics Card
    • Ryzen 2200G APU
  • Desktop or Laptop System
    • Desktop
  • Operating System
    • Windows 10 64bit
  • Driver version installed
    • 18.5.1
  • Display Devices
    • LGW2242BP 22" hdmi-dvi cable
  • Motherboard + Bios Revision
    • GIGABYTE A320M-S2H-CF, Bios Version F22
    • Ryzen 2200G APU
  • Power Supply Unit  Make, Model & Wattage
    • E.g. NPOWER 500W
  • RAM
    • 2x8GB 2400mhz
4 Replies

You need to provide more computer information as per AMD Forum rules: INFORMATION REQUIRED WHEN POSTING A QUESTION

Is your computer a Desktop or Laptop?


Thanks for the info, edited the post.


Any options in 'advanced power settings' ?

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro..

Everything is set to max performance in windows energy settings

These are all the options I have in BIOS, they don't seem to help either. Tried changing these a thousand times, to no effect sadly.

Imgur: The magic of the Internet

Imgur: The magic of the Internet

Imgur: The magic of the Internet