Showing results for 
Search instead for 
Did you mean: 


Journeyman III

AMD RYZEN about disable turbo core

Hi. I have a r5 2400G which base clock is 3.6 ghz. The problem is even in idle it reaches to 3.8 - 3.9 ghz. So, I wanna turn off the turbo core but I can't find a way to get it. My mobo is a form factor mobo from hp (sunflower type) with a b350 chipset. I tried setting max processor energy to 99% but cores only get 2.3 ghz. Is there another way to make it? I was thinking using ryzen master but I read is a overclock tool. I just wanna disable the turbo core. I'd like amd devs encourage hp to add a turbo core function in bios  

4 Replies

In Windows power plans, there is a setting called 'Processor performance boost mode'.  It is hidden by default so you can't see it in Control Panel.  However, you can access all hidden settings using a program called Quick CPU.

Download/install QuickCPU, go into Power Plan Settings, and search for 'Processor performance boost mode'.  Setting it to Disabled will prevent the CPU from boosting.

Alternatively, there is also a hidden setting called 'Maximum Processor Frequency' (not the same as Maximum Processor State you see in Control Panel), and it's exactly that - you can specify the maximum frequency in Mhz, and the CPU won't go past that.

Once you save changes, all of the settings become unhidden in Control Panel power settings and you can change them from there.  But QuickCPU has a much better UI.



Hi. I unhide Processor performance boost mode and Maximum Processor Frequency using registry edit method. Then I set 3600 mhz as maxium frecuency and disabled turbo boost mode but it doesn't work. I has 0 effect on my processor. 


If you've made the power settings changes correctly, and set the plan to active, it should work.  The only thing I can think of that would cause it to not work is if there is some other utility software running that is taking control.

If you bought this system as a prebuilt computer, maybe there's some HP software running in the background that is overriding the Windows power plan.



Hi. Yeah my deskptop is a pre built hp system. It's a hp pavilion desktop gaming. I set power plan as balanced then well I unhide the max frequency as 3600 mhz -but some ppl told me that's only for laptop- mmm setting max processor energy to 99% makes the cpu runs only to 2300 mhz. I verified bios but i couldn't find any way to disable too -it's a sunflower mobo- it'd be cool hp add an option for that. My other two options is ryzen master but idk if that disable turbo cores due i guess that's for overclock and trottlestop