Showing results for 
Search instead for 
Did you mean: 


Journeyman III

AMD Ryzen 9 5900X random reboot


I have a brand new system which worked fine for about two weeks and than all of a sudden it starts rebooting randomly. It started with a few reboots a day, than it wouldn’t start Windows 10 anymore, because it reboots during the login.


The Bios and AMD chipset have the latest versions. The only way I can get the system from rebooting randomly is turning of the PBO and CPB, now it’s only random reboots a few times a day.

The rest of the bios is set to default, no overclocking, it’s running at 3,7Ghz and still not totally stable


I do mostly GPU rendering work, so the CPU isn’t stressed at al, it’s definitely not temperature related the CPU is around 35C.


Any advice please.



My system:

AMD Ryzen 9 5900X


D432GB 3200-16 Ripjaws F4-3200C16D-32GVK

ASUS TUF Gaming GeForce RTX 3080 Ti OC

1TB 7.1/5.8 MP600PRO XT

Corsair RM850X

NZXT AIO X63 280mm

Windows 10 Pro

4 Replies
Adept III

It's due to ZEN 3 broken architecture. You can try RMA. Didn't work for me and many others, but, can work for you.

You can find my complete Odyssey bellow:

Re: Ryzen 5000 Crashes (WHEA Errors) will get a "S... - Page 5 - AMD Community 

Journeyman III

I'm having the same problem. I used an AMD Ryzen 9 5900x in my new build about 3 weeks ago, and last week it started rebooting randomly. Now it reboots so frequently that the computer is unusable for anything besides web-browsing.

I've narrowed it down that the 5900x is causing smss.exe to crash, but I don't have a solution. I'm planning on RMAing and giving it 1 star if I can't get this fixed in the next 2 days.

CPU: AMD Ryzen 9 5900X
Mobo: MSI MPG B550 Gaming Carbon Wifi
GPU: RTX 3080 Ti

I just came across this and would like to say I have exactly the same set up as you and experienced exactly the same thing with my deteriorating 5900x.

The sad bit is I bought it from my local shop and lost my receipt. AMD is refusing to take on my case because of this. I believe they are now making RMA as hard as they can be because they know they have a faulty product and is now putting that responsibility on us consumers and completely turning a blind eye to it.

I am now going to everywhere I can to spread the news regarding this faulty processor that they are selling and absolving themselves of any of the predicaments that us consumers are suffering because of their ineptness.

Just like how this thread has been treated with absolute silence from the AMD support team here.

Adept III

Try using OLDER BIOS ideally from Agesa V2 PI Patch A to AGESA V2 PI Patch B
It fixed the reboots for me, it's the only thing that have worked so far. Just make sure that it supports the 5900X