Showing results for 
Search instead for 
Did you mean: 


Adept I

AMD Ryzen 7 3800x or something else?

So I have a Ryzen 7 3800x with an Asus Rog Strix B550-f motherboard and im having this issue where my computer would originally just shutdown and would restart completely on its own and now it will reset  before even posting. I get half way through the boot cycle after the DRAM and POWER lights flash I see the light for VGA come on and then it flashes back to the DRAM light like it’s resetting itself over and over. Previously I would get to my bios and would even see the “Diagnosing Repair” screen from windows and I can’t even get the machine to show me my bios now.  

The reason I believe it is my processor is because I have replaced every single component and I’ve actually purchase the exact some model motherboard and am still having the same issue on a new mother board. And when I say every component I’ll list everything I’ve swapped so far.

Motherboard for the exact same model(also flashed to newest bios version)

New Ram kit 


2 new PSU’s (after the first new one didn’t work I purchased a 750w gold)

and I used a family member’s graphics card to no avail…

This leads me to my shocking conclusion, I had this CPU replaced by AMD for the exact same model, when the new cpu arrived everything worked without flaw for about 2 weeks until today the problem reoccurred and now my PC won’t even post. This seems like such a complex problem and any amount of input would be very much appreciated!! 

8 Replies

Since it won't post, Which Motherboard Trouble LED Light is lit and stays on?

Let BIOS determine which hardware is having the issue.

Anyways to narrow down the hardware possibilities you need to disconnect everything from the motherboard except the CPU and PSU and that it.

Power on and see if the Motherboard CPU Trouble LED light turns on then off and the RAM Trouble LED Light turns on. IF it the CPU Trouble LED light stays on that indicates that the CPU didn't pass the BIOS test during its check. But if it turned off and then the RAM Trouble LED light came on that indicates, at least, that the CPU passed the BIOS hardware check.

Now install just one stick of RAM MEMORY and see if the RAM Trouble LED light turns off and the VGA Trouble Light turns on and so forth.

NOTE: Make sure the RAM you choose is from the Motherboard's QVL List for Memory for your Processor to prevent any incompatibilities.

When you install the GPU Card make sure you have it connected to a Monitor.

If all else open a AMD Support -Warranty and see if they believe your processor needs to be RMAed from here:

Yes especially the VOLTAGE of the RAM. This is more important than the RAM speed your motherboard support specs shows. undervoltage or overvoltage RAM not supported by your MOBO can temporarily work but cause severe problems. Like your MOBO may only support 1.35 volt RAM and you may be using 1.15 volt or 1.5 volt RAM.

Its also a good idea to start your build with non overclocked base line RAM so you have RAM to fall back on in case future upgraded RAM starts to go bad.  

Hey there Elstaci! So I followed your instructions and removed everything besides the cpu and motherboard and I was getting a DRAM error light so clearly that is working. I installed one stick of Ram as you mentioned and I’m getting the same loop where I’ll see my DRAM light, then my CPU light, then lastly my VGA light. It never makes it to the boot light and will continuously repeats those three lights until I power it down. My Ram kit is indeed on the QVL list it’s just strange I can’t make it to bios. 


That set of MOBO could have a batch of corrupt default bios. I know how to flash a bios if it comes up but I can't remember how to force a bios update or boot up via a usb drive to get this guys computer up and running. I know there is a way to boot bios via usb without installing just cant remember how.

Is there someone that can help him out with this.

Wait have you tried clearing your CMOS. That could clear any errors that is blocking the bios from posting.


Sounds like you definitely have a hardware issue. Because when you first boot up no drivers are loaded and BIOS first checks all hardware connected to the Motherboard before allowing it to boot into Windows.

Since you replaced the Motherboard and PSU and RAM then It sounds like you have a defective CPU.

But @ThunderBeaver made a good suggestion about doing a CMOS CLEAR on the motherboard. This will reset BIOS back to factory default settings.

One to way to check if it is the CPU is by installing a another CPU and see if it does the same thing or not. IF it does then you have a defective CPU but if it doesn't then you probably have a defective Motherboard or RAM.

If you can find a Computer shop that will cheaply install another CPU, if you can't find a Family or Friend that can lend you one, That would be the best route.

Open a AMD Support - Warranty Ticket and see if they believe you should open a AMD Warranty ticket to RMA your processor from here:

Or you can just open a AMD Warranty Ticket from here:

NOTE: AMD Warranty goes into effect as soon as your Retailer/Vendor's Warranty or Return back date expires. Also the AMD Warranty is only good on official Sealed AMD Retailer Box processors.



Everyone’s input has been extremely helpful! So I cleared the CMOS and that had no effect. 

I actually had this same exact issue about a month ago and I had RMA’d my processor through its warranty to AMD and it passed inspection. They sent me a new one and the same problem started happening randomly again on this new CPU. That’s why it’s kinda hard for me to believe it’s my CPU. One thing I’ll say is when I replaced the motherboard and the same issue was happening I took that new one back because I was strapped for cash so if AMD accepts this RMA on this new cpu I’ll buy a whole new motherboard too since I have a feeling it’s causing major errors in the cpu somehow. 

I have encountered specific problems with ASUS MOBOs and their support of AMD CPU's in the past. They will have a list that shows your CPU is supported on the ASUS website but you will get a no post. Checked with their support bios update and their BIOS for that specific CPU was available in China but not available to the US for 6 months to a year. This is personally why I will not use ASUS products. This is just my personal experience and it was a bad one. I won't try to sway you in your choice of hardware just provide truthful information from my own experience. Good luck and hope your build learns to call you daddy.


@Astral98 Hmm, so basicly you replaced every mayor component right? Cpu as in rma, mem, mobo, ssd and PSU?

Is GFX connected with a riser-extension/cable? Check pcie power on gpu and PSU side and check the cables

Can you get into bios at this moment? If so, could you check the voltages of 3.3v, 5v, 12v and vcore? Vcore should be below 1.4v for example.

Also, you could try a bios downgrade by using bios flashback and a usb thumbdrive. Make sure to reset to factorydefaults before and after bios flashing. You could even remove the CPU and place it back after flashing. Though if possible check voltages, and remove riser first!

And before trying bios access, unplug mains, turn system on, wait 3 sec, plugin powercable, turn-on, Access bios (well, try )

Check voltages, mobo might be pushing way too much voltage to CPU. Bios could break 3800x support. And you could even check your 12v motherbord/CPU power connector on both mobo and PSU side.