Showing results for 
Search instead for 
Did you mean: 



AMD Ryzen 7 2700x - Games Crashing


Motherboard - Asus x470 Prime Pro

CPU - AMD Ryzen 2700X, No overclock

RAM - Corsair Vengeance LPX 32GB (4X8GB) Default 3000mhz 15-17-17-35 1.35v

GPU - Zotac 2080 ti 11GB

Boot Drive - Samsung 860 EVO 1TB

PSU: Corsair rm1000i

OS: Windows 10 Education 1909

I keep having issues with games crashing and it seems to be linked to Directx11 crashing. I have reinstalled windows at least 10 times in the past year. I've tried to update Directx11 only for it to say I have an up to date version. I've done all of the windows updates. I've tried using 1903, 1909, and 2004. It still crashes. Graphic driver, Chipset and BIOS are up to date. Temps are fine. It's happening with every single game. Risk of Rain 2, NFS Heat, R6 Siege, Rocket League. It was only Risk of Rain 2 at first but now it's happening to all of my games. I am so confused on how DirectX11 can be broken on a fresh install of windows. Dxdiag shows "No problems found". I've tried using memtest86 and it throws 400,000+ errors after the second pass. I've tested all of the sticks individually and they all tested fine. I've tried changing the timings and speed, only for it to continue. I tried using the Ryzen DRAM Calculator and my pc wouldn't boot after so I changed it all back. I've tried defaulting the BIOS - no fix. I've had three different GPUs, two different mother boards and three different kits of RAM. Someone on Reddit suggested that the Zen+ CPU can't handle the clocks on the RAM. I don't want to have to upgrade to Zen 2 just for this.

4 Replies

AMD prefers dual channel,not quad.And Ryzen works better with 2 sticks of Ram,not 4.Also try only 2 sticks in B1 and  B2(grey) slots.


Motherboard - Asus X470 Crosshair VII

CPU - AMD Ryzen 2700X

RAM - Corsair Vengeance Rgb Pro 32GB (2X16GB)  3200mhz 16-18-18-36 1.35v

GPU - ROG Strix RX5700XT OC

Boot Drive - Samsung 970 EVO Plus m.2 1TB

PSU: Corsair HX1200i

OS: Windows 10 64 1909

0 issues no crashes on any games so far


use windows 10 v 2004 and there is a hotfix driver 451.85 which solves some but not all problems

check to make sure your MB has the latest BIOS installed

Journeyman III

Hi, I'm having the same issue, Have you fixed this already?


Read this:

Best thing you could probably do is sell the Zen+ processor and buy a Zen2 or Zen3. 

The Zen+ Memory controller is pants.

Good luck.