Showing results for 
Search instead for 
Did you mean: 


Journeyman III

AMD Ryzen 3950x Reboot Issues

I built a 3950x based gaming computer earlier this year and I'm having a weird reboot issue. Modern games run great like Escape From Tarkov, Doom (2016), and No Man's Sky. However, when I try to run games like Borderlands 2, Grim Dawn, and even Terraria, the system reboots randomly. Sometimes it's a few minutes in and sometimes it's immediately! No BSOD, just a black screen and reloading windows. Even 1Password crashes it sometimes.

The most consistent way to make it crash is to run Unigin Valley Benchmark. It reboots almost immediately after Valley Benchmark goes full screen. That being said, I can run blender benchmark and Cinebench just fine. I also ran memtest86 with no problems detected.

No overclocking has been done on the motherboard at all, only the memory timings have been changed to comply with their respective specs.

I have updated the motherboard bios and all drivers and swapped out the following for known good ones: GPU, PSU and cables and Memory. I also tried downgrading the GPU drivers, as well as the nVidia Studio drivers. I've also reinstalled Windows 10.

Also, all of the temps are nominally around 40C.

System Build:

  • AMD Ryzen 9 3950x (00330-80212-51266-AA861)
  • ASRock x570 taichi MB (90-MXBA80-A0UAYZ)
  • nVidia GeForce RTX 2080 Ti (G150 0032) (tried at both PCIe Gen3 and Gen4 settings)
  • 2x G. Skill 16 GB DIMMs (f4-3600c18-16gtzn)
  • EVGA SuperNOVA 1000 G5 PSU (220-G5-1000-X1)
  • Samsung 970 EVO Plus 1GB M.2 SSD (MZ-V7S1T0BAM)

I'm at a loss here. I've tried everything that I can think of besides a different OS which would kill the whole gaming thing. Anyone have any Ideas?

1 Reply
Journeyman III

Re: AMD Ryzen 3950x Reboot Issues

Try to test your memory without xmp profile or add some voltage for dram like 1.36v or 1.37 and if not help, you can try add cpu offset voltage +0.05v and test again. For me only set +0.05v or enable pbo helped resolve problem with random reboot and bsod.