Showing results for 
Search instead for 
Did you mean: 


Adept II

AMD Ryzen 3900X stuck at very low (500 Mhz) frequencies on several cores

Hi all,

I am seeing an issue wherein my AMD's 3900x core 0, 1, and 2 are stuck at around 500 Mhz clock speed. All the other cores are running as expected, except for the first three.

This issue is intermittent.

I have attached screenshot from CPUID HWMonitor:


I let my system run for about an hour now, and these frequencies have not changed. A Reboot will surely fix the issue. 

Is anyone else experiencing this issue, and knows how to resolve it?




G.SKILL Ripjaws V Series 32GB DDR4 3200 (PC4 25600)


199 Replies

I believe this bug can hardly be mistaken as anything else by those who experience it and I'm afraid it has been overlooked by AMD. I was just stressing the point to avoid any possible misunderstanding on the validity of this issue. Thanks for your input on the power plans btw. Cheers

Journeyman III

After reinstalling windows for a third time and a few bios resets the issue seems to have disappeared from my 3600x. Now I´m even running the amd hp powerplan, pbo and overclocked ram at 3200cl14. Still have no clue what the possible fix was...



Well done !

don't forget, windows is not always the same, some KB on April and May have created many issues silently.

Adept I

Well I uninstalled *everything* that smelled even remotely like proprietary or monitoring software like AI Suite, MSI Afterburner, FanExpert, all AMD related stuff, killed all processes that weren't absolutely necessary and deleted their directories. Then I reinstalled only the mandatory motherboard drivers and ...well, as you can see from the picture below things have gotten better and I've had no issues since with clock speeds.reliability.png

Adept I

It was may 10 when I was here with this same issue. At that time this happened at least 2-3 times on a week. On a random site it was suggested that the CPU Vcore in the UEFI/BIOS should be changed from auto to normal(I've a gigabyte x570 mobo, so I don't know how others would behave). Then I changed only that, and I never had this problem since then. I use the PC every day at least 12h.

Other change was that I installed 2 linux distributions on my other ssds but I don't think that this should be related in any way.

Thank you for your suggestion!

Hope this solves the issue for at least some of the people here!

But sadly this didn't do the trick for me.

I have a x570 Aorus master (f11) and I turned this option from AUTO to normal yesterday.

Yet today the same problem has just occurred. To be fair, I got 4-5 cold boots without the issue before this happened.

Nevertheless AMD suggested me to RMA the CPU as soon as possible since it could be just a faulty unit.

It sure looks like a power management problem though!

Journeyman III

Hey guys,

just wanted to share my experience with the issue:


MSI X570 Ace (Bios 7C35v17)

Ryzen 3800X with IF @ 1867 Mhz

16 GB HyperX Predator @ 3733 Mhz CL16

Windows 10 (1909)

Yesterday I made the switch from a Noctua D15 aircooler to an Enermax Liqtech II AiO, I happened to have laying around. It was more of a test project, wasnt expecting huge gains in cooling performance.

Either way, I installed the AiO and booted to Windows 10, had some test running and all was fine and dandy with Temps in the expected range (35 - 50°C Idle and 70°C under full load).

I shutdown my PC, went to bed but couldnt sleep, so I turned it on again about 1 hour after the shutdown.

In Windows 10 it was immediately apparant that something was off. Sluggish mouse movement and extremely long app loading times.

I started hwinfo and checked the sensors. The 3800X was sitting at around 500 Mhz all-core clock.

I went ahead and started Cinebench R20's allcore benchmark. The CPU kept the clock at around 500 Mhz.

I checked the energy settings and the PC was set to "High Performance" (non-AMD plan). I didn't recall setting it to this plan, so I switched to "AMD Balanced" and immediatelly the clocks went up to their usual values, the PC was reacting normally again.

After that I installed the newest Chipset drivers and the newest version of Ryzen Master (had an older version from late 2019 installed before). Restarted the PC multiple times, without the error appearing again, so it might've been a one-time thing or I fixed it with my trial-and-error.

What seems odd to me is the proximity of the appearance of the problem to the cooler change and the fact that the machine was running flawlessly for 9 months before. At first I thought I might've tightened the retention screws of the AiO a bit too much or the backplate might be shortening something on the backside of the socket, but hopefully this really is a software issue.

I'll keep an eye on this and will report back in case things get worse. I'm glad I found this thread!



Journeyman III

Hi, just here to provide another data point as I have exactly the same issue.

Really disappointed to have such an expensive piece of hardware have such stability issues.

It's my first AMD CPU in a very long time. Not sure I'd pick it again in hindsight.

Ryzen 9 3950X

Gigabyte X570 Aorus Xtreme

32GB (4x 8192MB) G.Skill Trident Z RGB DDR4-3866 DIMM CL18-19-19-39 Quad Kit

EVGA SuperNOVA 750 P2, 80+ PLATINUM 750W

> It's my first AMD CPU in a very long time. Not sure I'd pick it again in hindsight.

Same here, first AMD in decades and I've had multiple issues from the beginning.

Next PC update will most likely go back to Intel unless they sort this out.

Journeyman III

hi guys i have MSI B450 Tomahawk and 32 GB RAM G.skill, and ryzen 3600 i got the same issue from yesterday , i bought new PC. And my frequency from cpu and ram goes really down to 23 mhz or 500 mhz. I tried 1Usmus, many power options, diable some power speed boost in win10 and core boost performence, Nothing help me. My pc fix after some mins Alone that power issue but its really weird when i start my pc and he is really slow of this issue. i try also a new beta bios and newest chipset driver and nothing help.


Clear CMOS, leave everything default, reinstall Windows without Ryzen Master, AI Suite and all the other OC software, except maybe HWiNFO.

Still at 0.53ghz  


have you tried 'Advanced/AMD Overclocking/AMD Overclocking\SoC/Uncore OC mode' (Forces CPU SoC... to run at their maximum frequences at all times.) in BIOS if you have it?

(I've used it in ASUS TUF Gaming+ and I think that it solves this)



i dont think i have this setting in my msi bios. ill check! thanks


If you find it, check with some other ppl before trying, to be safe.

My CPU is Ryzen 5 3600, when I used 'tuning' option it determined the max frequency was 3950 and it used that. I had to manually fix 3600MHz so it doesn't get overclocked.


Hello geroxir,

remove all previous chipset drivers and 1Usmus, reboot and install latest one from MSI ( or AMD website.

Same as 1Usmus power plan is already in latest chipset drivers since march.

Also try latest BIOS and set in BIOS [Advanced CPU Settings] -> [Power Supply Idle Control] and change the value to [Typical Current Idle] if not already set.

Yes i tried this too nothing help. I tried also the bios version and dont help . the power supply tried too and nothing change. I also tried off the c state and amd cool n quiet too. No change :/  tried also 2 time installing windows. The issue is when i install gpu driver. When i installed fresh windows was good. after GPU driver the frequency jump. I think the problem is in GPU Driver , when i startup my windows , the driver is crash and turn again on before crash got lags and issues with processor and ram and after restarting amd driver its working all fine. its there any energy options or so ?

Journeyman III

I found the problem , finally my pc working fine, on normal frequency and ram 3600 withous any issue.

The amd graphics card was crashing at start system, i taked bios battery for 10 min, and changed pci slot for graphics card now its fine. In system power energy is amd high performence in bios is everythink like auto after restarting battery. Just changed speed ram anything else is standard. Now finally after 2 days working on this it works  thanks you guys for u help too 


hi geroxir,

don't forget only PCI-E slot 1 have x16 lanes, other works at x8 or x4, so your graphics card will not work at it's full speed.

Journeyman III

I too am having this problem. All eight of my core clocks sometimes boot up to 523.3 MHz. We've all seen the HWiNFO screenshots that show the wrong clock frequency by now, but I would like to focus on something a little different, the Core Ratio.

HWiNFO64 v6.28-4200 Sensor Status 7_10_2020 8_53_11 AM.png

As you can see, all eight of my Core Ratios are 5.5. Normally you would expect something between 35 and 44, or so depending on your chip model. I'm using Ryzen 7 3700X on an ASUS ROG Crosshair VIII Hero motherboard. I never overclock. As others have reported I can clear out the problem by momentarily switching the power plan to some other setting. I only started having this problem recently.

I'm worried because this issue is cropping up with greater and greater frequency. I really don't have any good ideas now. I'm just trying to keep this thread alive and hope some other people can comment with their experiences.

Yup! Similar view from where I stand. 3950x whith two cores stuck. More often than not though cores 12 to 15 seem normal and the rest of them stuck at 5.7. I've been having this annoying issue since April.


I've tried any workaround I could find. Nothing worked. Either bios, windows, or driver related.

AMD has assured me it's a faulty CPU unity issue. I'll be sending this CPU back as soon as my work schedule allows it. I will then be able to post here my observations about the replacement. Cheers.

Journeyman III

I have this issue too on my 3950x, it only happens when I first boot up cold.  It also happens on all cores and the frequency it gets stuck at seems random.  I have seen it between  400MHz and 2GHz and everywhere inbetween.  I am using the Ryzen power plan in Windows with PBO enabled in BIOS.  Motherboard is ASUS ROG STRIX X570-E Gaming.  I keep updating the BIOS and chipset drivers whenever I see new ones come out but they have yet to be fixed for me.

The work around I have found in the mean time that seems to solve it for me, is that I open Windows power plan section and just switch from Ryzen Balanced to Ryzen High Performance or vice versa.  Switching from one to the other clears up this issue for some reason.

Journeyman III

hi, i read on a other forum to replace amd sata driver by ahci sata  from microsoft to fix issue

poor performance and some buzzing noise and,mouse freezing.

latency from storport.sys are the main problem from dpclat report

thanks to christoph on overclock forum,i hope this can help you!



3950x, Gigabyte Aorus Master x570 (rev 1.0). (3700x also tested, exhibits same behavior)

I've updated both the bios and the backup bios a couple of weeks ago to f20.

The problem hasn't reared its ugly head since then. I'm keeping an eye out though since you never know with these things.

All settings to default/Auto apart from XMP profile.

I had contacted Gigabyte for this issue quite a while ago and got nothing serious in response. Just a tip to disable AMD cool n quiet from bios and a vague suggestion to disable "other power saving options". I wouldn't necessarily suggest disabling AMD CnQ because people have been reporting issues with it either on or off.

The f20 bios description states that it fixes the security vulnerabilities for SMM Callout Privilege Escalation, and apparently all motherboard vendors have rolled out or will roll out updates with this fix. I'm not sure if this is in any way related.

Hope this somehow helps! Cheers!

EDIT: removed link to tomshardware article on SMM CPE

Journeyman III

I have same issue with my 3600x and we have same exact motherboard which is interesting.  

Journeyman III

It's interesting this issue happens for some users with Bristol Ridge as well (according to this thread) with different motherboard vendors. I had similar (I'm 99% sure it's the same) issue under Arch Linux with Picasso APU, with frequency stuck at random state (where CPU freq state is at the time bug happens). Solved it by rolling back to the specific UEFI version (2.30 for ASRock A320M-HDV R4.0 motherboard).

I've found semi-consistent way to replicate it under Linux tho:

1. Start Dolphin Emulator, run GC image (F-ZERO GX NTSC-U for example), let it loop in the background. Or any (? I know for some WINE) 3D application.
2. Start monitoring CPU/iGPUfrequencies:
watch -n1 grep \"cpu MHz\" /proc/cpuinfo
watch -n1 sudo 'cat /sys/kernel/debug/dri/0/amdgpu_pm_info | grep "MHz"'
3. Do whatever on the PC, wait (anywhere from 5 minutes up to a few hours = random) till frequency locks.

I've tried multiple kernels, governors etc., so software is rulled out completely, especially now when I know that one specific UEFI version does not replicate the bug.

Can you guys test it so we can see if this is the same issue? It sure looks like the same, behaviour is the same.

Journeyman III

I also just had this with a 3700X. Half the cores went 535 mhz. Had it for the first time since I build this PC in July 2019. I'm on a x570 TUF Gaming Wifi with 3733c16 ram. Is it possible that it is linked to the LLC (Load Line Calibration) setting? It is the only BIOS setting I touched recently in and since I never had this before, I wonder if it has anything to do with it. I changed the LLC from Auto to Level 3.

Adept II

This issue is happening with my Ryzen Threadripper 2990WX on MSI X399 MEG Creation motherboard. 


Maybe the only solution is to use the warranty and ask amd for a cpu replacement. Looks like everyone having the issue tried everything to fix it, but nothing really works seriously...

I have same issue, i updated recently amd drivers through msi dragon center. I have a 3700x with a b550 gaming edge wifi... tried almost everything... i think im gonna ask amd tech support...


ASUS ROG 370-F Gaming + 3950X

1 of 5 computer loading show me this result (0.56 GHz).  Reboot helps




Hello there guys I just created an account to bring this topic back to life again since it's been a while we had a discussion on what this issue could be. 

I bought this CPU from overseas (China) with box and serial numbers, all good. It all went ok after using it for the first months but then RANDOMLY sometimes some of the cores simply go to 0.54GHz as mentioned by our friends previously. 

I hadn't done what you have done regarding changing power plans cause I didn't know it could help by the time it happened to me (13.01.2021) and I just restarted my PC and it solved it for now.

Not sure what's causing the issue but how likely would it be for us to have different lines of processors that behave the same only from 2020 and so on? It seems like a software related issue rather than a faulty one. 

Below I will share a screenshot of the incident: 


RAM: 32GB 3000MHZ #CL15 - 1.35V


Thanks if anyone could revive this topic again! We need an official statement related to this issue.

Me too. I've had a R5 3600 in a ASRock Phantom Gaming B550 for 4 weeks and this morning (at cold boot) I had this problem where it's stuck a bit over 500 MHz. Reboot fixed it. All stock clock/ voltage settings. 3200 MHz 2x16G memory.

So here's what I think's happening. It's a hardware problem or hardware boot up problem. When the BIOS/ chipset starts the CPU, it has a clock oscillator that starts and then a Phase-Locked Loop (PLL) needs to sync to set the frequency multiplier to the final value. I expect it starts the PLL multiplier at a lower value... like 5.5x which is around 500 MHz... to do some of the POST. Later, it steps the PLL up to the final value. So sometimes for these CPUs, this PLL multiplier change fails to synchronize and it's stuck at the lower frequency. I'm certainly speculating but the problem is in the first second after power up.

We are not going to fix this playing around with Windows settings, power save options, etc. AMD need to fix this, or support the mobo devs to get their boot sequence working reliably. A BIOS update could potentially help. Certainly disappointing to see this problem is so old and not resolved. 


That's a good hypothesis though addressing the hardware as faulty for me does not make sense since there are so many people with the same problem but who knows. 

Weird enough people have said that simply changing the power plan "wake" the cores who are stuck at 500+MHz. I haven't had the problem since so I could test it myself. I have updated my BIOS (AMD AGESA ComboAm4v2PI Beta) to the latest one and also the AMD chipset drivers. Let's see if it fixes it. 

I will once again do a clean install of Windows LTSC to see if there's something in Windows Pro corrupting the system for some reason..


We're all here because we have a Ryzen CPU. Why couldn't it be a hardware problem? Even if you swap the CPU you have not changed the CPU design. Every one of these parts coming off the line might have some chance of not starting correctly. It always (from the posts I read) happens at cold start after it's been off a long time. So maybe low temperature makes the issue more likely. Whatever it is, only AMD could have really fixed it. 

You're right about that theory but what makes me think about another thing is that some users have reported that even having their cores stuck at 500+MHz the moment they changed the power plan from high plan to balanced the cores who were stucked simply woke up and everything came back to normal. That sounds like a software issue for me. AMD is giving zero f## about all of this though. That's why in the future I'm gonna be changing to Intel..


Hi everyone,

I would like to tell you that today when I turned on my PC after I woke up, I also noticed this. The 8 cores were running at 571.25MHz. My BIOS settings were in stock only I applied the XMP for the RAM. I am using the Ultimate Performance Windows 10 Power Plan.

I just loaded the BIOS defaults, applied again the XMP for the RAM, rebooted and everything is normal again. I know this is not about the 3900X but while it happened in 5950x I thought it would be useful to post it here.

I don't know if it had to do of course with some changes I was making to the PC FANS speed by checking them at default and max speed for a short time.


So you're saying this problem is also happening to their newer generation? **bleep**! This does not seem like a hardware fault then. Most likely it's a software related thing (probably conflicits within AMD chipset drivers itself). Just out of curiosity what set of memories are you using as RAM? Mine are corsair vengeance rgb pro 3000 cl15 kit (32gb - 16*2)  



Yes it is. First time of course happened to me. And I am using my PC about 2 months almost. I just changed a motherboard before a few days.

I am using the G. Skill Trident Z Neo @@ 3600MHz CL16.


Such a weird behavior. This is so sad to be happening and people simply don't talk about it. Many people on forums online are saying that the problem is related to my motherboard throtteling the CPU when in reality it is not. So sad. 

Next time I upgrade (probably when DDR5 comes out) I will go with Intel. I've never had any problems with Intel in the past and their technology although outdated nowadays seem be to more stable in the long-term. Can't trust AMD with all of those issues anymore.

I'm using a R7 3700X - 32GB DDR4 3000@CL15  1.35V - X470-GTN.



Maybe a software that running make this in the windows startup. Maybe it's nothing. What is more concerning is that still the Ryzen 5000 are so new that motherboards can't handle them at the best possible ability and the Ryzen 5950x is increasing very high temps even with good liquid coolers and dual custom loops liquid coolers.

There is a whole thread that already have 41 pages by the users posts and every week new users joining by reporting the same.

Check here if you like to know. But I hope in time by new bios and agesa updates, everything to be fine.