cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

salseropilot
Adept II

AMD Ryzen 3900X stuck at very low (500 Mhz) frequencies on several cores

Hi all,

I am seeing an issue wherein my AMD's 3900x core 0, 1, and 2 are stuck at around 500 Mhz clock speed. All the other cores are running as expected, except for the first three.

This issue is intermittent.

I have attached screenshot from CPUID HWMonitor:

pastedImage_1.png

I let my system run for about an hour now, and these frequencies have not changed. A Reboot will surely fix the issue. 

Is anyone else experiencing this issue, and knows how to resolve it?

Thanks,

AMD3900X

TUF GAMING X570-PLUS

G.SKILL Ripjaws V Series 32GB DDR4 3200 (PC4 25600)

Karim

195 Replies

I'm programming the Corefreq software to help troubleshooting issues like yours 

Corefreq, ready to boot, is available at https://github.com/cyring/CoreFreq/wiki/Live-CD

Follow instructions to put it on an USB or CD; next reboot on medium and let it go until Core monitoring appears.

Press shortcut key O for Processor or per CPU stress functions and watch the frequency you get.

CoreFreq is an open source software for both AMD and Intel processors. ArchLinux is embedded into the image thus you don't need to install it.

F2 F3 F4 keys will open menus with various features targeting the processor.

Hope it will help you to diagnose your Ryzen.

Thanks for your help.  After running corefreq if I'm reading this correctly it states I have a max Frequency of 5.25 Ghz.  Is that correct?  If so that rules out the CPU as the problem.  cpu.jpg

0 Likes

It is indeed an abnormal high frequency for a 3900X according to its specs. Could the BIOS firmware be an issue ?

Can you post a screenshot of the UI showing bars when at max frequency ? 

0 Likes

@cyring This is not the OP @Lord_Vader captured this thread and posted the output of his 5900X. His problem ist obviously a wrong MB config.

AMD user since 1994

I was able to solve the problem by trying 7 different bios. I finally put the FIRST bios for my MB and all my cores unlocked. Everythings fine since then. No, 5.25ghz isnt normal. 

So on the latest AMD chipset drivers the problem has stopped popping up.

0 Likes

Yes! Latest chipset driver and the first bios of my msi pro vdh. Everythings good now! 

0 Likes

The only thing I did to fix it was do a completely clean Win10 OS install.  Not on Win11, and don't care to.

It has not fallen back to 547MHz (or some variant) since the re-install.

Somehow (and I have no idea, even though I'm in tech and have built PCs for over 30 years), I don't know how this can happen other than some weird combo of software in the OS (or an app) somehow in conjunction with the BIOS resulting in this such that only a cold boot fixes it. 

And yes, I tried every thing under the sun: updated BIOS, disabled Windows fast boot, power savings settings, etc, etc.

My case was that it was random. I'd be fine, in the middle of a game (for example) and suddenly it gets really choppy.  I see my CPU cores are all at greatly reduced MHz.  Warm boot would not solve.  Cold boot did solve--until it happened again.  The frequency seemed to be increasing with only happening once every few weeks to eventually every few days.

0 Likes

Disabling the windows fast boot feature if the only actual resolution right now.

Don't trust the people telling you to disable safety features.

0 Likes

There are other safety features as I've said. has anyone damaged anything by disabling PROCHOT? 

I didn't invent it, web is full of it. Google it up before telling people who to trust.

 

If it works and if it doesn't damage anything, I'd say its not a feature but a bug at least in some cases.

Both ifs are small, IMO

0 Likes

The fact that even their new processors is having the same problem makes me want to go to Intel. Next Gen will be Intel for sure They never learn from their mistakes..

0 Likes

Sadly this does not fix the problem, only a reboot does.

0 Likes
obeliskag
Adept I

This is odd in that it looks like CCX0, C01 and half of C02 are impacted. Usual suggestions, check you have the latest motherboard BIOS, install the latest AMD Chipset drivers, reset BIOS settings to default and then see if it is still an issue.

0 Likes

Indeed latest BIOS is installed, latest Chipset drivers for x570, and other than  Precision Boost Overdrive being enabled, everything in BIOS is set to default.

This issue is intermittent, hence I don' think it's a user configuration issue. 

It has happened three times in the span of a month, and only a reboot fixes the problem.

Any help is appreciated to characterize this problem.

Thanks,

AMD3900X

TUF GAMING X570-PLUS

G.SKILL Ripjaws V Series 32GB DDR4 3200 (PC4 25600)

0 Likes
ledhed
Adept II

Try running with PBO totally disabled in your BIOS, according to 1usmus, this will force Precision Boost 2.0 to handle the throttling/boosting instead of Precision Boost Overdrive (PBO).


There is no guarantee this will work, but it won't hurt anything and it's easy to test it.

You may also want to set the Thermal Limit to manual (located right under PBO enable/disable) and put a value around 80-90C. I have mine set to 85C and I notice that my 3950X seems to start leveling off the boost clocks when it reaches near 75-80C. It's likely that Precision Boost 2.0 begins to lower the boost ratio prior to hitting your thermal limit, ensuring it never reaches your TMax.

HI, What is your reasoning to disable PBO? Are you saying it could be the issue? I do want to be able to use PBO for higher performance.

Also when the issue happens, temperature is at idle level (40s to 50s C); this is not something I start to experience when high temperatures are reached.

So again, core 0, 1 and 2 are "Stuck" in the 500Mhz range. Nothing is being throttled or boosted on these core no matter the work load. The other cores however are indeed working as required.

Karim

0 Likes
shinkojiro
Miniboss

That happened once after I tried out 1Usmus's power plan and Bios settings. needless to say it has never happened with AMD's or windows power plans.

ledhed
Adept II

I don't quite understand what you said, what is "it," that has never happened with AMD or Windows PPs? 

Are you saying that this low clock behavior actually occured when you were using the 1usmus CPP?

What about your thermal performance? What is your average idle temp and your avg load temp? 

0 Likes

My idles are in the low 20's. It only happened because of settings in Bios that were suggested be set by 1Usmus for use with his plan. That was the only time I ever had CCX0 lock to 500ish mhz. I have long since changed those settings back to what I had them at and just went back to using AMD Ryzen Balanced/High Performance power plans.

0 Likes
kamatcho
Journeyman III

I here have been having the same issue, with the CPU deciding when to do this and I recon it does most after being heavy used, which made me think the temperature wasn't any good. It showed me about 65 degrees while doing rendering of a video, so I don't know. All is indeed set to default, and power plan is set to AMD Ryzen High Performance.

I will be following this to see if there comes a solution for this, and if this is even solvable.

pastedImage_1.png

Hello Kamatcho,

Just out of curiosity, what motherboard do you have? I have the ASUS TUF GAMING X570-PLUS

And I am wondering if it's motherboard issue, or a CPU issue.

0 Likes
jaguvaari
Journeyman III

I have also had this issue, but on Ryzen 5 3600 processor. It seems to make one or both of the CCX in the processor to get stuck to 550Mhz after booting the computer. I have had the issue with ABBA bios and the newer 1.0.0.4 as well. I have had the issue happen on both Ryzen Balanced and Ryzen High performance power plans.

I've found that touching settings in the power plan or changing between power plans and applying the changes releases the locked CCXs and the frequencies work as normal after that.

salseropilot
Adept II

Hi all, 

I am having this low core frequency issue again. This time core #0 seems to be locked in the 1800Mhz's, whereas the rest of the cores look normal.

I have attached some pictures. Can anyone please take a look and let me what is going on?Capture1.PNGCapture2.PNGCapture3.PNG

0 Likes

If your VDDR SOC is really 1.362v you need to turn it down pronto below 1.2v.

Set it to 1.1v

0 Likes

Is that bad? It is set to Auto in the Bios. I have not touched anything there.

How would one know that it should be set to 1.1 V?

0 Likes

Its been 1.2v max safe since Ryzen 1000 series. If your bios is stupid enough to set something higher than that, you may need a bios update and/or set it manually.

How to Kill Your CPU with “Safe” Voltages | Raven Ridge SOC Voltage Guidelines | GamersNexus - Gamin... 2020.03.04-07.13.png

0 Likes

Theres also the issue where your CCD0/CCX0 and CCD1/CCX1 are showing 4600mhz setting while your middle two are showing 4650mhz.

0 Likes
salseropilot
Adept II

Hi all,

I seem to be having this low frequency issue more often than usual. Particularly after a cold boot, such as powering up the PC after being off for about 8 hours.

The issue happened again this morning, and this time all 9 cores were locked at the 500 Mhz range! And the 10th core was locked in the 1900Mhz range. This is ridiculous. 

Here are some photos:

Capture4.PNG

Capture5.PNG

Capture6.PNG

The frustrating part about this issue is that you can actually feel the lack of performance. As in, this is not a display issue or a frequency reporting issue. The cores seem to be really locked at those frequencies.

Also it does not matter if I exercise the CPU using a CPU stress tool or not; the frequencies stay low and never jump up to their appropriate frequencies when stressed.

A reboot promptly fixes the issue.

Nevertheless it is unacceptable to be dealing with an issue such as this one, on a $500 CPU. This need to be addressed, and I really wish this forum was frequented more by actual AMD engineers that would take our issues to heart and actually investigate these issues. 

It seems as we're all running around trying to guess what the issue is, instead of having someone from AMD test this for a potential defect. This is an AMD forum after all.

salseropilot
Adept II

Just a quick update. I have decided to disable Fast Startup (which Windows happens to recommend by the way) as I suspect that maybe, just maybe this has something to do with it. 

From what I learned, Fast Startup saves a few things before shutting down and reloads them straight to Ram, including configurations, drivers etc.. It is plausible this could be interfering with the way the AMD CPU works. 

In any case, I will try this and will come back and update after a few days.

0 Likes
xaia
Journeyman III

Hi!

I am running in the same issue as above. For some reason all my cores are down-clocked to 500ish Mhz. After restart everything goes back to normal.

I recentely updated my BIOS to newest one. Before update I never noticed such issue.

AS Rock Taichi x570

G.Skill 3600Mhz 64GB

Ryzen 3950x

0 Likes
salseropilot
Adept II

Hi, xaia,

Can you check if you have Fast startup enabled?fast start up.PNG

0 Likes

Hi!

No, I don't have any fast startup enabled. Even the one in the BIOS is disabled.

0 Likes

Interesting, ok. I was hoping you had it enabled, then I would have more certainty that it was the issue, as I have had Fast Startup disabled for a few days; and have not had the issue happen to me. 

It may very well be that Fast Startup is not the trigger for this issue. Could be something else. Nevertheless the fact that you have a different motherboard than mine (I have an TUF GAMING X570-PLUS) at least indicates that it is not a motherboard issue.

So Maybe it is a CPU issue after all, specific to the 3 series.

0 Likes
stayer_mc
Adept I

The same issue. Ryzen 9 3900x drops multipliers after loading. Motherboard ROG STRIX X470-F GAMING with latest bios version. Latest AMD chipset drivers.  All BIOS settings are set to default. Previously had 2700x on this motherboard, but with an earlier BIOS, and had no problems.

2020-01-16_16-27-13.png2020-01-26_18-09-37.png

0 Likes
kaeuvian
Journeyman III

I have had this similar bug, one time it was ALL cores - I didn't realise until after I played some MHW for about 90mins why I was so laggy/jumpy frame rate - to be honest, I'm impressed it ran as well as it did still. 12 cores running at 559Mhz.

When I realised that was the issue, I loaded up both HWMonitor & Ryzen Master to check clocks from both and they showed the same clocks. I ran a Cinebench R20 and got a score of 851!  

This was a recently built system and I had only not long installed the latest bios  for an Asrock B450M Pro4-F to even use the 3900x (yeah, not ideal but I found the 3900x cheap as new so jumped at it. I do plan on upgrading board)

I only noticed the bug AFTER I had installed Ryzen Master/AMD Power plans and enable the power plans. Before this I had many reboots/cinebench runs to try and get higher boost clocks which lead me to the power plans/ryzen master (power plans is all that I really needed it seemed)

After reading this thread, I changed power plan from High Perf to Balance (both AMD versions) and back and it fixed the locked clocks without a reboot. I have also disable the Turn on Fast startup option as described above. If i see it again I will try a bios reset ( was reset originally with the upgrade/to get it to post with new memory and cpu)

Sadly, it's exactly these types of issues that lead me away from ever buying an AMD GPU from about 10 years ago and now something similar with processors. I wouldn't say I'm an intel fanboy , but I sure enjoyed things just working with my previous intel builds and having smooth experiences

locked clocks.jpg

Hey Kaeuvian, good to know you are using a Ryzen 9 3900x with an Asrock B450M Pro4-F. So, is it working good besides this problem with clocks that are common to all users apparently? I have the same board with Ryzen 5 3600, but I'm planning to upgrade to a Ryzen 9 3900x and use it in stock to render (Vray and Corona). Is the package doing good?

Thank you!

0 Likes

I  changed my power option from AMD Ryzen High Performance to AMD Ryzen Balanced and the four cores running at 570 MHz immediately jumped to where I expected them to be (around 44xx MHz). 

My peak package (Node 0) temp at the time was 67 deg C.

I can switch it back to AMD High Performance without it throttling but I will leave it at AMD Ryzen balanced for a month or so to see if it comes back.

I have noticed this once before where all 8 cores were around 570 MHz and that time my first measure was rebooting and that fixed it.

System:

Ryzen Master not installed

3800x

Gigabyte A570 Aorus Pro Wifi board v 1.0 bios v f12

Asus Cerberus GTX 1070 Ti

GSkill 3200

PBO on

XMP on

0 Likes
candymancan
Adept II

This happens on my 3800x too, its happen to me 3 times.. Its only does this when i have Ryzen master installed.  Once i got rid of that program i havent see my cpu do that anymore.   I think this is a software issue.. Ryzen master has given me alot of problems not just this.  But i have seen this before,,, 3800x stuck at 500mhz or so on many cores and performance is crushed

I suggest you guys reset your ryzen master to default.. reboot, then uinstall it..  Ill never use that program again.   If you guys however are getting this without ryzen master installed then im wondering if this is a hardware issue.   Honeslty though, i am so tired with in-consistant boost clocks on these cpus.  i cant even get a single core boost at 4500mhz like advertised...  with multicore boost at like 4160-4200mhz.   I decided to tinker with the cpu and i managed to get 4450mhz 8 core boost at 1.37v stable..  I plan to keep it there 24.7,  im not messing with this up and down up and down crap anymore.

Came back to say this also, since my previous post all I had done was turn off fast boot as previously described and also uninstalled ryzen master.

No more episodes of low frequency locks. No idea what the program was doing actively to cause issues, since all i had done with it was install it to check it preferred cores/ccx and see that clock speeds to compare to cpuid HWMonitor.

0 Likes
payo36
Journeyman III

LowClock.png

I have the same issue with 3900x and 3950x. These are list of the HW that I use.

- Aorus x570 I

- Asus Crosshair impact VIII

- Asus Hero VIII

- Aorus x570 Xtreme

All main boards above have this problem once in a while. The CPU is not OCed and PBO is off. The cooler is NZXT X62. What I have tried but NOT fix the problems are. 

- Disable Windows fast startup.

- Change the RAM speed, turn off XMP profile.

- Change power plan setting to AMD high performance and AMD balance (Edit.. with AMD Balance , sometime it will fix it self like 10 seconds after boot)

- Change RAM stick from T-Force 4133 MHz  to Hyper X fury 3200 MHz

- Change CPU from 3900x to 3950x

- Change 4 above main boards.

- Clean install of Windows 10

When it happens it just happen. I can feel the lag as others say. 

I've nothing left to try, 2 cpus, 4 main boards, 2 set of RAMs.  

CAM software from NZXT is my last suspect. Ryzen Master won't lunch when CAM is on.  This might cause the issue. But If I turn off CAM, the pump speed will run at slow setting. so..

Edit 1

Today when this symptom happen, I ran CB R20 and monitor it with Ryzen master. I found out that all cores were running at 566 MHz instead of 3960 MHz. While the CB R20 was still running, I opened up power setting and change the power plan setting from "AMD High Performance" to "AMD Balance" , suddenly the clock jumped right back to 3960 MHz in Ryzen Master.

So, I believe this is WIndows 10 and AMD driver specific issue. I found this problem also happen when I boot from AMD Balance plan but sometime it will fix itself in a few seconds after boot.