cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

Windfire
Adept I

Re: Summary of my situation, a theory, but no good resolution

HW:

                3900x w/ AIO 360 (not overclocked, runs pretty cool)

                32GB 3600MHz RAM (configured correctly)

                Asus ROG Strix X570-E Gaming ATX

                Win 10 (a couple year old install)

 

I think all of my issues on this do revolve around power management.

When I use the PC constantly the issue does not seem to occur. I think it happens when I don’t use the PC for an extended period (over an hour).

 

Symptoms: 

1 – (this may be red-herring, but may not). For past 6 months I’ve had cases where if I walk away for 1-n hours and come back, my PC is frozen. Locked up. Requires reset button to re-start.  I’ve DISABLED both screen and CPU sleep.  However, it still somehow impacts me.

2 – This low MHZ issue kicked in over the last month.  Often down to 546MHz on all cores.  Nothing I can do resolves the underclocking.  Core multiplier is at 5.5 instead 40+.

3 – Changing Power setting between Balanced / Performance makes no difference.  It doesn’t resolve GHz rate, nor does it make any difference on this issue occurring.

4 – Warm reboot, or even reset button does not seem to fix the issue. I can only get back to full GHz with a cold boot.

 

What have I tried to do to solve:

1 – Set Screen and Sleep to “Never”

                Did not help.

2 – Uninstalled Ryzen Master (didn’t use it much)

                Did not help.

3 – Updated Bios to most recent non-Beta BIOS (Asus ROG Strix X570-E Gaming ATX)

                Did not help.

4 – Updated “Power Duty Control” under DIGI+ VRM settings to “Extreme”

                Seems to help a bit.

A – Have not seen 546MHz issue since doing this – even with long delays of no PC use

B – non-CPU intense apps keeps CPU running in the 4.1 – 4.3GHz range – again, even with long delays of no PC use

However, CPU intense apps (Handbrake, CineBench) can still result in a CPU MHz drop down to 2.6GHz on all cores.

On cold reboot the cores run at full speed again until a later time (likely after non-use of PC for 1+ hours).

My theory:

On a clean boot all is well—games, CPU intensive run at full GHz.

It stays well as long as I’m interacting with PC.  If I step away for an extended period (an hour or more?) then it introduces the risk of this issue arising. Not 100%. 

My hunch is that Microsoft and the industry continue to introduce more and more aggressive or systemic approaches to save power.  These changes are what is causing issues.  This explains why I didn’t see any issue for over a year.  Then I started experiencing lock-ups if I walk away from my PC.  Now I see cases where somehow the OS/motherboard under-clocks the CPU as if it was in a low power state. No temperature issues involved.

marcbittner
Adept I

Re: Summary of my situation, a theory, but no good resolution

I'm skeptical about this being a Microsoft problem only because it persists across warm reboots. Windows can't touch me until it is loaded, but I can very clearly see the depressed voltage from the cpu protecting itself in the voltage readout. for me, the issue seems more likely to occur under load but definitely also occurs at idle.       

There does seem to be a version of this failure state that is 100 percent caused by the power plan going haywire. But For me (and I presume some  others) changing the power plan has no effect at all                       

Edit: this is now happening to me SO frequently that I'm seriously considering a different motherboard. The corsair extreme has dynamic overclocking and some extra voltage features.  A LOT of these reports seem dark hero-related. 

marcbittner
Adept I

Re: Summary of my situation, a theory, but no good resolution

Update: I would NEVER have believed it, but reinstalling windows cured this (so far). I'm assuming that means some combination of things I had loaded conflicted to put the CPU in a bad state that could only be recovered by clearing the BIOS. If I manage to figure out what combination of software was at fault, I'll report back. 

Windfire
Adept I

Re: Summary of my situation, a theory, but no good resolution

UPDATE on my summary above: Today I had another instance of all cores going to 547MHz in teh middle of playing a game.  Smoother as butter one moment, slow the next.

So none of my attempted fixes have worked (see above).  Last event was on Feb 19th, but I'm not interested in this.

I've decided to purchase an MSI Edge z690 and a 12700KF.  Will be moving over soon.

 

Once I have the new PC up I'm doing full-up CLEAN install of Win10 on the 3900x to see if that fixes it.  Some time in the next week or two hopefully.  As other have remarked, I'm not sure how Microsoft could be fully to blame on this or a warm-boot would fix it.

cyring
Adept II

Re: AMD Ryzen 3900X stuck at very low (800 Mhz) frequencies on all cores

Check if Power Limiters are not set too low ?

CoreFreqCoreFreq

Bootable images of CoreFreq

Windfire
Adept I

Re: AMD Ryzen 3900X stuck at very low (800 Mhz) frequencies on all cores

@cyring , first how do I get that information?

Second, if the CPU worked fine for over a year, and then started getting these, what could have updated those values?

 

UPDATE - I've completed a CLEAN install of Win10 Pro again and so far I've not had the issue repeated.  No symptoms so far.

cyring
Adept II

Re: AMD Ryzen 3900X stuck at very low (800 Mhz) frequencies on all cores

Download the ISO image, RELEASE or DEVELOPMENT link.

Write image on an USB key: Rufus makes this easy.

Reboot PC, go to BIOS and disable "secured boot": required to run Linux.

Save BIOS parameters and reboot, selecting the USB key as the startup disk.

 

And let it go. CoreFreq will start by itself.

 

More detail in Wiki 

0 Likes
GMdoghunter
Adept I

Re: AMD Ryzen 3900X stuck at very low (800 Mhz) frequencies on all cores

You get the information from windows task manager,and also i DID ELIMINATE THE ISSUE TO BEING ICUE,Icue was the culprit in my case the most recent version of icue doesnt replicate the issue so in my case it was a software issue not a hardware issue.

Hopefully this helps.

0 Likes
Windfire
Adept I

Re: AMD Ryzen 3900X stuck at very low (800 Mhz) frequencies on all cores

Thanks.  I am beginning to think it is software too.  I've not had any symptoms since re-imaging with Windows 10 Pro (clean install).

Very odd though that in my case:

1 - On cold boot the CPU runs at full speed for an indeterminate period of time (hours/days).

2 - At some random point one of 2 symptoms started:

    2.1 - CPU would drop to ~600MHz on all cores (often in middle of game--running great, then suddenly slow)

    2.2 - In CPU heavy tasks the CPU dropped to 2500MHz (~4000MHz is the norm)

3 - Warm boot / reset button would NOT correct the issue.  Requires shut down and cold boot fix issue.

 

#3 seems to argue it is not the OS.  However, perhaps the OS had an "issue" (bad driver install?? whatever) that, in conjunction with motherboard, would result in a bad state that required cold reboot.

It argues Win10 or a driver situation triggers the issue that the motherboard enables.

Never seen something like that in my 30+ year hobby of building PCs and troubleshooting.

 

0 Likes
Windfire
Adept I

Re: AMD Ryzen 3900X stuck at very low (800 Mhz) frequencies on all cores

I'm not sure this would work because the PC does not exhibit the issue on turning on.  It happens mid-stream.  

I'd have to reboot, go into BIOS and make that change, Save/Reboot and utilize this thumb drive.  In all that I'm not certain the issue would be in play still.

There are others on this forum where it occurs from boot, so this would work in those cases.

0 Likes