cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

Mcunixz
Journeyman III

Re: AMD Ryzen 3900X stuck at very low (500 Mhz) frequencies on several cores

Still at 0.53ghz  

0 Likes
avet
Adept I

Re: AMD Ryzen 3900X stuck at very low (500 Mhz) frequencies on several cores

have you tried 'Advanced/AMD Overclocking/AMD Overclocking\SoC/Uncore OC mode' (Forces CPU SoC... to run at their maximum frequences at all times.) in BIOS if you have it?

(I've used it in ASUS TUF Gaming+ and I think that it solves this)

 

0 Likes
Mcunixz
Journeyman III

Re: AMD Ryzen 3900X stuck at very low (500 Mhz) frequencies on several cores

i dont think i have this setting in my msi bios. ill check! thanks

0 Likes
avet
Adept I

Re: AMD Ryzen 3900X stuck at very low (500 Mhz) frequencies on several cores

If you find it, check with some other ppl before trying, to be safe.

My CPU is Ryzen 5 3600, when I used 'tuning' option it determined the max frequency was 3950 and it used that. I had to manually fix 3600MHz so it doesn't get overclocked.

0 Likes
prabhu
Journeyman III

Re: AMD Ryzen 3900X stuck at very low (500 Mhz) frequencies on several cores

I am using AMD 3700x first four core stucked at 500Mhz. this is windows 10 problem not an amd issue.

Solution:

Go to control panel -> Power Option -> Select AMD Ryzen Balanced -> then select change plan settings -> Change Advanced power settings -> + Processor power management ->  + "Minimum processor state" -> Setting type 100% and + "Maximum processor state" -> Setting type 100%. Then Apply and OK.

I know Maximum processor state already set as 100% but you have to retype as 100%.

This is works for me that why I am sharing with you guys.

By Prabhu 

 

0 Likes
prabhu
Journeyman III

Re: AMD Ryzen 3900X stuck at very low (500 Mhz) frequencies on several cores

I am using AMD 3700x first four core stucked at 500Mhz. this is windows 10 problem not an amd issue.


Solution:


Go to control panel -> Power Option -> Select AMD Ryzen Balanced -> then select change plan settings -> Change Advanced power settings -> + Processor power management -> + "Minimum processor state" -> Setting type 100% and + "Maximum processor state" -> Setting type 100%. Then Apply and OK.


I know Maximum processor state already set as 100% but you have to retype as 100%.

This is works for me that why I am sharing with you guys.

By Prabhu

0 Likes
Cajamarquino
Journeyman III

Re: AMD Ryzen 3900X stuck at very low (500 Mhz) frequencies on several cores

Hello friends, the same thing is happening to me with my Ryzen 3900x and a MOBO: Asus tuf gaming x570 plus wi-fi.
It happens to me every 4 days or 5 days at every cold boot, and it's not all. Sometimes in each cold boot on the home screen when I am about to type the password I get a blue screen with the message: Kernel_datainpage_error. Everything happens at every cold boot, so I think the two are related.
I solved this by disabling windows fast startup, but it makes me very sad anyway, I invested a lot of money in this build. I don't want to have to disable anything, I just want it to work fine. I don't think I'll ever choose Ryzen again in my next builds.

0 Likes
Cajamarquino
Journeyman III

Re: AMD Ryzen 3900X stuck at very low (500 Mhz) frequencies on several cores

Hello friends, the same thing is happening to me with my Ryzen 3900x and a MOBO: asus tuf gaming x570 plus wi-fi.
It happens to me every 4 days or 5 days at every cold boot, and it's not all. Sometimes in each cold boot on the home screen when I am about to type the password I get a blue screen with the message: Kernel_datainpage_error. Everything happens at every cold boot, so I think the two are related.
I solved this by disabling windows fast startup, but it makes me very sad anyway, I invested a lot of money in this build. I don't want to have to disable anything, I just want it to work fine. I don't think I'll ever choose Ryzen again in my next builds.

Tags (1)
0 Likes