Showing results for 
Search instead for 
Did you mean: 


Adept II

AMD Ryzen 3900X stuck at very low (500 Mhz) frequencies on several cores

Hi all,

I am seeing an issue wherein my AMD's 3900x core 0, 1, and 2 are stuck at around 500 Mhz clock speed. All the other cores are running as expected, except for the first three.

This issue is intermittent.

I have attached screenshot from CPUID HWMonitor:


I let my system run for about an hour now, and these frequencies have not changed. A Reboot will surely fix the issue. 

Is anyone else experiencing this issue, and knows how to resolve it?




G.SKILL Ripjaws V Series 32GB DDR4 3200 (PC4 25600)


198 Replies

Thank you for posting that link I will surely look onto it. 

For me as a costumer It's unacceptable for us to have such problems that shouldn't even EXIST in first place. Even though it does not happen so often having the possibility of having any related problem that isn't my fault is simply annoying. I made up my mind already next gen I'm going with Intel and I recommend you guys to do so as well.

Regarding the problem itself I'm lost since you've posted you do have this problem with your new CPU as well. It has been a very informative comment cause it'll make people realize that the problem lies on the plataform itself and not on especific CPU units and I thought it could have been.

Journeyman III

I am using AMD 3700x first four core stucked at 500Mhz. this is windows 10 problem not an amd issue.


Go to control panel -> Power Option -> Select AMD Ryzen Balanced -> then select change plan settings -> Change Advanced power settings -> + Processor power management ->  + "Minimum processor state" -> Setting type 100% and + "Maximum processor state" -> Setting type 100%. Then Apply and OK.

I know Maximum processor state already set as 100% but you have to retype as 100%.

This is works for me that why I am sharing with you guys.

By Prabhu 


Journeyman III

I am using AMD 3700x first four core stucked at 500Mhz. this is windows 10 problem not an amd issue.


Go to control panel -> Power Option -> Select AMD Ryzen Balanced -> then select change plan settings -> Change Advanced power settings -> + Processor power management -> + "Minimum processor state" -> Setting type 100% and + "Maximum processor state" -> Setting type 100%. Then Apply and OK.

I know Maximum processor state already set as 100% but you have to retype as 100%.

This is works for me that why I am sharing with you guys.

By Prabhu


Hello friends, the same thing is happening to me with my Ryzen 3900x and a MOBO: Asus tuf gaming x570 plus wi-fi.
It happens to me every 4 days or 5 days at every cold boot, and it's not all. Sometimes in each cold boot on the home screen when I am about to type the password I get a blue screen with the message: Kernel_datainpage_error. Everything happens at every cold boot, so I think the two are related.
I solved this by disabling windows fast startup, but it makes me very sad anyway, I invested a lot of money in this build. I don't want to have to disable anything, I just want it to work fine. I don't think I'll ever choose Ryzen again in my next builds.


Hello friends, the same thing is happening to me with my Ryzen 3900x and a MOBO: asus tuf gaming x570 plus wi-fi.
It happens to me every 4 days or 5 days at every cold boot, and it's not all. Sometimes in each cold boot on the home screen when I am about to type the password I get a blue screen with the message: Kernel_datainpage_error. Everything happens at every cold boot, so I think the two are related.
I solved this by disabling windows fast startup, but it makes me very sad anyway, I invested a lot of money in this build. I don't want to have to disable anything, I just want it to work fine. I don't think I'll ever choose Ryzen again in my next builds.

Journeyman III

I just had my Threadripper PRO 3975WX lock itself to 547 MHz for several days and tried all the solutions in this thread. What finally unlocked it for me was allowing the login screen to idle until my computer went to sleep, then waking it and logging in. Now only some of my cores are locked to half the boost speed (1800-2400MHz), but I’ll take it. 


UPDATE: After testing, I can only conclude that disabling Core Performance Boost and enabling whatever that C-states option is allowed me to get back to base clock.


Check the P-States plan which might be corrupted.

Also Max Non-Turbo & Boosted P-states

And whatever Coefficient of frequency is locked in SMU.




A wrong Power Limit can also limit the frequency.


I too like many others have the same issue of all of a sudden the processor seems to just go down to 800mhz on all cores,most noticable whjen the computer just goes sluggish.

I have to add my build is only 1 month old

Asus rog crosshair v8 formula am4 motherboard

ryzen 3900x cpu

corsair vengeance pro rgb 64gb@3600 mhz

rtx 3060 gpu

32tb storage split over 2 nvme drives,2 ssds,4 internal hdds.

Everything is new in this build,build is also fully watercooled as well,not with an aio but pumps rads etc full watercooling setup.

Temperatures range-idle 40.c app,under laod about 51.c

Definitely not temperature related as i initially thought it could be thermal throttling.

But after reading this forum its definitely not a thermal issue imo its either hardware or software,but i would suspect more of a hardware issue.

Hopefully someone can get to the route of this very annoying problem as i came from using an intel processor,amd does seem more responsive,but the issues with these are just beyond ridiculous.

I want to stay with team red but issues need to be fixed.


I have the same problem.

Ryzen 5 3600, intermittently dropping down to 500Mhz (5.5 multiplier). Reboot doesn't bring the clocks back up, I have to turn off/turn on the PSU power.

I have ASUS Crosshair VIII Dark Hero and everything was working fine until I installed custom water cooling loop in my build. I also updated the BIOS, and chipset driver, so I'm not sure whether it's software or hardware related.

I tried clearing CMOS, updating BIOS, disabling PBO, disabling Core Performance Boost, enabling SoC Uncore OC Mode, reinstalling chipset driver, changing power plan. No luck so far. I hope that's not the case, but I suspect it's a hardware issue. Maybe, a pin on the CPU, CPU socket, or some other motherboard component was damaged when I installed the loop. I'll be upgrading the loop and inspecting the components in 2 weeks or so, so maybe then I will identify the cause.


it seems that setting the multiplier manually to x36 (in my case) is crucial


I got the issue, I found what was causing my problems and hopefully many other people here have the same as me, it was CORSAIR ICUE V v4.16.194 that was causing the issues with me, and the latest update to icue as well anything by 4.15 seems to have the problem but its DEFINITELY ICUE that is causing the CPU frequency drop hopefully that helps and maybe cure some peoples issues here. Sorry for the late reply, but I've been doing a lot of testing lately to find the problem.


I have my Ryzen 1600 since it was released, this problem is not new, I still haven't figured out how to solve it, I don't discard the Icue software related to this, it is very invasivel.

Another problem that also happens to me since the beginning, is my computer having random shutdowns for no reason.

I've done everything and still haven't figured out the cause, I suspected that I have the power supply, but it's hard to send it for warranty and stay a month without the computer.

I have a Biostar B350gt5 motherboard, I suggest you don't use the chipset driver directly from the AMD website and use the chipset driver directly from your motherboard website.

I don't write English very well, I'm Brazilian.


Have you try Linux ?


If you need a ready to play ISO image, I'm providing CoreFreq to monitor, stress and tweak Ryzen processors.

Release can be downloaded at



Implementation of CPPC reveals to me that some low hints programmed into MSR could constraint frequency.

Check if Power Limiters are not set too low ?


Bootable images of CoreFreq

@cyring , first how do I get that information?

Second, if the CPU worked fine for over a year, and then started getting these, what could have updated those values?


UPDATE - I've completed a CLEAN install of Win10 Pro again and so far I've not had the issue repeated.  No symptoms so far.

You get the information from windows task manager,and also i DID ELIMINATE THE ISSUE TO BEING ICUE,Icue was the culprit in my case the most recent version of icue doesnt replicate the issue so in my case it was a software issue not a hardware issue.

Hopefully this helps.


Thanks.  I am beginning to think it is software too.  I've not had any symptoms since re-imaging with Windows 10 Pro (clean install).

Very odd though that in my case:

1 - On cold boot the CPU runs at full speed for an indeterminate period of time (hours/days).

2 - At some random point one of 2 symptoms started:

    2.1 - CPU would drop to ~600MHz on all cores (often in middle of game--running great, then suddenly slow)

    2.2 - In CPU heavy tasks the CPU dropped to 2500MHz (~4000MHz is the norm)

3 - Warm boot / reset button would NOT correct the issue.  Requires shut down and cold boot fix issue.


#3 seems to argue it is not the OS.  However, perhaps the OS had an "issue" (bad driver install?? whatever) that, in conjunction with motherboard, would result in a bad state that required cold reboot.

It argues Win10 or a driver situation triggers the issue that the motherboard enables.

Never seen something like that in my 30+ year hobby of building PCs and troubleshooting.



Download the ISO image, RELEASE or DEVELOPMENT link.

Write image on an USB key: Rufus makes this easy.

Reboot PC, go to BIOS and disable "secured boot": required to run Linux.

Save BIOS parameters and reboot, selecting the USB key as the startup disk.


And let it go. CoreFreq will start by itself.


More detail in Wiki 


I'm not sure this would work because the PC does not exhibit the issue on turning on.  It happens mid-stream.  

I'd have to reboot, go into BIOS and make that change, Save/Reboot and utilize this thumb drive.  In all that I'm not certain the issue would be in play still.

There are others on this forum where it occurs from boot, so this would work in those cases.


I kind of found a workaround for my issue. I'm monitoring my temps with both AIDA64 and Argus Monitor and I noticed that my VRM and water temperature sensors sometimes give a reading of N/A, and Argus sometimes gives me a warning that my CPU temperature exceeds 85C limit, although it was nowhere near that. That confirmed my suspicion that something is going on with temp sensors.

What I did, I changed CPU Power Duty Control (Extreme Tweaker - External Digi+ Power Control) in BIOS from T. Probe to Extreme, and it solved this problem. Although my system sometimes still behaves weirdly, I haven't encountered this issue since. 


@orange_t ,

I have same issue as you I think.  3900x.  

PC will start/reboot fine.  I'll be playing a game or running Handbrake when suddenly all the cores drop to 546MHz (5.5 multiplier). Sometimes it is higher, most of the time it is 546MHz.

Warm reboot does not fix.

Reset button dos not fix.

Turn off, and cold boot fixes it and I'm back to normal until the next time it happens - every couple days.

What have I done:

1 - I've updated Bios to current highest version (not Beta however): Asus ROG Strix X570-E Gaming ATX

2 - I've updated Chipset drivers to current AMD drivers

3 - I've disabled quick boot in Win10 and BIOS

4 - I've un-installed Ryzen Master (never used it much)

5 - Changing power plan does not fix anything.  Cold boot is only thing I've found that gets me back to 4.xGHz.

None of those things have fixed the issue.


Adept III

Have you tried resetting your bios, that usually fixes this

Adam J Martin

Hey guys, I've been reading this thread on-and-off for a month or so now.  I'm also having these issues on a 5950X running on an Asus Crosshair Viii Hero Wifi board.

I was previously running without Ryzen Master installed but after this issue started (when I installed Argus Monitor) I had all sorts of issues.  I got it originally on BIOS 3904 but I've now rolled back to 3801 which I thought had resolved the issue.  But today it randomly happened again while I was tweaking something in the Dual Intelligent Processor software that comes with the Asus board.

I thought I'd add my findings to see if it helps anyone.

When the issue is occuring, for me a reboot doesn't fix it.  But I have noticed that within Ryzen Master it shows the PPT is >100% constantly (while running at 500mhz), even though the CPU Power shows 40-60W.  

It certainly seems to suggest to me that there's something about the Power State that is messed up and something gets stuck between reboots.

For me, the problem DID get resolved if I send the computer to sleep and wake it up (this happened today once, I have as-yet been unable to reliably reproduce this behavior).

- Using an Asus Crosshair Viii Hero Wifi
- 5950X with DOCP RAM settings and PBO enabled
- Software installed: Ryzen Master, Asus Motherboard Suite, iCUE (I note this because others have mentioned it's potentially related)

Adept III

Have you ever tried a remount of the processor and use air to blow out the dust from the processor mount???

Adam J Martin

I'm continuing to have a similar issue on 5950x + Dark Hero mobo. I was convinced it was a bad sensor, then I tried no fewer than three brand new boards, AND swapped the chip. 

Strangely, since the chip swap, I no longer loge get locked at .54 ghz, but at 4.18 instead. This wouldn't be at all noticeable except for the fact that I'm looking for it and noted that edc, ppt et all are at or above 100 percent (ppt @395 Watts, EDC reading 130 percent of 200a)

This is a real head-scratcher since it occurs 1. predictably after a variable period under load 2, unpredictably at idle, and 3. at stock settings. In each case, either a flash or hard reset of the bios is required to restore normal functioning. Setting pbo limits to "motherboard" mitigates most of the performance hit since it throws the limits wide open, but the metrics are still pinned in the red *at idle* 

Edit: So much for that theory. Just had all the cores lock at .54 ghz. I really envy those of you who can clear this with a reboot / power setting change. I have to hard reset cmos every time. 


                3900x w/ AIO 360 (not overclocked, runs pretty cool)

                32GB 3600MHz RAM (configured correctly)

                Asus ROG Strix X570-E Gaming ATX

                Win 10 (a couple year old install)


I think all of my issues on this do revolve around power management.

When I use the PC constantly the issue does not seem to occur. I think it happens when I don’t use the PC for an extended period (over an hour).



1 – (this may be red-herring, but may not). For past 6 months I’ve had cases where if I walk away for 1-n hours and come back, my PC is frozen. Locked up. Requires reset button to re-start.  I’ve DISABLED both screen and CPU sleep.  However, it still somehow impacts me.

2 – This low MHZ issue kicked in over the last month.  Often down to 546MHz on all cores.  Nothing I can do resolves the underclocking.  Core multiplier is at 5.5 instead 40+.

3 – Changing Power setting between Balanced / Performance makes no difference.  It doesn’t resolve GHz rate, nor does it make any difference on this issue occurring.

4 – Warm reboot, or even reset button does not seem to fix the issue. I can only get back to full GHz with a cold boot.


What have I tried to do to solve:

1 – Set Screen and Sleep to “Never”

                Did not help.

2 – Uninstalled Ryzen Master (didn’t use it much)

                Did not help.

3 – Updated Bios to most recent non-Beta BIOS (Asus ROG Strix X570-E Gaming ATX)

                Did not help.

4 – Updated “Power Duty Control” under DIGI+ VRM settings to “Extreme”

                Seems to help a bit.

A – Have not seen 546MHz issue since doing this – even with long delays of no PC use

B – non-CPU intense apps keeps CPU running in the 4.1 – 4.3GHz range – again, even with long delays of no PC use

However, CPU intense apps (Handbrake, CineBench) can still result in a CPU MHz drop down to 2.6GHz on all cores.

On cold reboot the cores run at full speed again until a later time (likely after non-use of PC for 1+ hours).

My theory:

On a clean boot all is well—games, CPU intensive run at full GHz.

It stays well as long as I’m interacting with PC.  If I step away for an extended period (an hour or more?) then it introduces the risk of this issue arising. Not 100%. 

My hunch is that Microsoft and the industry continue to introduce more and more aggressive or systemic approaches to save power.  These changes are what is causing issues.  This explains why I didn’t see any issue for over a year.  Then I started experiencing lock-ups if I walk away from my PC.  Now I see cases where somehow the OS/motherboard under-clocks the CPU as if it was in a low power state. No temperature issues involved.

I'm skeptical about this being a Microsoft problem only because it persists across warm reboots. Windows can't touch me until it is loaded, but I can very clearly see the depressed voltage from the cpu protecting itself in the voltage readout. for me, the issue seems more likely to occur under load but definitely also occurs at idle.       

There does seem to be a version of this failure state that is 100 percent caused by the power plan going haywire. But For me (and I presume some  others) changing the power plan has no effect at all                       

Edit: this is now happening to me SO frequently that I'm seriously considering a different motherboard. The corsair extreme has dynamic overclocking and some extra voltage features.  A LOT of these reports seem dark hero-related. 

Update: I would NEVER have believed it, but reinstalling windows cured this (so far). I'm assuming that means some combination of things I had loaded conflicted to put the CPU in a bad state that could only be recovered by clearing the BIOS. If I manage to figure out what combination of software was at fault, I'll report back. 

UPDATE on my summary above: Today I had another instance of all cores going to 547MHz in teh middle of playing a game.  Smoother as butter one moment, slow the next.

So none of my attempted fixes have worked (see above).  Last event was on Feb 19th, but I'm not interested in this.

I've decided to purchase an MSI Edge z690 and a 12700KF.  Will be moving over soon.


Once I have the new PC up I'm doing full-up CLEAN install of Win10 on the 3900x to see if that fixes it.  Some time in the next week or two hopefully.  As other have remarked, I'm not sure how Microsoft could be fully to blame on this or a warm-boot would fix it.

I have the same Problem on an Asus CH8 Dark Hero with an 5950X. It seems that some monitoring-framwork could trigger this issue. I had also installed different versions of iCue on my system - but none of it triggered this bug. I could nail it down to the Aquasuite software from Aqua Computer in my case. However, a monitoring-framework shouldn't lock all cores of the processor to 500MHz. So I would appreciate, if this bug could be fixed.


Dear All, 

I got the same Issue little while ago and here are my Specs, 

AMD R9 3900x
Asus Rog Formula VIII X570

ASus Rog ryujin 360 

TridenZ 64 GB Ram @3600 CL 16 

EVGA 1080 TI Hybrid


, and I tried the following, 


1. Change the Power plan, 
2. update Windows.

3. update x570 chipset drivers, 

4. restart the PC multiple times, 

all the above mentioned solutions didn't work , but I managed to fix it and it was a simple one, 

the issue was a combination of a 2, 
1. Aura Sync,

2. static charge, 

and i think it happened like this a static charge has been deducted and the motherboard shut down the static charge location (for me it was the RGB header which was connected to my CPU cooler), then Asus Aura sync sees that one RGB device has been disconnected and it tries to connect to it again, and due to poor app optimization it create a clock cycle bug that keeps on the same refresh rate of the Asus Aura Sync even when i changed the power plan the CPU goes to 2000mhz then back to 554 MHz, 


after all i shutdown my PC disconnect the Power Plug and pressed the power button to clear any static charge. then connected the power plug and started the PC and the problem went away, 




it's a static charge, and do a static discharge (like this) 

1. shut down your pc completely. 

2. Unplug the Power cord from the PSU, 

3. Press the power Button wait for 1 to 3 secs (do it multiple times).

4. Profit uummm i mean plug in your Power cord and start your PC normally. 


At the End ,
let me know if my post wasn't clear 


Thanks for the details.  The more we all share it helps on the patterns.

My PC has no longer had this occur at all since doing a completely clean install of Win10 Pro.

I'm just glad it current does not seem to be HW (CPU or motherboard) but it obviously is some kind of combo of an issue (software and hardware).

What is kind of discouraging is that there seems to be several very unique ways to solve this--but all have very similar symptoms.  That is unfortunate.  AMD should come out with some kind of white-paper on the cause of their CPU suddenly locking at a very low MHz with recommendations (whether static electricity or whatever).

The fact AMD has not ever replied to this to help has given me evidence to move back to Intel.  Their loss.



Are you still experiencing this on CH VIII Dark hero mobo?

I just built this mobo + 5900x.  Running into this issue - first day it happened 3 times.  Only cold boot seems to solve it.  Have yet to try toggling power management profiles.  Will be on next surface.  Ryzen master shows bogus #s when 100+ % TDC, EDC, Watts, low temps. 

Everything is current on build - Win10, amd chipset 06/27/22, BIOS 4201, etc.  XMP + Minimal PBO with 83C throttle limit.

I thought it may have been this discrete Asus TPM as it ran for 30 hours removed then did it again.  Not like many reports on a cold boot.  It does it when idle.  And stays until shutdown always.

I have not identified what causing it but suspecting some monitoring framework that puts BIOS into a bugged state.

I have discovered this other repeatable bug.  Have NZXT X73 - unfortunately use CAM software for pump speed.  Upon having open Ryzen master + NXZT CAM and restarting CAM, Ryzen master will go into a flapping non responsive state.  Sensors will read -1.  End task on Ryzen master and it will refuse to initialize again.  Must reboot for master to work again.  During this time that Ryzen master is in non responsive state the CPU clock is normal however.  I've re-created this 3 times now yet each time clock remains ok despite Ryzen master being in a not responding state.  So the reason why this $3K+ PC turns into a 500Mhz potato remains a mystery.

New build for friend.  First CH8 DH had defective WIFI.  Now this is nightmare.  If no resolution within Asus regarding power management / BIOS in few days I'll be returning entire platform Mobo, CPU, RAM and building an Intel.  Will be the PC's 3rd build in ~3 weeks...and a more involved Fractal Mesify 2 case in storage mode with 360mm AIO....FML.

How this issue got past my radar last breaker.

Journeyman III

I just want to confirm that NZXT software was causing my Ryzen 3900X with CH VIII wifi (not dark) lots of issues.

Often it would slow down cores which would make windows unusable, occasionally it would completely freeze and sometimes when frozen, holding 5 seconds power button wouldnt work, I would have to cut the power completely, and things like this would happen once in 1-2 days. 

For moths I thought its something with bios, disabling XMP, lowering and disabling lots of things, nothing helped. Finally you mentioned NXZT, and after I uninstalled it - wow! Like I'm having a new computer, I restored bios settings to optimized values and enabled XMP and for a week not a single freeze.


Adept II

Programming ACPI CPPC registers can stuck frequency to low values; between 550 and 750 MHz

However it should not persist among reboots, except if some software is auto altering the frequency during startup.

See my example : 

Journeyman III

I have the same issue with R5 7600 and ASUS TUF GAMING B650-PLUS WIFI. The issue seems to be entirely on a BIOS level.

The CPU has a 65W TDP.

In Ai Tweaker if I enter PBO "AMD Eco Mode" and "cTDP 105W" with manual Platform Thermal Throttle Limit of 90°C there are no problems.

If I enter PBO Mode "Enhancement" with Thermal Limit "Level 1 90°C", a few seconds to couple of minutes after boot all cores lock at 545MHz and the system is extremely slow. It never "unlocks" itself.

The 2 settings have the same level of "overdrive", so I just use the first one, but at least I have a repeatable scenario if someone ever investigates the issue. It seems it is a math error on BIOS level.

Adept III

set everything in bios to auto and remount and clean with air CPU place holder and see if that does not solve all your issues!!!

Adam J Martin