Showing results for 
Search instead for 
Did you mean: 


Journeyman III

7950X / Asus TUF X670E Plus WIFI - Can't Disable CCD

Hi All,

This is my first post on these forums as I now have a 7950X / Asus TUF X670e Plus WIFI build.

I'm trying to test performance between having 1 CCD enabled vs 2 CCDs.  Currently I'm using process lasso to set core affinity on certain game apps, but I'd like to test disabling 1 CCD altogether and see what kind of latency gains are to be had, if any.

In my BIOS under 'CPU Core Count Control,' it clearly states under 'CCD 01 Bit Map Down Core Control:' <Setting this item to 1 means core is enabled, setting this item to 0 means core is software down>.  The defaults for both CCD 00 and CCD 01 are <1-1-1-1-1-1-1-1>.  I changed CCD 01 to <0-0-0-0-0-0-0-0>, then click apply changes.  System saves and then reboots.  The problem is that my system won't post after I apply these settings.  I have to pull the cmos and trip the jumper for 5-10 sec to reset everything back to defaults.

Anyone have experience w/ this and possibly know what I'm doing wrong?  Perhaps it's just a BIOS bug that an update will fix in the future.  I'm currently on the latest BIOS ver for my board.


9 Replies

I believe in Ryzen Master you are able to disable 50% of the cores by disabling one or more CCDs but there are no Ryzen Master program to download for the 7000 Series processors yet.


It's available from


Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3600c16dgtzn kit, Aorus gen4 1tb, Nitro+RX6900XT, RM850, Win.10 Pro., LC27G55T..

Good find!

The Release Notes for that AMD Ryzen Master website download does show to be compatible with the new 600 AM5 Motherboards.

I wonder why AMD hasn't updated the AMD Download page to show that the 7000 series does indeed have Ryzen Master downloads.

Journeyman III

I have the exact same experience as you ... setting the Bit Map Down Core Control in the EFI/BIOS will prevent the system from booting ever again ... like you the only option is a hard reset of BIOS.  Clearly a bug that ASUS don't want to fix or maybe some AMD restriction?  (I'm using the ASUS Extreme X670E board).

If you get the latest Ryzen Master, you can disable CCD1 by selecting "Game mode" (default will be CCD0 only).  Or you can select Profile 1 or Profile 2 and then under Cores Section the "active CCD mode" option to click on 1 or 2 (click on 1).  BTW the UI for Ryzen master is terrible, it's not clear at all when a option is selected when they use those control ... if it's solid green that means it's selected or the dark gray that means it's selected?  After experimentation it's Green means selected but the visual cues are terrible, AMD need a UI/UIX designer for their software.



rainscough, there are conflicts between Ryzen Master (RM) and direct BIOS changes. Above it says there is no RM support for 7000 series. Use one or the other but never both to make changes. It sounds like RM works with your processor but you did not say what processor you have. I do not have a 7000 series processor so cannot test RM Enjoy, John.


I'm using the new 7950X3D ... RM doesn't allow me to do anything with it.  I also have a 7950X and RM does all me to make changes to CCD per above. 

For my 7950X3D, all changes I must be done thru EFI/BIOS.  I did get the latest RM and I did get the latest Chipset drivers that add support for the 7950X3D vCache but RM will not let me do anything with the 7950X3D.



I have x670e crosshair hero with 7950x3d. My first attempt to turn off ccd1 also resulted in bios not booting and had a c5 error, had to reset bios. I tried again not enabling expo, it worked. Then I tried again turning on expo II on my kit, works. Then I tried one last time, back to my original expo I, it worked again. I think maybe the memory optimization that happens when changing memory settings only applies on that type of bios changes and disabling ccds which under CPU overclocking might work differently and throw something out of wrack.

Anyways, just wanted to report disabling ccd does work.

made an account just to thank you good sir, this worked for me.

At first i tried just disabling expo by setting everything back to auto, still got C5.

after a clear Cmos disabling CCD1 worked, turned expo back on after that, still good.

Adept I

Asus rog strix gaming b670x-e and 7950x3d,  can't disable one ccd. Same issue.  System posts but not booting to windows