Showing results for 
Search instead for 
Did you mean: 


Journeyman III

7800x3d wont post

So I just built my new pc and when I got done making sure everything was plugged in and ready to go I hit the power to boot it up for the first time but just got the red and yellow cpu and dimm lights. after an entire day of googling and trouble shooting I ended up buying a new motherboard and the same issue is happening. Any help would be appreciated, I'm hoping im just stupid and am missing something here. I should also state I have not installed my GPU yet so i am using the onboard hdmi output to monitor for video but get nothing. 


mother board #1 MSI Mag B650 tomahawk. Cleared cmos. updated bios to most recent, Tried swapping ram sticks between a2 and b2 and also with no ram installed. let sit for about 20 minutes thinking maybe it was memory training. Checked pins on board no bent ones found

motherboard #2 NZXT N7 B650E Cleared cmos, swapped around ram and also removed all ram, updated bio. checked pins on board no bent ones found.

Thermaltake toughpower gx3 850W psu

corsair vengeance 2x16gb 5200MHz

After everything I have tried as troubleshooting the cpu and dimm lights stay lit and never changes.

7 Replies
Adept I

I had this exact same issue with the same motherboard and CPU combo but my PC had already been running fine for about 6-8 months with no heat or performance issues (apart from this). Only occasionally did I have this boot issue and after a few off/on cycles with the power button it would just randomly fix itself and make it to Windows. At one point it failed to post 3 times so I turned off the PSU via the I/O switch and then turned it back on and it made it past the BIOS just fine. I discovered my BIOS was way out of date so I updated it and the problem went away at the cold boot stage but it still happens if I try to sleep the PC and then wake it (just a blank screen and red + yellow DRAM and CPU lights). 

I've seen some ideas floated that it might be the RAM sticks in some way but I can't see how it would have worked this whole time if it had incompatibility issues. Also you have the same issue and we have different RAM so that seems to become less likely. The fact that the BIOS update limited this issue to boot from sleep confuses me more. If you come up with any solutions, kindly let me know. I'll do the same.


Sounds like your RAM may be failing. The intermittent behavior is strange, but when components are in the process of failing they tend to be inconsistent. Failing RAM can also cause issues in the OS over time. BIOS/chipset updates can improve RAM compatibility.

Have you tried running MemTest86?


I haven't tried MemTest yet, I'll give that a go and report back. Thanks for the tip!


That is a strange one.

  1. Have you gotten video output at any point on either of the motherboards?
  2. What method did you use to update the BIOS on each?
  3. Have you tried using a DisplayPort cable instead of HDMI?
  4. Are you using a CPU contact frame? If you've tightened it too much or unevenly, it could cause issues with the RAM and BSOD among other things.
  5. What CPU cooler are you using? If you've tightened it too much, it could cause issues with the RAM and BSOD among other things.
  6. Have you verified your specific RAM kit is on your motherboard's QVL list for the 7000 series CPU?
  7. Have you tried only 1 stick of RAM at a time? Seems much more likely 1 or both RAM sticks are bad than the CPU.
  8. Have you made sure the RAM is fully seated in the slot?

no video output, when i power on the motherboard cpu and dramm lights come on. I just got another set of ram in today the G. Skill Trident z5 and installed it and same issue still cpu and dramm lights. I am using the N7 B650E motherboard now and made sure it was compatible with both cpu and motherboard. I have taken the ram out and tried just 1 stick at a time in both a2 and b2 slot. sorry for such a late reply i ordered the new ram and kind of pushed it to the side until the ram showed up.


Sorry to hear it didn't work.


With the new RAM testing complete, it seems like the CPU is the culprit.


Exchange the CPU if possible, otherwise, open an RMA with AMD.


Good luck and let us know how it goes.



Did you try one stick of ram?

I bet the cpu is fine.