Showing results for 
Search instead for 
Did you mean: 


Journeyman III

5950x doesn't overclock

Hello, my 5950x is paired with an MSI x570 mpg gaming plus and a 64g 3200 memory. I have trouble in all core overclocking, for some reason no matter the maxed out limits in PBO, in all core situations it doesn't consume more than 120-140watts and hitting only 3500-3600 clock speed, manual voltage 1.35-1.40 and a core ratio of 43 crashes the pc.

I am new to overclock, so dont know how and why it happens when i see other 5950x hitting 200+watts 

10 Replies
Community Manager

What applications are you using on your system?


To monitor i use ryzen master, to load the cpu, i use prime 95, and cinebench r20


I was more getting at, are you playing games? If so, there is no point trying to overclock the CPU as it will just reduce gaming performance. The 5000 series processors come optimised for optimal gaming performance out of the box. No need to overclock all cores and reduce your performance. 

I use my pc to plot chia, the new cryptocurrency, it heavily relies on a multithreaded workload, so its very important to let the cpu use its power, cus now its a bottleneck 

Adept II

I have an Asus Rog Strix X570-I motherboard, 32 GB DDR4 4000 CL 14 Ram, an SF 850 Watt PSU.

In bios, I have AMDs version of XMP enabled, and PBO enabled.

When the system is running, I use Ryzen Master to overclock. I have 4.9 all core, and it boosts to 5.2 in applications that don't need all the cores in my 5950X. I'm using an NZXT Kraken Z63 for cooling. The software did all the OC work for me. I just put what I wanted for goals.

Adept II

What exactly are your PBO Setting?

You need to enable PBO set your values for the limits (or use the board limits). Be aware that your temps and power consumption will explode, you need a proper cooling solution! Better set the values by hand and test what your cooling solution is able to handle. Maybe first just try to raise TDC (Default 95A) and EDC (Default 140A) slightly and stay within the 142W. For the first step let all other settings @stock / auto. 


My PBO is set to advanced and the limits are 500W 500A 500A but the cpu still doesn't want to consume more than 120-140watts, the cooling is more than capable, dark rock pro4 is rated for 250watts

My psu is rated for 850watts, with an 8+4pin connector plugged in to the motherboard 

So i thought if there is a feature in this particular motherboard that is limiting the cpu or just the motherboard is not rated for 16 cores? But i didn't find anything

Edit: now I've done something and it doesn't want to go above 90 

Screenshot (2).png


You rly should read some basics about OC, thermals, and so on...

First of all set Voltage to Auto and lower your setting to 142W (and THEN try to increase as long thermals are ok).

As i said, this is only a plotting machine, it is used for Chia plotting, the cryptovurrency. Nothing else is running on it


Fixed Voltage = "Fixed" max clockspeed depending on "voltage-clocktable" as long you don't set the multiplier too, then you have a fixed clockrate. For 4,3GHz Allcore you will at least need around 1,3xV (not tested myself, need some research), depending on your CPU. BTW: I'm not sure PBO works with fixed voltages.

On single core use (~5GHz) Voltage jumps up to 1,50V

All Core Cinebench (@~3,80GHz) all cores are at around 1,0xV

Default the ~125W are roughly at >8 Core Load (Amp limit) and the 142W are at 8 Core Load

With your Workload and only an Dark Rock Pro just try to rise the TDC/EDC (105A/160A). In your screenshot you hit the 4-4,2GHz on at least 12 cores. Looks like dynamic clockrates would be the better choice maybe.