Showing results for 
Search instead for 
Did you mean: 


Journeyman III

5950x Cache Hierarchy Error

I have a new system built and running seemingly well, apart from this "fatal hardware error" which has popped-up at least twice (maybe more). 

Admittedly, I have another PSU coming from Corsair that will hopefully fix a 5% to 10% reproducible startup issue where the PSU has to turned off and then on before the system can power on.  Hopefully the cache hierarchy error I'm posting here now is a result of the PSU, but I thought I should mention the cache hierarchy error regardless.

The latest occurrence of this error resulted in all my current work halting as the system powered off/on by itself.  This happened in the past as well but I wasn't sitting in front of the computer when it happened.

My System Specs:
CPU - AMD 5950X
CPU Cooler - LianLi Galahad 360 AIO
Mobo - ASUS ROG X570 Crosshair VIII Hero Wifi (latest bios: 2502, XMP-Enabled (DOCP DDR4-3603 18-22-22-42), FCLK-1800MHz, PBO-Enabled, PBO Max CPU Boost Clk Override-200Mhz, Windows Power set to Ryzen Balanced (and Ryzen Performance, previously I think))
PSU - Corsair HX1200
UPS - Cyberpower 1500VA (100% charge)
RAM - G.Skill Trident Z Neo 3600 32GBx2 C18 (my motherboard is listed on the QVL) part# F4-3600C18D-64GTZN

All the latest drivers are installed, including the latest chipset drivers from AMD (not Asus).

Please advise on how I can resolve this issue, its been eating into my work productivity.  I've since set PBO and PBO Max CPU Boost to Auto and set Windows Power to Ryzen Performance to ensure adequate voltage or whatnot.  I'd very much like to be able to run this chip at its fullest capacity as I've invested in significant cooling (9 120mm fans including the 3 that are pulling on the AIO radiator).

Here's some detail from the error in event viewer:
Source: Microsoft-Windows-WHEA-Logger
Date: 11/19/2020 3:46:06 PM
Event ID: 18
Task Category: None
Level: Error
Description: A fatal hardware error has occurred.

Reported by component: Processor Core
Error Source: Machine Check Exception
Error Type: Cache Hierarchy Error
Processor APIC ID: 0

The details view of this entry contains further information.
Event Xml:
<Event xmlns="">
<Provider Name="Microsoft-Windows-WHEA-Logger" Guid="{c26c4f3c-3f66-4e99-8f8a-39405cfed220}" />
<TimeCreated SystemTime="2020-11-19T23:46:06.1955831Z" />
<Correlation ActivityID="{a292dcc3-5fa1-49ae-b6ff-cc1349f2e997}" />
<Execution ProcessID="4780" ThreadID="5744" />
<Security UserID="S-1-5-19" />
<Data Name="ErrorSource">3</Data>
<Data Name="ApicId">0</Data>
<Data Name="MCABank">5</Data>
<Data Name="MciStat">0xbaa0000000030150</Data>
<Data Name="MciAddr">0x0</Data>
<Data Name="MciMisc">0xd01a0ffe00000000</Data>
<Data Name="ErrorType">9</Data>
<Data Name="TransactionType">0</Data>
<Data Name="Participation">256</Data>
<Data Name="RequestType">5</Data>
<Data Name="MemorIO">256</Data>
<Data Name="MemHierarchyLvl">0</Data>
<Data Name="Timeout">256</Data>
<Data Name="OperationType">256</Data>
<Data Name="Channel">256</Data>
<Data Name="Length">936</Data>

50 Replies
Community Manager

Please can you enter the BIOS, and press F5 to apply optmised default settings, then press F10 to save and exit. Please do not change any BIOS settings for now. 


Run the system for 24-48 hours to see if you experience the same issue. 

@Matt_AMD wrote:

Please can you enter the BIOS, and press F5 to apply optmised default settings, then press F10 to save and exit. Please do not change any BIOS settings for now. 


Run the system for 24-48 hours to see if you experience the same issue. 

Matt would this be good advice for all with this error. There have just been a ton of users complaining of this issue with no clear idea on what is causing it. Some have claimed that replacement cpus have fixed it. While others say if they regress there Zen 2 processors bios to an older bios this goes away. 

Any idea on any of this? It would be great to have some idea on how to help users. 


I've tried the optimized defaults and it seems stable.
Also tried simply applying DOCP (3600) and FLCK 1800 with good stability.
Also tried enabling PBO with good stability.

I've since updated the bios to 2702 (released Nov.24) and it's running stable so far even with PBO enabled.
Bios 2702 has changed in that if you enable PBO, Max CPU Boost Clock Override is greyed-out.  I have a hunch that the 200Mhz value I set here previously was causing me grief, along with the Ryzen Balanced Power Option in Windows (just a guess).

I did have a bit of a scare though, as during the bios update (from BIOS UEFI via USB), it appeared to be a success, the system rebooted itself and went through the final update process after post.  At the end of the process where I'd expect another restart, the system powered off.  I couldn't power it on again until I turned off/on the PSU (like the problem I mentioned in my first post).  The system then started up and all was well.

I'll keep the system running and see how it goes. HOPEFULLY this new bios has fixed it. 

Also looking forward to Precision Boost 2 becoming available.

Be sure to disable write-caching on hard drives until the power states in bios get updated.  Small annoyances meh w/e.


I'm having the same issues, I've been able to mitigate it to some degree, but it's not completely gone.

- 5950x
- Gigabyte X570 Master
- PNY 3090 (non-OC edition) 

These are the settings I've gotten to "work"

  • Downgraded to the F30 Bios, the F31l BIOS was almost entirely unusable
  • Set the CPU Clock Ratio to 36.00 (unsure if this had any real impact)
  • Set the CPU VCore to Normal, considering setting it to a manual voltage, but I'm worried 
  • XMP to 3600 enabled on RAM, doesn't seem to have much impact either way

Default settings are really unstable, instant unplanned reboot in under 30 minutes typically.  With the settings above, I was able to maintain a synthetic load for over an hour with no issues. 

As of now, the only time I'm experiencing instant unplanned reboots are with low/no load. Like downloading files (not even steam files, as they are compressed & put a load on the CPU). 

If these changes are actually having an impact, I'm hoping a future BIOS update will fix the issues. The target market for 5950 & 3090 is content creators, and a huge part of their workflow is at low/no load. If they lose enough work in progress, you'll have an army of angry creative types, and no marketing department wants to deal with that. 


Temps ok? Running at XMP 3600 is fine. CPU clock ratio should work in Auto, kill the PBO and any overvoltage. Try manually setting the IF to 1800 vs. Auto. Auto IF can make things wonky. Best set at half the full RAM clock, no higher than 1800. Still unstable, drop IF to 1600 but you'll lose some performance that you might not notice. Memtest 64 should run for hours without an error, overnight if possible. Lastly if you have 4 RAM slots and 2 sticks they need to go in A2/B2 or the second and fourth slot from the CPU.

"It worked before you broke it!"

I was getting the same errors on mine. Tried many different BIOS settings and still kept getting reboots with the same Cache Heirarchy Error code. Finally got it stable by turning on the Asus TPU II OC setting that keeps my CPU at 4.1ghz speed. It actually runs cooler now and doesn't have crazy temp jumps like before. Haven't had one reboot in the last week. 

MOBO: Asus B550 F gaming
CPU: 5950x 
GPU: PNY 3090

PSU: 1000 W Corsair

Same issue as original post [whea logger, fatal error, processor core] and your cache hierarchy error... as well as several others.

like @ctnfoster  i also have: 5950x &  x570 Aorus Master w/latest bios [F33i from 3.25.21]

using g skill trident z neo 2x16 3600 & asus tuf 6900 xt gpu

computer randomly shuts down and auto-reboots... so far, only when i am not doing anything - pc is basically at idle

i'll try troubleshooting and if it becomes a bigger problem i do have a 3900x here as well but would very much like to stick with the 5950x... seems there's still a host of potential issues though which i suppose is to be expected since at this time there aren't any motherboards available that were made specifically for the ryzen 5000 series. maybe by the end of the year..?!?



You can try disabling DF states in the BIOS, not sure where Gigabyte hides it. It seems disabling sleep/hibernation functions in Windows helps. Using an SSD make sure that it's set to never power down. If your RAM is on the QVL, I'd test it with TM5, try running OCCT, try turning XMP off and enter the basic RAM timings/voltage by hand, set the FCLK or IF to 1800 for 3600 RAM. Manually set the SOC to 1.2, that fixes the issue for many. You can run lower SOC but stock is 1.2. 

All else fails, no PBO, and still getting error 18, RMA the CPU.

"It worked before you broke it!"

I'm just going to share this here since anyone else reading this using the same apps may be able to verify.

Full specs:
Ryzen 5 3600 4.2ghz All core undervolt 1.125v
DDR4 3600mhz 2x8gb ~C16,, HCImemtest 200% stable.
Gigabyte RX 6700 XT Slight undervolt, all big titles stable(Days gone, warzone, tarkov etc.).
Rebar enabled according to GPU-Z.
Agesa, updated to mid-may in an attempt to fix the Hierarchy Error, seems the Agesa is innocent.
Radeon Driver 21.5.2(this is also suspect as I jumped on 21.5.1 as soon as it released).

I started getting frequent Cache Heirarchy reboots at the start of May, roughly the same time I started using HWinfo(launch at startup) along side MSI afterburner with a undervolted Ryzen 5 3600, now this CPU is ROCK stable in everything I throw at it including long idle periods(I was concerned about the Vcore being too low at first) but now I suspect it may be an issue with Resizable Bar & GPU behaviour + Compute mode COMBINED with CPU trying to 'park' and getting polled for temps too frequently which would obviously be aggravated by multiple sensor programs but Im honestly unsure how the CPU+GPU communicate and if things like Compute mode and Rebar make much difference at all, only a AMD Tech would be able to answer it properly.

So the long story is, I was doing on & off mining, 24hr stable for MONTHS until I started benchmarking games again and set HWinfo to 'launch at startup' to integrate with Afterburner OSD. This is when the Heirarchy crashes began(early May). At first I suspected my undervolt immediately as it's 4.2ghz all core @ 1.125v,, but bumping up to 1.2v made no difference. I did not suspect HWinfo involvement at first, but over 3 weeks of very random and intermittent Heirarchy crashes(mostly at idle) I stumbled across a thread linking it to HWinfo(and other users confirming), so I disabled HWinfo launch at startup from that point, and stopped using all programs except MSI afterburner. 

No Heirarchy crashes until 13 days later, when I ran nicehash for all of 5 minutes but changed my mind and shut the PC down. The next day I was greeted with a Heirarchy crash when loading Cyberpunk shortly after boot. And THIS gave me a hint that a combination of not specifically sensor programs, but Mining software enabling 'GPU compute' mode was persisting after reboot and contributing to the Heirarchy crash, after a crash the GPU drivers reset which is why the issue seemed so intermittent. After the crash I loaded up Cyberpunk and tested for hours no problems.

So the TLDR is, Monitoring programs and any Mining software that may be enabling Compute mode are key factors in 'triggering' the Heirarchy issue, and it may be GPU related. I went from about 10 crashes between the first 2 weeks of May, to only one crash after removing HWinfo from my startup programs and avoiding 'compute mode' set by Nicehash. Its frustrating because while Compute mode can be manually enabled via mining software, its not as simple to disable since the switch back to graphics mode was removed from Radeon software.

The main reason for sharing this info is anyone with 'similarities' might have a clue were to start troubleshooting.




I can confirm your observation, since i had similar whea error when mining. 

I found that I also have the same problem, but the frequency of illness only appears when I watch a movie. Whether you are watching YouTube with a browser or watching a movie with a player, you can just turn on the computer without watching the movie.


Forget about "fixing" this, it is related to AMD defective ZEN 3 Architecture.

I've tried from December/2020 to May/2021 until I lost my patience and started a RMA of my 5950x.

After discussing about WHEA error, AMD decided to refund me, instead of send me another 5950x. So, they KNOW the problem they have with PB/Core Performance Boost and PBO, but since AMD is a trash company, they will never admit their mistake.

Here is my summary about all this Ryzen 5000 PBO Mess: Ryzen 5000 Crashes (WHEA Errors) will get a "Silen... - AMD Community


There is nothing to fix, because this issue being defective ZEN3 architecture in not a thing. Problem can be caused also by various applications, e.g. HWInfo and similar.

Also, probability of motherboard defect is more likely than CPU, since motherboards are the most RMAed things together with graphics cards.

Just install bare windows with the latest drivers, do not install any utilities from motherboard/cooling or additional software, load bios defaults and perform tests with games.


I have 5600X and Gigabyte B550I AORUS PRO AX motherboard.

Have been getting this same error and system reboot always follows.
It does not matter if computer is idling or not. 

Error Source: Machine Check Exception
Error Type: Cache Hierarchy Error
Processor APIC ID: 10

GPU is RTX2080S

Everything is custom watercooled and temps are in check. Also ram is running on default XMP profile, no manual tuning.
Altough PBO has been setup. And is rock solid when running hours of Cinebench23....

Motherboard bios is F12 (latest stable) with AGESA
There is newer beta bios F13i.

Edit: just checked today 13'th of July 2021, Gigabyte has release stable F13 bios!

In the description there is not much mentioned:

  1. Checksum: C66F
    1. Update AMD AGESA ComboV2 B for Ryzen 5000 G-Series processors support

Maybe I should try that...

But something fishy has been happening. Do not remember these kinds of errors few months ago.
Also i have MSI Afterburner starting when Windows is booting. But I usually manually start HWInfo64 manually later.





Well again, you can quickly Google that this issue is caused by third party applications such as HWInfo, yet  something fishy has been happening ...

Just load bios defaults, reinstall windows to clean, install drivers only without any additional motherboard/rgb/control software.


At this point, I think AMD should close these forums, because it is full of nonsense complaints "broken ZEN architectures", conspiracies, etc.


Frustrating reading through these and many other threads like it, in many places,

Running a 5950X - geforce 3080TI FTW, 32GB Gskillz 3600 RAM. Gigabyte X570 Aorus Master 

Random reboots WHEA-Logger 18 on CPU 0 and 1.

Endless tests/passes in memtest.

Had the issue with fresh build immediately. New windows, default drivers/everything. No bloat or 3rd party apps whatsoever.

installing the utilities and updated drivers for everything actually significantly improved/reduced the frequency of the reboots.


Its not related to AMD GPU as I have Nvidia.  Its not related to HWinfo or monitoring apps as it  happened to me and many others without any of that even downloaded yet.

Also not related to F31 or above firmware as some suggested rolling back to F30 since late last year.  It happened to me starting with F30. haven't tried F31 through F34 yet.  Gigabyte's site is broken I can't even download them they mostly all 404. 

Haven't tweaked any settings but found a couple promising workarounds that seem to have worked for people (disabling XMP, CPB, PBO, lowering curve optimizer) but all of those were already disabled and haven't touched any settings yet. 

Would really love a solution to this besides "RMA"


I've run my 5950x on a gigabyte X570 Aorus Master v1.0 with bios versions 33-34 without any issues.


How strange... Gigabyte has pulled the July F13 bios and has replaced it with earlier F13g bios!
At least for my B550i ax board.


I've noticed that the support page for my mb is in transition and all of the bios versions were pulled except for the original F1.  Last week I couldn't even get into it.


Gigabytes site is crap. Half of the firmwares 404 but I managed to grab F34 on luck alone.  Also, All links to contact technical support are also broken.  So, just like their applications, then.

So I don't think they pulled any firmware links, their **bleep** is just broke.  I tried a couple days in a row, hoping they'd fix it


Don't forget that Tweaktown has their latest bios versions too.  This afternoon I tried using the bios utility and it couldn't contact any of their servers anywhere around the world.


Got my reboots to stop.  It was the F30 bios firmware on Gigabyte X570 Aorus Master rev1.2 motherboard.

Basically the gigabyte "BIOS" utility was saying it was updating to latest but it wasnt.  Also you could not download any/most of the BIOS from Gigabyte's site. Apparently they got hit with ransomware attack and have been slowly recovering for weeks and that's why so many of the utilities/drivers/bios downloads are still 404ing on their site.    I know now that I could have grabbed it from Tweaktown but I was attempting other driver updates and fixes before this (thinking BIOS was up to date, and stable). Some people said their F30 was stable so I left it.  

Once F34 became available I tried it and all my event viewer errors went away, haven't had a reboot in 4 days (it was rebooting at least once ever 12-24 hours previously)



Sounds like a classic vdrop.  idk anything. I wasn't here.


I have the same issue with a 5950X. Sometimes the cache Hierarchy error happens directly, sometimes after a few hours. All with default bios settings. I'm using the latest bios version from MSI MEG X570 UNIFY, 7C35vA82. The version before was even worse.

I tried reducing Precision Boost Overdrive to 95 Max in bios, reduced the ram speed, or reduced/fixed the fabric speed. It made no difference.

I do java number crunching, no gaming.



There seem to be a lot more users having the same problem, with default bios settings.

Discussion in German:


Journeyman III

I have the exact same problem with my new Ryzen 9 5950X. I've already tested 2 different motherboards (ASUS, Gigabyte), each with the latest BIOS and everything on default settings.

I have also tested 2 different RAM kits and dozens of other settings.

In any case it leads to the mentioned error again and again:

Serious hardware failure.

Reported by component: processor core
Error source: Machine Check Exception
Error type: Cache Hierarchy Error
Processor APIC ID: 14


I sorta asked the same question in a few posts. My 3600X has done this since day1, it's intermittent, nothing solves it, ever. I read it was the AMD video driver, can't be, OP is using Nvidia. I ran default settings 72 hours and it would still happen. If I look in Event Viewer now, it's probably there. Doesn't always crash the PC, sometimes just an app or nothing and I find it when it does crash. 2 days ago I got it running OCCT to see why my PC crashes, thinking it's the RX 5600 XT GPU or driver for it. Reinstalled Windows, nope. 

I feel bad for the OP but good i didn't go spending more money building with new AMD products. My build is 7 months old and I have 20+ years exp. building PC's for myself and customers, 98% AMD. Had little to no issues with any platform until now. @Matt_AMD  Many have similar complaints and tried exactly what you mention. Yields nothing but the same error to the point I'm past returning anything to the vendor. AsRock needs a specific reason to RMA my board. AMD would probably want more than this code to warranty the CPU, if so there's a whole lots more to warranty out there. Guess I can't blame Gigabyte for a faulty RX 5600 XT either. "Processor Core Failure" or "cache hierarchy error", "Processor Core Bus Interconnect error/corrected" all actually do relate to the CPU, not the GPU. Correct? 7 months of getting the wrong info.... 

So given all of my hardware checks out except for the above mentioned errors, AMD should replace my CPU and that will fix this nightmare? Where do i send my receipt? How do I get the process going?

"It worked before you broke it!"

Yah I have to say the lion share I see on these are mostly 3600 processor but likely as they probably sell more of those. Now we are seeing them on the new Zen 3. I don't remember seeing complaints of this until after bios updates came out mid year. 

So I do wonder if a bios microcode change is causing this? No idea!

I do know that lots of things can cause this error. Almost any system component even malware and registry corruption can cause it. 

However it is odd that so many Zen customer vs all other are reporting this. 


Then you write me a patronizing message about this same subject??? Here you admit there's a lot of 3000 series customers having the same problem. This happened from my very first BIOS before the one that came out over the summer. Then there was one that caused huge issues or something that Igor's Lab ID'd as a prerelease sub beta. Caused a huge stir and most of us that do their own work rolled back. 

I'm open to a BIOS update vs. RMA to fix the issue. I guess it takes a dude to build a $4k PC and have it crash out of the box to get proper attention.

"It worked before you broke it!"
Adept I

Had this too. 

A fatal hardware error has occurred.

Reported by component: Processor Core
Error Source: Machine Check Exception
Error Type: Cache Hierarchy Error
Processor APIC ID: 2

The details view of this entry contains further information.

Two restarts so far, on a brand new build from the ground up. Random.

Didn't happen during a large Aida system stress test, or even CPU-specific. Just when I was downloading some games via a PC client, and running Windows Defender scans.


I tried quiet a lot. Disabling boost, disabling XMP, loading bios defaults, underclocking Ram, etc..

I did remove and readded the CPU and reduced my ram timings (underclocking) from the advertised 16-19-19-39 to 18-20-20-40, and I haven't experienced any crash now in 2 days.

Seems to be a ram/board/cpu incompability.

Try DRAM Calc and be sure to run Memtest 64 for a few hours or until an error. Aida64 or CPUZ will give you all the sub JDEC's of you RAM. Somethings never change with AMD Ryzen and that RAM compatibility. i have a 3600x, same issues until I dropped my IF to 1800 from 1866 and reduced my RAM speed to 3600 from 3733. They claim these 5000's can do 2000 on the IF, no way, 1900 is a tough one. Most I read about are stuck at 1800-1866.

"It worked before you broke it!"
Journeyman III

I'm also getting the same issue, have brand new system with default settings and this happens randomly, sometimes after 72 hours, sometimes after3 hours...

Did you find any solution?


A fatal hardware error has occurred.

Reported by component: Processor Core
Error Source: Machine Check Exception
Error Type: Cache Hierarchy Error
Processor APIC ID: 14

The details view of this entry contains further information.


Processor AMD Ryzen 9 5950X 16-Core Processor, 3401 Mhz, 16 Core(s), 32 Logical Processor(s)

BaseBoard Product PRIME X570-PRO

Installed Physical Memory (RAM) 32.0 GB


If you ruled out RAM, just RMA the CPU and stop wasting your time. Messing with voltages and overclocking the darn thing is not a solution.
The CPU is busted from factory.
Visit to see how many fixed their problems with a new CPU.

What I read on that thread was a small percentage had to replace the CPU or thought so. Many had BIOS related issues, could be due to a variety of things from wrong BIOS to settings in the BIOS. Your exact board model you never say but from the BIOS numbers you mention I'd say it's a Gigabyte something.

16.7% or 29 in that "vote" claim the replacement CPU was the issue. All claimed switching from a 3950X to the 5950X caused a WHEA problem. 37.9% were the 5950X. Nothing definitive says that AMD 5000 series CPU's have an issue directly related to the CPU itself. Yours seemed to be fixed by a RMA. I'm sure a few are bad but that doesn't prove a mass bad batch. I did a real thorough search online and found no consistent trend of defective 5950X's.

AGESA problems abound, so board to board there may be something with that to patch. I'm not advocating an OC as a fix, it should work out of box, with possible BIOS changes due to it's new tech on the same platform of AM4, hopefully one has an X570 board. A lot are buying these and putting them in budget B550 boards and I think that's a mistake, even if the BIOS claims to handle it.

Most seem to fix it with RAM settings or sub-timings. While I'm sure some are bad, I really think most of these failures are RAM related or setting the IF too high. Depending on the RAM kit one might need to manually set timings, start with no XMP, use DRAM Calc to find "safe" timings for no more than 3600mhz. Set the IF at half the RAM speed or no higher than 1800Mhz. SOC can be set to 1.2V solid, which is the stock SOC for that CPU. If you have LLC set it in the middle or about a 3. With those settings right, enabling PBO shouldn't be an issue with an AIO or decent cooler.

If you still think the CPU is faulty do what @Matt_AMD  says and RMA it. I'd make sure everything else is right first, because stock is low, you'll be waiting a while.

"It worked before you broke it!"

Same issues as the OP, current build in sig have 9KB 5950x

Already put in an RMA request. BS that a brand new processor should have so many issues. My old  3900x had way less problems from start.

[ AMD Ryzen 9 5950X | NZXT Kraken x63 | MSI MPG X570 GAMING PRO CARBON 7B93v1B | 64GB DDR4 3600MHz G.Skill Neo 16-19-19-39 | ASROCK 6900XT Phantom Gaming D | EVGA G3-1000 | SSD 970 EVO NVMe M.2 1TB ]

Try turning the RAM down to 3200. Ryzen's seem to have issues running higher than that with 4 sticks of RAM. I can nearly also state it's very board specific. MSI is notorious for building "daisy-chain" RAM topology vs. "T" topology and this can cause problems when all 4 slots are used. However, not many Ryzen anything's can run 4 sticks at 3600. You can try manually setting the IF to 1800 but I'd try setting the RAM to 3200. Dram Calc can help find the timings for running at that speed optimally. Use the A)/B0 setting on the calculation screen. Here's a pic of said screen.dram.png

"It worked before you broke it!"

Will look into trying this. What's the best way i can find out what Ram topology is being used for the Motherboard?

[ AMD Ryzen 9 5950X | NZXT Kraken x63 | MSI MPG X570 GAMING PRO CARBON 7B93v1B | 64GB DDR4 3600MHz G.Skill Neo 16-19-19-39 | ASROCK 6900XT Phantom Gaming D | EVGA G3-1000 | SSD 970 EVO NVMe M.2 1TB ]