Showing results for 
Search instead for 
Did you mean: 


Journeyman III

5950x Cache Hierarchy Error

I have a new system built and running seemingly well, apart from this "fatal hardware error" which has popped-up at least twice (maybe more). 

Admittedly, I have another PSU coming from Corsair that will hopefully fix a 5% to 10% reproducible startup issue where the PSU has to turned off and then on before the system can power on.  Hopefully the cache hierarchy error I'm posting here now is a result of the PSU, but I thought I should mention the cache hierarchy error regardless.

The latest occurrence of this error resulted in all my current work halting as the system powered off/on by itself.  This happened in the past as well but I wasn't sitting in front of the computer when it happened.

My System Specs:
CPU - AMD 5950X
CPU Cooler - LianLi Galahad 360 AIO
Mobo - ASUS ROG X570 Crosshair VIII Hero Wifi (latest bios: 2502, XMP-Enabled (DOCP DDR4-3603 18-22-22-42), FCLK-1800MHz, PBO-Enabled, PBO Max CPU Boost Clk Override-200Mhz, Windows Power set to Ryzen Balanced (and Ryzen Performance, previously I think))
PSU - Corsair HX1200
UPS - Cyberpower 1500VA (100% charge)
RAM - G.Skill Trident Z Neo 3600 32GBx2 C18 (my motherboard is listed on the QVL) part# F4-3600C18D-64GTZN

All the latest drivers are installed, including the latest chipset drivers from AMD (not Asus).

Please advise on how I can resolve this issue, its been eating into my work productivity.  I've since set PBO and PBO Max CPU Boost to Auto and set Windows Power to Ryzen Performance to ensure adequate voltage or whatnot.  I'd very much like to be able to run this chip at its fullest capacity as I've invested in significant cooling (9 120mm fans including the 3 that are pulling on the AIO radiator).

Here's some detail from the error in event viewer:
Source: Microsoft-Windows-WHEA-Logger
Date: 11/19/2020 3:46:06 PM
Event ID: 18
Task Category: None
Level: Error
Description: A fatal hardware error has occurred.

Reported by component: Processor Core
Error Source: Machine Check Exception
Error Type: Cache Hierarchy Error
Processor APIC ID: 0

The details view of this entry contains further information.
Event Xml:
<Event xmlns="">
<Provider Name="Microsoft-Windows-WHEA-Logger" Guid="{c26c4f3c-3f66-4e99-8f8a-39405cfed220}" />
<TimeCreated SystemTime="2020-11-19T23:46:06.1955831Z" />
<Correlation ActivityID="{a292dcc3-5fa1-49ae-b6ff-cc1349f2e997}" />
<Execution ProcessID="4780" ThreadID="5744" />
<Security UserID="S-1-5-19" />
<Data Name="ErrorSource">3</Data>
<Data Name="ApicId">0</Data>
<Data Name="MCABank">5</Data>
<Data Name="MciStat">0xbaa0000000030150</Data>
<Data Name="MciAddr">0x0</Data>
<Data Name="MciMisc">0xd01a0ffe00000000</Data>
<Data Name="ErrorType">9</Data>
<Data Name="TransactionType">0</Data>
<Data Name="Participation">256</Data>
<Data Name="RequestType">5</Data>
<Data Name="MemorIO">256</Data>
<Data Name="MemHierarchyLvl">0</Data>
<Data Name="Timeout">256</Data>
<Data Name="OperationType">256</Data>
<Data Name="Channel">256</Data>
<Data Name="Length">936</Data>

50 Replies
Community Manager
Community Manager

Re: 5950x Cache Hierarchy Error

Please can you enter the BIOS, and press F5 to apply optmised default settings, then press F10 to save and exit. Please do not change any BIOS settings for now. 


Run the system for 24-48 hours to see if you experience the same issue. 


Re: 5950x Cache Hierarchy Error

Sounds like a classic vdrop.  idk anything. I wasn't here.

Adept I

Re: 5950x Cache Hierarchy Error

I have the same issue with a 5950X. Sometimes the cache Hierarchy error happens directly, sometimes after a few hours. All with default bios settings. I'm using the latest bios version from MSI MEG X570 UNIFY, 7C35vA82. The version before was even worse.

I tried reducing Precision Boost Overdrive to 95 Max in bios, reduced the ram speed, or reduced/fixed the fabric speed. It made no difference.

I do java number crunching, no gaming.



Adept I

Re: 5950x Cache Hierarchy Error

There seem to be a lot more users having the same problem, with default bios settings.

Discussion in German:


Journeyman III

Re: 5950x Cache Hierarchy Error

I have the exact same problem with my new Ryzen 9 5950X. I've already tested 2 different motherboards (ASUS, Gigabyte), each with the latest BIOS and everything on default settings.

I have also tested 2 different RAM kits and dozens of other settings.

In any case it leads to the mentioned error again and again:

Serious hardware failure.

Reported by component: processor core
Error source: Machine Check Exception
Error type: Cache Hierarchy Error
Processor APIC ID: 14


Re: 5950x Cache Hierarchy Error

@Matt_AMD wrote:

Please can you enter the BIOS, and press F5 to apply optmised default settings, then press F10 to save and exit. Please do not change any BIOS settings for now. 


Run the system for 24-48 hours to see if you experience the same issue. 

Matt would this be good advice for all with this error. There have just been a ton of users complaining of this issue with no clear idea on what is causing it. Some have claimed that replacement cpus have fixed it. While others say if they regress there Zen 2 processors bios to an older bios this goes away. 

Any idea on any of this? It would be great to have some idea on how to help users. 


Re: 5950x Cache Hierarchy Error

I sorta asked the same question in a few posts. My 3600X has done this since day1, it's intermittent, nothing solves it, ever. I read it was the AMD video driver, can't be, OP is using Nvidia. I ran default settings 72 hours and it would still happen. If I look in Event Viewer now, it's probably there. Doesn't always crash the PC, sometimes just an app or nothing and I find it when it does crash. 2 days ago I got it running OCCT to see why my PC crashes, thinking it's the RX 5600 XT GPU or driver for it. Reinstalled Windows, nope. 

I feel bad for the OP but good i didn't go spending more money building with new AMD products. My build is 7 months old and I have 20+ years exp. building PC's for myself and customers, 98% AMD. Had little to no issues with any platform until now. @Matt_AMD  Many have similar complaints and tried exactly what you mention. Yields nothing but the same error to the point I'm past returning anything to the vendor. AsRock needs a specific reason to RMA my board. AMD would probably want more than this code to warranty the CPU, if so there's a whole lots more to warranty out there. Guess I can't blame Gigabyte for a faulty RX 5600 XT either. "Processor Core Failure" or "cache hierarchy error", "Processor Core Bus Interconnect error/corrected" all actually do relate to the CPU, not the GPU. Correct? 7 months of getting the wrong info.... 

So given all of my hardware checks out except for the above mentioned errors, AMD should replace my CPU and that will fix this nightmare? Where do i send my receipt? How do I get the process going?

"It worked before you broke it!"

Re: 5950x Cache Hierarchy Error

Yah I have to say the lion share I see on these are mostly 3600 processor but likely as they probably sell more of those. Now we are seeing them on the new Zen 3. I don't remember seeing complaints of this until after bios updates came out mid year. 

So I do wonder if a bios microcode change is causing this? No idea!

I do know that lots of things can cause this error. Almost any system component even malware and registry corruption can cause it. 

However it is odd that so many Zen customer vs all other are reporting this. 


Re: 5950x Cache Hierarchy Error

Then you write me a patronizing message about this same subject??? Here you admit there's a lot of 3000 series customers having the same problem. This happened from my very first BIOS before the one that came out over the summer. Then there was one that caused huge issues or something that Igor's Lab ID'd as a prerelease sub beta. Caused a huge stir and most of us that do their own work rolled back. 

I'm open to a BIOS update vs. RMA to fix the issue. I guess it takes a dude to build a $4k PC and have it crash out of the box to get proper attention.

"It worked before you broke it!"