cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

Refrax21
Adept I

5800x Plagued by WHEA 18 Errors

Hello everyone! I'm coming to you all with yet another WHEA 18 error issue because I've tried seemingly tried everything with no luck. The backstory here is I had a totally stable system running a 3600x + 6800XT, when I got my 5800x from Microcenter last year I would get WHEA 18 errors (with various APIC ID numbers) when gaming. Since the issues began, I have tried: New PSU, new RAM, disconnecting various hardware such as hard drives/SSDs, full clean install of windows, BIOS updates, messing around with RAM XMP on/off/manual, disabling PBO, enabling PBO, using PBO with manual settings, installing latest chipset drivers, trying various GPU drivers to no avail. My last thought a few weeks ago was surely my CPU was defective. I RMA'd my CPU, got one back in a week, and nothing has changed! So after the new CPU came back, next thing was to change my mobo:

After the component swaps, my build is now:

Gigabyte B550 Aorus Elite (Have tried BIOS F14, F15, and F16a - no changes)

ASUS TUF Gaming 6800XT

Ryzen 5800x

Corsair Vengeance Pro CMWX16GX4M2C3200 C16 - 16 GB

EVGA Gold 1000w power supply

Corsair H110i cooler

So with these new parts, I've been running Cinebench and OCCT to test all sorts of BIOS settings. I can consistently pass both tests with PBO on auto or PBO on manual settings, generally with PPT 120, TDC 75, EDC 130 and a curve of -15. I also pass tests with all BIOS settings on optimized defaults. However, within 30mins to 1.5hrs of gaming I get the black screen crashes, windows is still running in the background (can hear discord still running etc), then I have to hard reset with the power button. Event log reveals WHEA 18 errors each time.

What is particularly alarming to me is that even with completely stock BIOS settings and XMP off, I get these errors and I've tried the three most recent revisions of the BIOS. During gaming and these tests, my thermals are maxing out at around 75 degrees so I don't think temperature is a problem. During gaming they consistently sit in the high 60s for COD MW2.

Does anyone have any recommendations on things I may have missed or something else I can try? Any help is greatly appreciated!

0 Likes
12 Replies
MADZyren
Paragon

Do you have any strong magnet or subwoofer is loudspeaker very close to PC?

Do you plug computer straight to wall or extension cord? Try moving your computer and plug it to another room with different wallsocket.

If you have some RGB-device, USB-splitter, or anything of a sort, unplug it for testing.

Pull out those tiny connectors that feed pwr and hdd LED and pwr and reset switches right after you have started computer (for testing)

When you changed PSU, did you also change all the power cables? Generally you shouldn't use cables of one PSU with another (unless identical model). 

When you reinstalled Windows and drivers, did you install directly the latest driver from AMD's website? If you first installed some older version, they sometimes have an instruction to uninstall old drivers before installing new if new drivers structure is very different.

Any chance you could borrow someone elses GPU for testing, because if that is the only component which has not been changed...

 

 

Thanks for the suggestions! PC is plugged into the wall outlet, I'll try to find a different circuit that I can setup at.   Drivers were installed from AMD directly. PSU cables were all changed when the new PSU came in. Unfortunately no loaner GPUs are available to me at this time.

0 Likes

Seems like many people who get blackscreens mention discord. Maybe try without it first.

Some people who get black screens (not sure if they get that WHEA or not) have gotten rid or reduced problem by one of these:

1) Disable AMD Crash Defender service


2) If you have Apex Legends installed, uninstall it, remove graphics drivers and reinstall drivers (not the game anymore)


3) Disable Multiplane overlay (MPO). Here are registry fixed to disable and enable it: https://nvidia.custhelp.com/app/answers/detail/a_id/5157/~/after-updating-to-nvidia-game-ready-drive... 


4) Disable hardware acceleration: https://learn.microsoft.com/en-us/dotnet/desktop/wpf/graphics-multimedia/graphics-rendering-registry... 


5) Use only monitor, unplug the other one


6) Disable hardware acceleration from software like web browsers, Steam aso.

0 Likes
ThreeDee
Paragon

What case make/model are you running? how is your air flow?

try a good air cooler and see if you get same issue(s)

IF your VRM's and RAM get too warm .. that can cause issues too. Going from 65wtt to 105wtt TDP might be enough to push thermals over the edge .. 

Could be a thing .. maybe not .. 


ThreeDee PC specs

Thanks for the suggestion! I have a fractal design meshify with front fans intaking and my 240mm radiator and fans exhausting up top. I wish I had a good air cooler on hand to try, it's getting tiresome ordering and trying new parts!

0 Likes
mama
Adept II

You've set your undervolt in PBO2 too low on at least one core.  Use CPUZ to map and identify the issue. 

0 Likes

I've stated in my post that I have the same results whether I'm undervolting or not, but thanks for the suggestion!

0 Likes
mama
Adept II

Also, your TDC seems low.  Try adjusting up.

0 Likes
ed6698
Adept III

When you say you are testing and gaming at completely stock values. Is that with the PPT, TDC and EDC at their default settings? 

Asus ROG Crosshair VIII Dark Hero - Ryzen 5950X - Noctua NH D15 Chromax Black - 4x8GB 32Gb GSkill DDR4 @3800 - Asus RTX 3070 TUF OC V2 - Samsung 980 Pro, 970 Evo Plus, Corsair Force GT - Super Flower 1000W Leadex SE Platinum
0 Likes
G1n
Adept III

The only thing that made a difference for my WHEA ERRORS ID 18 was to revert back to older bios. For my Asus Prime 570X-P both 3405 and 3603 did manage to avoid these errors so far, but need more testing to make sure they aren't coming back.

0 Likes

I think it was between 3000 and 4000 versions of BIOS where the structure of the BIOS changed and instruction was to first set BIOS to default and only after then to upgrade. Also if you had any saved memory settings in BIOS, those became useless and you had to manually set them again and save to new profile. So I was wondering if your errors were due to memory timings being wrong after BIOS update, if you didn't do it like that.

0 Likes

No, after updating BIOS I manually put the RAM settings, tried XMP, tried F5 Optimized defaults, tried PBO limts, etc. Nothing worked, only downgrading to those versions helped. In fact  have almost 0 stutter compared to latest ones, and CPU run at lower temps I have no idea why, Voltage seems the same.

0 Likes