cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

Highlighted
Journeyman III
Journeyman III

5600x not posting on B550 board

Hi everyone, 

I'm building a new PC, using a 5600x and B550 board. 

first start, EZDebug lights up for CPU, so I reseated it. No change. Did a POST test without anything plugged in. Flashed the BIOS, still doesn't POST. I've also checked the PSU cables, and they're in tight.

 

I'm at a loss, anyone have any suggestions??

Thanks. 

0 Kudos
6 Replies
Highlighted
Esteemed Contributor III

Re: 5600x not posting on B550 board

Does the BIOS you flashed state that it supports the 5600X?
0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: 5600x not posting on B550 board

Yes, it should. 
it’s worth mentioning, I can’t actually get into the Bios, i just get a black screen, no response at all from my keyboard, mouse or anything. 

0 Kudos
Highlighted
Big Boss
Big Boss

Re: 5600x not posting on B550 board

Is it a new mobo with 'USB Flash Back' support.

For kb/m are they in usb 2 port for initial setup.

Assume you also have graphics card installed and powered.

Maybe post your full system specs, might help someone offer further suggestions.

 

Edit: 'USB Flash Back'

 

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3200c16d kit, Aorus nvme gen4 1tb,
0 Kudos
Highlighted
Journeyman III
Journeyman III

Re: 5600x not posting on B550 board

It is a new board, with USB flash support. 
full specs are:

Ryzen 5 5600x, stock cooler. 
MSI B550-A pro motherboard 
Asus gtx 1060 6gb

crucial ballistix 2x8gb DDR4 3600C16

psu is corsair CX600-M

I also have a new crucial m.2 ssd, but at the time of writing this, no storage is plugged. 

I’m suspicious about my board though, as just for fun, I tried plugging an optical mouse in every port (restarting every switch) and it would not power up. Could there be a problem with the motherboard itself, which is why it’s having a “cpu not detected/ fail” light come up on the ez debug leds?

0 Kudos
Highlighted
Big Boss
Big Boss

Re: 5600x not posting on B550 board

Sorry, my mistake.

I should have said 'USB Flash Back', which is a different option.

A quick look through your mobo manual suggests it does not have that option.

Suggest you contact MSI support to confirm, otherwise you need an older cpu, or MSI may have other options to upgrade bios before installing the new one.

Ryzen 5 5600x, B550 aorus pro ac, Hyper 212 black, 2 x 16gb F4-3200c16d kit, Aorus nvme gen4 1tb,
Highlighted
Journeyman III
Journeyman III

Re: 5600x not posting on B550 board

Well, it has a flash Bios button at the back, and seemed to work as intended... I just have no way of confirming it did anything. I've contacted MSI, and will update when I get confirmation.

Thanks!

Edit: they told me to grab an AMD boot kit :/

0 Kudos