cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

hubog3
Journeyman III

5600X and Rog Strix B550-E Boot

Hello all, 

I have been experiencing this issue with my system.

Whenever I do a hard reset and unplug my pc from the wall (whilst cleaning it) and then plug it back in when I’m finished my pc is unable to boot. My pc turns on however a yellow/orange ish LED lights on up my motherboard which in my manual is related to a RAM issue. (Specs written below)

I thought it was an issue with my RAM however I have tested both sticks and they are working correctly. After hours of troubleshooting I figured out I try reset my cmos. I tried resetting the headers and it fixed my issue. However now each time I need to do a hard reset the issue returns and I need to reset cmos headers again. 

For context I noticed this issue happening when I upgraded my power supply. I upgraded from 650w to 750w.
Does anyone have any ideas as to why this is happening? Although I don’t have to do a hard reset very often it is still very annoying to have to fix afterwards.

My current specs are:

Ryzen 5 5600X

Asus Rog Strix B550-E

Corsair vengeance pro 16gb 3200mhz

Asus Tuf RTX 3070 OC 

Corsair RM750w gold 

If anyone knows of any solutions then please do let me know! I would appreciate it very much, thank you. 

Tags (2)
0 Kudos
1 Reply
mackbolan777
Forerunner

Re: 5600X and Rog Strix B550-E Boot

No offense, but Corsair RAM is just not great and doesn't mesh well with AMD Ryzen Zen 3 at least. Aside form that, I suggest not using XMP/DOCP and instead manually enter the RAM info and voltage. There's a new BIOS out, so be sure to update to it. If that doesn't work, ensure the RAM is on the QVL and I'd still swap that out to some GSkill Ripjaws V, Patriot Viper/Steel, Crucial Ballistics, Team Group Dark or Dark Za. Those seem to work well. Other brands might too, just forget Corsair RAM with AMD, IMHO.

"It worked before you broke it!"
0 Kudos