cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

RocKWooD
Journeyman III
Journeyman III

4650G and issues with a B550 Motherboard

Hello there,

I had issues with my new pc, tried to solve them and finally fixed and now I am writing this to help others who have similar issues.

My system is as following:

CPU: Ryzen 5 4650G

Motherboard: MSI B550 Gaming Edge Wi-Fi

Ram: Crucial Ballistix 2x16GB DDR 3200

GPU: Sapphire 5600xt Pulse

Drive: Samsung 970 Evo 500GB

I start building my pc in October, and having black screens with application blocked warnings. First I though issues are related to GPU (driver issues as you all know), I contacted with Sapphire if I had an defective GPU, they try to help with regular fixing options (DDU, fresh install of Windows etc...) I also contacted with AMD, and sent them bug reports but then I realized I had USB disconnect issues (especially on extendable ones which are on the bottom edge of the motherboard), and I realized it may be related to motherboard.

I am building computers for almost 20 years, I still keep my Athlon XP 2500+ (Abit AN7) and Opteron 185 (Asus A8N SLI Deluxe) machines and all those years I kept myself away from MSI, usually prefer Asus and lately Asrock (since I had issues in past with MSI especially with K8N that I returned). But I could not find any B550 Asrock (especially Steel Legend or Extreme4 at least and also a little frustrated with their behavior to hardware unboxed) motherboard in my country so I had to choose MSI.

Anyway, long story short, my problems are fixed with 2021-01-18 MSI motherboard bios update with revision 7C91v15. The PCI Express version settings were missing in the bios and motherboard was switch between 1.1 to 3 (maybe even trying to switch to 4 even I don't have a supporting CPU or GPU or NVME). With the mentioned bios now I am able to set PCI Express version 3. So I am writing this to inform that even my cpu is not a 5000 series, I also had same issues with B550. I thought it could help someone having similar issues.

As we all know new tech can bring issues, this is not the first time and it won't be the last. I read in internet and I know AMD is working on the fix. I also want to thank to both Sapphire and especially AMD support, they tried to help as much as they can and I could not return feedback to AMD (I did not know it has a time limit).

I hope these can help some of you.

Take care and best regards.

0 Kudos