Showing results for 
Search instead for 
Did you mean: 


Adept I

3970x stuck on installing windows 10

Hi Guys,

I have a problem, Ive fighting for 1.5 month without any luck:

Bios works fine, but when Installing fresh copy of windows 10, alsways infinite freezing (keyboard, mouse are not responding) on the beginning of installation. One time i was lucky to get it almost installed, but on the step of preparing devices, again freezing. Freezes sometimes random, but i had no chance to get inside windows interface to install the drivers.

Have no idea how to fix it. On the motherboard it show AA code (Possible hardware failure)

I have:

-Threadripper 3970x 

-128GB Gskill 3200

-TRX40 AORUS XTREME (rev. 1.0)

-PSU Bequiet 1200w

What kind of steps I've tried:

- waited for unfreeze 30 minutes, no ressults

-Replacing motherboard to other brand

-Replacing ram to other brand

-updating bios to the latest version

-Replacing SSD

-Tyied to connect other ssd with pre-installed windows

-download latest windows iso file


Nothing above works....I need you help, please!

6 Replies

What happens if you install Windows on your SSD on another computer with a similar processor and then install it on your motherboard?

Do a CMOS CLEAR to put the BIOS back to factory defaults.

Are you using a Windows Installation USB Flash drive or a Windows Installation DVD disc?

I presume you are able to enter BIOS. Do you have BIOS set for CMS (Legacy) Mode or UEFI Mode? 

If your SSD is set for MBR type then you need to enable CMS (Legacy) in BIOS otherwise it won't work. But if your SSD is set up as GPT type then you need to enable UEFI mode in BIOS.

Before installing Windows disconnect all unnecessary hardware except GPU, Monitor, Keyboard/Mouse, PSU, CPU, and RAM.

Also try installing with just one stick of RAM Memory in case it is a RAM compatibility issue.  I presumed you installed RAM from the Motherboard's RAM QVL List or from the RAM Manufacturer's QVL List.

When installing Windows what errors shows up (Windows installation errors)? 

Do you have a PC Speaker installed and if so, what is the BEEPING sequence when Windows is installing or fails to install, if any?

I since you replaced both the Motherboard and RAM I would open a AMD Service Request (Official AMD SUPPORT) Warranty and find out if it could be a defective CPU causing the problems or see what they suggest to do:


Thanks for your reply. 

-I did CMOS reset a couple of times;

-CMS is enabled by default;

On the links below you could find some screenshots:


Screenshot 1. Its where it freeze now, some times before, at spinning wheel windows loading, sometime where i need to pick language, one time almost at the end of installation during "device check." But mostly on spinning wheel before windows installation/loading interface pop-up.
Screenshot 2-3. How the BIOS setting looks at the moment, you could see whole ram amount, and processor model are there.

I see the only last try is to use RAM from QVL List like you suggested. I use 4 sticks GSkill x32GB each, that could be perhaps a problem. I found same Brand and model in QVL List, but just 8GB per stick...not 32GB
But the motherboard says that its support 32GB per stick, and in BIOS I could see whole amount of ram. Also found information on some other forums, where guy told that he replaced his motherboard 4 times before he got working one.

This drives me really mad...Didn't expected investing $6K and getting raw and unstable rig...

If you would have any other ideas please advice.



Don't change the RAM just install one RAM stick and see if Windows installs.

The QVL List will show you how many DIMM Slots you can populate depending on the RAM Part number. Some RAM is compatible only with 2 DIMM slots populated and others are compatible with 4 DIMM slots populated.

Here is the QVL list for G-Skill RAM 3200 Mhz with 32GB Sticks:

Screenshot 2021-01-20 105213.png

Screenshot 2021-01-20 105509.png

There are only two G-Skill RAM with 32GB per RAM Module at 3200Mhz that is compatible for your motherboard. I missed the other 32GB RAM listed above the one that I marked.

That is why I suggest to install just one RAM stick to see if it changes anything.

I am not saying that you issue is due to incompatible RAM but just trying to eliminate that factor in the equation.

I notice in the Boot Options you have 4 choices. Have you tried booting with the other 3 choices?

By any chance are you able to enter Troubleshooting menu with the Windows Installation USB Flash drive?

If so try running "Start Up Repairs" and see what it says. 

Also if "Startup Repairs" is not available try booting into Command Prompt and use DiskPart to see if there is any issues with your SSD and to set the SSD ready for installing Windows on it.

Here is how to use DiskPart to check your SSD Windows drive:

Thanks, I will try it now.


After 5 hours of many different options, again no success. Ubuntu was also not possible to install because of some other errors. 

Ive created support topic on Motherboard first, to get some tips. But perhaps will send the motherboard to manufacturer back for checking...and after cpu.

Again its sad to spend so much money and time because of raw and faulty products....

Just checked Gskill QVL list and according to them my mother board is supported.

I would try to dismount and mount CPU again, to look if all the pins are fine. Otherwise I'm out of any other ideas....