Showing results for 
Search instead for 
Did you mean: 


Adept I

3950X Stability

I just recently built a pc with a Gigabyte Aorus Ultra X570 and a 3950X. It runs fine except when I run prime95 small fft or occt small data set it will instantly stop workers or BSOD. The pc is at default setting no overclock. From troubleshooting the only thing I can do to get it to run prime95 small fft or occt small data set is if I make one change in the bios and that is changing Load Line Calibration from auto to medium. I am mainly trying to find out if anyone else has this issue if the cpu or motherboard my be faulty I'm leaning towards swapping out the motherboard or if this might be something fixed in a bios update. Any help would be greatly appreciated.

12 Replies
Adept II

First suggestion is to verify that you're running the latest BIOS for your board. The Gigabyte support website indicates that that would be F11. This is crucial, or at least it was for me with my Aorus Xtreme x570. Mine arrived with the F3 version of the BIOS and was almost unusable, even for BIOS configuration.

My configuration is similar to yours and my initial configuration was all auto. To date, my only substantive change has been to memory configuration to support XMP at 3600...


1. Verify BIOS version and update to latest (F11) if necessary.

2. Run a standalone memory test against the CPU/RAM. Building a USB bootable MemTest86 is quick and easy, but will help identify any substantive issues. By far, the most frequent causes of BSOD are bad RAM or bad power.

Also, everyone reading this thread will need some more information about your configuration and hardware, from case, cooling, RAM, graphics, etc. There are a number of very competent folks here that will happily help...

Hey thanks for the response! I am running the F11 bios my board shipped with F5 bios so first thing i did was update it. Here is a list of what I have tried. I have run memtest over night twice passing both times, I have tried 3 different sets of ram, different known good psu, clean install of windows 10, all drivers updated. If I set bios to default the pc will crash running previously mentioned stress test. If I leave the bios at default and set CPU Load Line Calibration to medium the pc runs perfect and will pass all stress test. I guess the main thing I am trying to figure out is if the Motherboard is not supply the correct power (and could possibly be fixed in a future bios revision if other people are experiencing the sam issue too) or if the CPU is maybe out of spec on voltage and is faulty?

PC specs

AMD R9 3950X

Corsair Vengence LPX (2X16) 32gb CMK32GX4M2A2666C16

Gigabyte Aorus X570 Ultra

Noctua NH-D15S cooler

Nvidia GTX 1080 Ti

Evga Supernova P2 1200 watt PSU

Fractal Design Define R6

Samsung M.2 960 Evo ssd operating system drive

Western Digital Black 6tb storage drive

Windows 10 Pro 64 bit

Adept II

You didn't mention anything about your temperatures right before you crash. Is it crashing before it even starts to ramp up the temps during Prime95. Or, is it crashing after/during reaching load temperatures?

Have you tried contating Gigabyte to see if there are any known solutions that they are aware of? There are tons of things that can cause this, but they might be able to narrow it down greatly, based off past experiences. 

What is your active Windows power plan?

Did you try booting it with only 1 stick of RAM? 

Tell us as much as you can about the behavior of your temperatures up to and during this issue. Does the BIOS throw any POST codes on your mobo error/temperature display?

Also, can you show us your homescreen inside of Ryzen Master? That will give us a lot of details and prevent us from having to ask you repeatedly for values.

Adept I

I have a update to the issue I was having with my pc. It turns out it was the processor that is faulty. I was able to try it in a friends motherboard and the same issue was happening in his. I then put my friends processor in my motherboard and it worked perfectly at default settings so I have a replacement processors coming to me from Amazon. Thanks to all for the help!

Journeyman III

So I'm looking at the same issue.

Gigabyte X570 Aorus Pro WiFi.  Latest version of UEFI (F20b at the time of writting), temps hovering right around 60, only P95 stable if I add a LLC of Medium.

Everything, and I literally mean everything else in the UEFI is set at stock.  I'm really having an issue with having to make any changes in UEFI to make thing be stable doing what amounts to math.  (Which is what computers are supposed to do.)  They should just do math and get it right, without my having to figure out how to tweak their settings.

Trying to decide if it's the chip or the board.

I have not seen many people having good luck with exchanging the chips. (The exchange transactions are fine, but the replacements are as bad or worse than the originals.)

Hello Kevin! I haven't been on this forum in a while but since my last update on here I did get a replacement cpu and though the the problem was fix but it showed back up. The new replacement cpu would run prime 95 seemingly fine until about the 30 minute mark and then would crash just like the first one. I was able to borrow my friends computer that has a 3900X in it and try both 3950X cpu's I had in his pc with the exact same results. I ended up returning the second cpu and motherboard for a Intel 9900K cpu and Z390 motherboard. I can only offer you my thoughts on the matter. In my opinion I believe that maybe with the 3950X being the new flagship cpu from AMD it may be running on the absolute bleeding edge of stability at stock settings and maybe we were really unlucky and got cpu's that were just good enough to pass quality control or maybe the motherboard manufacturer has the voltage set too low and could possibly be fixed with a future bios update. Don't get me wrong I don't dislike AMD for the issues I had I was just coming up on my Amazon return deadline and did want to be with out a pc for a long period of time sending my cpu back to the manufacturer for warranty.

There are tons of  reasons this could occur, but to blame the entire Zen 2 lineup, is just silly. It is in fact possible, you received two "bad" CPUs, but even if you did, that is not a reflection of an entire generation of CPUs. I once had NVIDIA send me out three GTX 480's, before I got one that worked properly. Sometimes you just have bad luck, when it comes to the HW lottery. 

Some other possibilities: 
Incorrect configuration of the motherboard (as default/stock, isn't always "correct' for every CPU)
Inadequate or failing PSU (output wasn't stable enough for the load placed by the 3950X) 
RAM that was not stable or configured properly
Driver conflict and/or firmware update/s needed
The Windows Power Plan selected
Motherboard SW you installed caused its own conflicts (I recommend using as little mobo provided SW, as possible)
Dirty power from the mains in your residence (such as, spikes of noise across the ground line) caused the PSU to fluctuate too much for the CPU to remain stable.
Even AntiVirus settings, especially regarding power plans, can do this.

etc. etc.

I could go on in this fashion for hours, listing things that could have caused such behavior. 

AMD is not selling CPUs that are on the "bleeding edge" of stability, as you will find tons of people with OC'd 3900 series CPUs, all across the world. It would be a really bad business practice to knowingly sell CPU's that just barely meet their stock requirements. 

Think about it, if what you said is true, the reviews on the 3950X and 3970X would be terrible. Almost every professional reviewer, did much longer stress testing than 30 mins of P95. If you look at nearly all reviews made about this generation, they are nearly all positive (most are insanely positive). 

If I was you, once I got the 2nd CPU and had the same problem, I would have been inspecting ALL other HW. 


I had a problem one time with a GPU and a Viewsonic XG2760. I assumed the Viewsonic panel was the issue and I ended up getting 3 units to test, before I decided it was not the display's fault! I figured out it was my GTX 1070 randomly causing an issue where an entire column of pixels had been swapped from the center of the screen, to the far left. 

Now, if I was to act like you, I'd say that the XG2760 is on the "bleeding edge" of stability, due to its 1mS response and 165Hz refresh rate. 


delray_kevin, I disagree with a lot of what amarrotti has to say.  If you would like me to try to help you, please open a new thread and post your HW, OS and error particulars.  I encourage you to do a Clear CMOS and change nothing in BIOS.  If your Minidump folder has any files in it, please compress and attach it to your post.  Also post a screenshot of Ryzen Master (RM) - simply drag-n-drop the image into your new thread - maybe while running Prime95.  If you have any processor applications but RM, please go to Windows key-I and Apps and uninstall them all.  Make sure you are running the latest BIOS.  Please filter your Event Viewer for critical errors.  Post any with the Detail data.

AMD Threadripper is AMD's Flagship not the 3950X.  I have not examined all the above, but I see no real information provided by amarrotti in an attempt to get at the problem.  Thanks and enjoy, John.

So I'm realizing that I didn't ever update this thread.

After much dithering about, I decided that it was the chip that was the problem (the path to that was long and circuitous.)   So I gave the Silicone Lottery wheel another spin.  (After returning the CPU to the vendor I bought it from.)

The results were much better this time.  The new chip runs Prime95 without issue for as long as I care let it go (several days was the record).  It's run error free ever since.


Wow! I really hurt some peoples feelings with my theory on the issue I had! LOL! Glad to hear you got your issue resolved! Enjoy your new CPU!

I know for fact that X570 BIOS bugs are abundant. Use the latest BIOS for your boards.

Journeyman III

It's not just you.  Aorus X570 motherboards are indeed pushing the 3950X a little too hard.

I get the same issue with two different Aorus X570 motherboards and two different 3950X chips.  Running OCCT 7.1's Power test, or its "Small data set", immediately produces thousands of errors and blue-screens the system.

If I move either 3950X onto a different motherboard, the error does not occur.  If I run a 3600X on one of the Aorus boards, the error doesn't occur either.

I get the same result with different power supplies, GPUs, and RAM.

The following changes do not fix the error:

  • Disabling XMP and setting memory speed to 2133MHz.
  • Disabling Core Performance Boost.
  • Setting Normal instead of Auto for all the voltage settings on the main screen.
  • Enabling/disabling SVM (virtualization) or IOMMU.
  • Plugging in the extra 4-pin CPU power.

The following BIOS changes do fix the error:

  • Setting CPU Vcore Loadline Calibration to Medium (great find!).  Cinebench R20 multi-core score is not impacted.
  • Disabling CCD1 (same config as a 3700X)
  • Disabling a core on each CCX (same config as a 3900X)

One 3950X was purchased on the week of launch.  The other was purchased October 2020.  One motherboard is an X570 Aorus Pro WiFi, purchased around November 2019 (BIOS might be F11, not sure).  The other is an X570 Aorus Ultra, purchased December 2020 (BIOS F21).