Showing results for 
Search instead for 
Did you mean: 


Adept II

3950X Idle speed spiking

Fresh system, 3950x CPU, X570 chipset (Asus TUF Gaming X-570 Plus), Windows 10 Pro, Noctua NH-D15 air cooler
At full load (Lightware 3D rendering), all the cores boost themselves to 3900-4000 GHz (and stay there constantly), with max temperature logged 74C - So there are no cooling issues here.

But here is the annoying thing: When the system is Idle, the cores keep bosting themselves to 4+ GHz every 10-15 seconds or so, with the accompanying fan speed-up. And when the system is otherwise completely silent, that constant pulsating noise becomes irritating quite fast.

There are no processes that  show more than 0,5% usage at a time, I have killed off most of the junk that come with Windows 10, including Defender.

Is there any way to stop this?

7 Replies
Big Boss

amerelium, how are you observing the core clocks?  If your are using HWinfo, please remove it.  Please post a screenshot of Ryzen Master (R) - simply drag-n-drop the image into your reply.  Thanks and enjoy, John.


At first my ears - easy to hear when the cores spin up. Then the task manager, Speccy, CPU-Z - they all show the same. Do not have HWinfo.


Getting exact same issue - here is a screenshot of my Ryzen Master, it will be fairly identical... keep in mind I am using a Corsair H150i Pro AIO - it should not be running this warm idle. Note Core 1, always >4.3GHz. Causes an annoying pulsating noise as OP describes. 


Journeyman III

damn... I'm getting exactly the same issue with my 3950X. Noting the Core 1 speed of 4.3GHz or higher, and the constant pulsing of the fans speeding up and slowing down as it fluctuates between 40-50C. 

Can fix it by going into power management and setting min and max processor state of 1% - but then it never goes above 2GHz which is obviously, useless. Have spent 3-4 days trying BIOS combinations - messing with PBO, core voltages, multipliers. Resitting the H150i Pro AIO cooler THREE TIMES and shelling out to buy expensive Thermal Grizzly Kryonaut Paste for good measure. I am not getting very far. Have you had any luck since Dec 18th?

Adept II

This is what I have done:

I've shortcutted Power management, so that I can swiftly change between two profiles; High Performance and Balanced. I have set the max CPU state for Balanced at 99% - the Noctua aircooler I use is so quiet that it cannot be hear at all when the cores are spiking up to 3400MHz.

If I need full throttle, like doing render work, or playing a game that I want absolute max performance (thought the GPU does most of the work), I just switch to High Performance. I use the bios Turbo Mode profile no 3, and all 16 cores will then run constantly at 4100-4200 MHz during renders, temperature peaking at about 85C - gotta love Noctua.


ah glad you found some success with this.

I'm looking for full autonomy - e.g. idle: 2GHz, <1V, 30-35C scaling to load of 4.325GHz 1.4V, 80-85C.

...if I go to Power management and set anything above 1% for min / max processor states I get that annoying pulsating sound that you described - not from my AIO or the radiator fans, that stuff is all fairly silent, but from the computer case fans (Corsair 680X RGB - these are all Corsair fans which aren't the worst in the business). This is because the idle temps will be 55C+ (due to that one core running at 4.3GHz or higher, constantly) - when it rises above 50C, the case fans kick in and bring it to 45C, then they slow down and it heats up again in seconds - rinse and repeat. Very frustrating sound. Playing with processor states fixes this and my cooler can achieve a consistent 30-35C when that one core isn't running at 4.3GHz... but then it scores 5000 pts and not 10000+ pts in Cinebench. Can have cool idles with poor performance, or warm idles with strong performance but struggling to achieve both. Hardware is clearly up to it but settings and motherboard power management needs further tweaking still. 


I have only Noctua fans in my case, so I never hear anything unless it approaching max load. So, I haven't really fixed anything, I've just limited the spiking to 3,4 GHz when I want it in quiet mode (which when playing games, is more than enough with a Sapphire Pulse 5700 XT doing all the work, a card that is also dead quiet even during load). It is mostly idle though, with temperatures rarely going above 35C. It's just those short spikes that are annoying when in a quiet room.

If you have one core running constantly at max then your system is behaving differently than mine. On my system all the cores jump to max briefly, every 10 seconds or so, before settling down to min again.

I haven't really wanted to mess around with voltage settings and the like yet, since I got such good results by just setting that turbo mode. I also do not really know what the red line temperature for this CPU is, and how far one should push it.