Showing results for 
Search instead for 
Did you mean: 


Journeyman III

3900x white led on 3 different motherboards with different hardware.

My 3900x won't even get to BIOS/UEFI. I'm stuck at the white led forever.

I tried: 

  • Cycling the PSU (EVGA Supernova G2 650w on the two builds - two different GPUs).
  • Checking pins / Re-applying thermal paste (about 4-5 times). All pins are fine.
  • Swapping GPU (GTX 760 / GTX 1660 Ti / GTX 1070)
  • BIOS was flashed to the latest version on the 3 motherboards tested.
  • Clearing CMOS a few times per motherboard.
  • Removing/Swapping RAM, tried different slots. RAM Tested:
    • Corsair Dominator 3200Mhz Cl16 2x16Gb, tried only one slot, or two slots (A2 B2)
    • G.Skill Trident Z RGB 3200Mhz Cl14 2x8Gb, tried only one slot, or two slots (A2 B2)
  • Here are the motherboard models tested: ASUS Strix X470-F, ASUS TUF X570 Plus Gaming, MSI X570-A Pro

On the Strix X470-F, the build was running a 2700X just fine, 5 minutes later, when I try to boot with the 3900x: White led (same as other boards which were brand new). Put back the 2700X in this morning: boots just fine.

What did I forget to test ? What can I do next ?

5 Replies

probably due to the BIOS not being updated enough for your processor to be supported

I have a MSI X570-A PRO but it is not in use due to problems galore


BIOS was flashed to the latest version on the 3 motherboards tested.

Not only that, but the X570-F supports it right off the bat, but I STILL updated the bios to the latest available version (yesterday) and that cpu didn't work. Strangely enough, another 3900X works just fine on the same motherboard.

My actual motherboard (a X470-F) had its BIOS updated 5 days ago, while the latest BIOS was released weeks ago. It is stated in the release notes of an older BIOS version for the same motherboard that it, in fact, supports Ryzen 3000 series CPU.

I cannot update it more than it is right now, I'm on the latest version.


only reason I bring up the BIOS as it is often overlooked

there are known issues with some batches of Ryzen 3000 series processors

NB the long thread for the R5 3600 woes

Adept II

I fear that you're going to end up looking for an RMA...

Suggest verifying one (or two) of the X570 boards and their hardware with the existing 2700 processor. Generate a known good configuration with known latest BIOS...

Once you've booted to BIOS, run a MEMTEST86 on your selected X570 to validate the RAM XMP configuration and selected clock rate.

Then reinsert the 3900x into the known good motherboard/memory/bios configuration. 

I know the whole thing is frustrating, but remember testing basics. Start with known good and only change 1 thing at a time between tests...

Best of luck!

Journeyman III

I have almost the same issue, but it works with the initial released BIOS version, on all other I get a Error code 25, or 63.

Gigabyte X570 Aorus Master

AMD Ryzen 3900X

Corsair Vengeance LPX 32GB 3200MHz

Corsair HX1000i PSU

Everything works fine with the F4 BIOS, but as soon as I try to update it to any other BIOS version it doesn't POST.