Showing results for 
Search instead for 
Did you mean: 


Adept II

3900x low stability at idle or low load

Hi All,

My PC will intermittently "reset" itself when idle or under low load.  By idle or low load, I mean no running applications or perhaps only running a web browser.  By "reset", I mean it appears to have the same behaviour as if I had push the reset button.  This occurs in Windows or Linux.  If I run anything that loads at least 1 thread e.g. running a single thread of prime95 in windows (assuming I can get into Windows without it "resetting") or stress in Linux (I setup a service to run this on boot), the system is stable (have run it 24/7 for over a week like this).

PC components:
CPU: 3900x
CPU Cooler: NZXT X73
MBD: Gigabyte X570 Aorus Pro Wifi
RAM: G.Skill 2 x 16GB 3600MHz (F4-3600C16D-32GTZNC)
GPU: EVGA 1660Ti
SSD: Samsung 1TB 970 Evo Plus
PSU: Corsair RM850
OS: Windows 10 20H2 or Ubuntu 20.04.1

BIOS settings I run compared to factory default:
- Enable XMP profile for RAM.
- Enable SVM and IOMMU (for VM use).
- Disable Full Screen LOGO
- Set fan settings for the headers used by water cooler and case fans.

CPU temperatures are good.  ~33C at idle, less 73C after 24hr running prime95, less than 73C after 24hr running stress.  The CPU will run at 4612MHz with a single core load or 4060MHz with all 24 threads loaded.  The infinity fabric runs at 1800MHz automatically.

BIOS settings I have change in an attempt to fix the problem (one at a time):
- Reduce memory speed to 3200MHz (infinity fabric runs at 1600MHz automatically).
- Not enable XMP altogether.
- Increase RAM voltage to 1.4V.
- Change CPU Vcore to Normal.
- Change CPU Vcore to Normal with Dynamic Vcore set to +0.1V
- Change CPU Vcore to Normal with Dynamic Vcore set to +0.2V
- Change SOC Vcore to Normal
- Change SOC Vcore to Normal with Dynamic Vcore SOC set to +0.1V
- Change SOC Vcore to Normal with Dynamic Vcore SOC set to +0.2V
- Change CPU Vcore to Normal, SOC Vcore to Normal, Dynamic CPU Vcore SOC set to +0.1V, Dynamic Vcore SOC set to +0.1V
- Set PCIe Slot to Gen3
- Disable DRAM Power Down
- Enable Power Loading

I have tried all of the BIOS versions available from F12 through to F31h.  I have tried a manual CMOS clear by removing the battery for 5 mins and shorting the battery contacts in the battery holder.  I have no interest in overclocking.

Hardware changes tried in an attempt to fix the problem (one at a time, in combinations, and all at once):
- RAM: Another set of G.Skill 2 x 16GB 3600MHz, F4-3600C16D-32GTZNC (I run 2 of these sets in a 3960x build)
- GPU: Gigabyte GT1030
- SSD: Intel 760p 1TB (NVMe) or Intel 660p 1TB (SATA)
- PSU: Sure Star 600W (2U Rack mount)
- CPU: Re-seating CPU
- CPU/MBD: Check for thermal compound on CPU PINs or in/around CPU socket

Anyone experienced this and perhaps fixed the issue?  Or alternatively know some way to determine a MBD or CPU fault?

6 Replies

There is a BIOS setting for power for the PSU that has caused the computer to shut down during idle or low loads

Need to set it at from low to normal. If it's set for normal then possibly you have a hardware issue.

Sorry I can't find the BIOS setting since I am using my cellphone.

Note: you can always run OCCT and stress tests your CPU, GPU, & PSU.


Thanks for the response elstaci.

As indicated, I have already tried that setting.  It's the "Power Loading" setting in the Gigabyte BIOS.


I suggest you open a AMD Service Request (Official AMD Support) under Warranty and see if they suggest to RMA your  CPU.



Hi All,

While gathering all my notes to send the MBD and CPU to be checked by the retailer I noticed I didn't actually test the F12 version BIOS like I thought I had.  The system has now been running with BIOS F12 for 24 hours straight, including overnight idle with a locked screen and no resets.

The BIOS version F20 has the idle resets.  The description from Gigabyte state there was a new AGESA version (AGESA ComboV2 to enable 3rd Gen Ryzen and "Fix AMD security vulnerabilities for SMM Callout Privilege Escalation", which I assume is a microcode update.  While I'm happy it's now stable, I'm not to happy to go without the security fix.

Anyone else with a X570 Gigabyte MBD and a 2nd Gen Ryzen with this issue that can roll back to version F12 and test?

Hi All,

BIOS version F12 has been 100% stable so far.  I know of 2 other people with 3000 series processors (no XT) that downgrading their BIOS to something with AGESA fixed the issue.

So I’m actually having a similar issue. I have the gigabyte x570 UD MOBO, Ryzen 7 3800x and RTX 3060ti.

my computer shuts down when in idle or sleep, it’s not consistent in when it does it. It only does it during sleep and idle and shuts down not a restart from what I can tell.

my current BIOS version is F20, I don’t think I can go to an older version because I have a third generation cpu. Any chance that updating the bios will fix it?