cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

anurag9799
Adept I

32GB RAM but only 16GB Usable

I have one question that I would like to get help or feedback.

I have upgrade my ram to 32gb, mostly due to video editing from 16GB.

The problem is:
I have a Ryzen 7 2700 and MSI x470 Gaming Plus Motherboard, the QVL is somewhat limited. Even worst, my current Corsair ram sticks are on the QVL and they do give me some problems.

I am using 4*8GB RAM sticks(32GB), and it says only 16GB usable. I removed an stick and it displays 24GB of RAM all usable.

Also, with 32GB cannot perform any overclocking on the CPU, as the system does not boot.

I have already got 3600Mhz of RAM and now i am stuck with this issue.

All the sticks are detected on all the softwares (HWinfo, CPU-Z), but not with windows 10(x64).

Please help.

Thanks

28 Replies
BigAl01
Volunteer Moderator

it sounds like a bad stick of RAM, but I would first try swapping the sticks around to different slots, keeping track of which stick was tried in which socket.  Put a bit of masking tape on each one with a number or letter so you can keep track.  Maybe you can find a combination that Windows will like.

As Albert Einstein said, "I could have done so much more with a Big Al's Computer!".
0 Likes

Thank you for the response.

I tried the same, checked single slot with individual ram. They are working fine. 

Same model same ram, all the slots filled tried the combinations nothing seems to be working  

ThunderBeaver
Miniboss

I'm running the exact same CPU OS MOBO is MSI X370 M7 ACK with 4x8 32GB Corsair Dominator Platinum PC3200.

Though I've never encountered a bad failed or DOA on Corsair Ram it doesn't mean it's impossible.

If you have a multimeter and know what the default voltage of the RAM is I suggest removing the RAM and testing it. 

I know there is software that can test RAM while system is powered up but a multimeter will give a more consistent result. Make sure you are testing the RAM on a non conductive surface (wooden table is ideal) and away from materials that generate static electricity due to friction (example any cloth like material).

Hope you find the dud soon. 

Check the RAM interface for any defects.

One question does the problem occur when you move the RAM into different slots? If so you may not have a bad ram stick you may have a bad RAM port.  

0 Likes

I tried the same, nothing is working

0 Likes
anurag9799
Adept I

0 Likes
tenzo23
Elite

Have you enabled XMP and selected the RAM's profile?

Also, there's a setting called Memory Try It ! you can try enabling. According to the manual (https://download.msi.com/archive/mnu_exe/mb/E7B79v2.1-GSE-LITE.pdf) "It can improve memory compatibility or performance by choosing optimized memory
preset."

Screenshot 2022-02-23 074815.jpg

/sig Fun guy.
0 Likes
BigAl01
Volunteer Moderator

Under your Task Manager screen snap, it shows '16.1 GB hardware reserved'.  My current desktop system shows about 81 MB hardware reserved, and I have 64 GB of RAM installed.  For some reason, I think Windows is holding half of your RAM in reserve.  That might be a clue to something.

As Albert Einstein said, "I could have done so much more with a Big Al's Computer!".

First, check this:

Run msconfig
Select Boot tab
Select Advanced options
Make sure Maximum memory is unchecked

 

 

Second, try setting your pagefile to something lower.  Or turning it off, rebooting and then turning it back on and rebooting... 

 

QB

Well, this is the most common thing i have got as a solution but unfortunately this did not work in my case bud.

Really appriciate your help  


@BigAl01 wrote:

Under your Task Manager screen snap, it shows '16.1 GB hardware reserved'.  My current desktop system shows about 81 MB hardware reserved, and I have 64 GB of RAM installed.  For some reason, I think Windows is holding half of your RAM in reserve.  That might be a clue to something.


Ahh, good catch @BigAl01 

Perhaps RAMDisk software?

/sig Fun guy.

Well , i tried and this did not help.

This does not want to system to boot up hence i have to reset the bios again. 

I am sure it's an BIOS issue but could not figure out the exact option.

 

 

Thank you so much for your help

Serreph
Journeyman III

Believe it or not even though it recognizes all sticks of memory, it's possible that there is an issue with the motherboard. MSI as of late has been noted as not being the most reliable with hardware stuffs. 
I recently had an issue what my PC booted up, everything was recognized but, my benchmarks said my ram and CPU (ALL BRAND NEW OUT OF BOX INCLUDING THE MOBO) were not performing. My CPU was at 8% and my RAM was at 12%. I could run programs and games but, they ran like crap. It is possible for the system to run but not perform properly if the mobo has an issue. 
Maybe take it to a computer store where they have spare parts that can be plugged in to diagnose it. Best advice as I have built many systems in the past and never had an issue until now and could not figure out the issue.

My mobo was bad out of the box. A replacement and mine runs like a UFO now!

"made it to a save point time for bed, nah 5 more minutes"
ASUS Dark HERO MoBo, Ryzen 7 5700G CPU, 1080 GPU, 32gig DRAM, 1000watt Corsair APU, Samsung 1TB M.2 970Pro SSD, Barracuda 2TB SATA

Yes, i am still in the middle of the discussion with MSI.

That's the last report of replacement or changing the CPU. 

 

Thanks

Jmork
Journeyman III

Hello, everybody,

I know this is somewhat old topic, but is there a solution to this problem?

I am running AsRock X470 Master SLI mobo, Ryzen 5 1600AF and have the same issue.

Ram runs fine at 1/2/3 sticks respectively with 8/16/24GB of memory but when I plug in the 4th one, it shows 16GB available, 32GB physical memory.

Running tests with MemTest right now but all of the proposed solutions I found in this thread/in other forums as well/ won't work.

 

Thanks for the help.

Muddbog
Journeyman III

Did you ever get this resolved? I'm having the same exact problem.

Muddbog, you should open a new post with your particulars but please post a SS of CPU-Z (latest) Memory tab. Thanks, John.

It's annoying when people start a thread but never close it out with a resolution.

I having the same issue to and was wondering if you have found a soltion. I have a Ryzen 7 2700X on a B450 Aorus pro Wifi. I have 4x8Gb ram and it gives me the same issue.

 

Capture.PNG

BigAl01
Volunteer Moderator

Here is something I found on the Internet.  This page is a good source of information, but here are some bits from it:

  1. There is a maximum memory option in the boot procedure that's used to reserve RAM in Windows 10. If you set the maximum memory too high, you may find a large amount of hardware reserved RAM Windows 10.
  2. In a computer system, the "Hardware Reserved" memory refers to the portion of system memory that is set aside by the hardware and is not available for general use by the operating system or applications.
  3. The system will continue to have some about of memory GB reserved. Often reserved memory is used by the graphics device if you are using onboard or on cpu graphics. Even if you are using a dedicated gpu , the ram can still be reserved if the embedded graphics device hasn't been disabled in the bios/uefi setup.
  4. How do I enable all RAM memory?  Right-click on the Windows icon and click on “Run.” Type in “ msconfig ” and press Enter and the System Configuration window will appear. Click on the “Boot” tab, make sure the current installed OS is highlighted, and then click on “Advanced Options.” Uncheck “Maximum memory” and press OK to save the changes.
As Albert Einstein said, "I could have done so much more with a Big Al's Computer!".

Am I utilizing my ram correctly. IMG_0064.jpeg

MSI X470 GAMING M7 AC, CPU: AMD Ryzen 7 5800X, 64 GB Corsair Vengeance RGB Pro 3600, Gigabyte RX 7600 OC, 980 PRO with Heatsink 2TB
0 Likes

Hello.

If you type in System Information in the search bar, what BIOS mode are you in?  If you have installed Windows in legacy BIOS mode, that will limit the RAM Windows can address.

yanielquentiam
Journeyman III

**For everyone coming here for the same issue**
i know this is old but switching the RAM sticks around worked for me, last thing I wanted to do.

Here's something I found that helped me

  1. Operating System and Version: What operating system are you using, and is it up to date? (e.g., Windows 10, macOS, Linux)

  2. RAM Configuration: How have you installed the new RAM? Did you add two additional RAM sticks of 8GB each to reach a total of 32GB, or did you replace the existing 16GB with two 16GB sticks?

  3. Physical Installation: Have you confirmed that the new RAM sticks are properly seated in the motherboard's RAM slots? Are there any physical issues or loose connections?

  4. BIOS/UEFI Settings: Have you checked your system's BIOS/UEFI settings to ensure that the new RAM is recognized and configured correctly? Sometimes, adjusting memory settings in the BIOS might be necessary.

  5. Compatibility: Are the new RAM modules compatible with your motherboard and the existing RAM? Did you check the motherboard's documentation for supported RAM configurations?

  6. Memory Testing: Have you run any memory diagnostics tools to check for any potential issues with the new RAM? Running a memory test could help identify any potential problems.

  7. Windows Memory Settings: Have you checked your system's memory settings in Windows? Sometimes, there might be settings that need adjustment.

  8. Task Manager: When you check your system's memory usage in Task Manager, does it show all 32GB of RAM but only utilizes 16GB, or does it show only 16GB of RAM available?

  9. RAM Slot Configuration: If you have multiple RAM slots, have you tried different configurations to ensure that all the RAM is being detected and utilized?

  10. Drivers and Updates: Are all your system drivers up to date? Sometimes, outdated drivers can cause issues with hardware recognition

Dave24-7
Journeyman III

I had exact same issue (4 x 8gb sticks). I noticed 2 of the sticks were slightly faster.

I removed all ram only inserted the faster sticks (2 x 8gb) then turned pc on, it rebooted like 3 times then booted into windows all working.

I then powered off added slower memory back in (2 x 8gb) then powered back on.

system now showed all 32 gb (4 x 8 gb) available in windows task manager, previously it reported 16 hardware reserved, this was resolved. 
just sharing what worked for me. 

BigAl01
Volunteer Moderator

That's an interesting solution.  The motherboard needed to configure for the faster RAM first.  This also goes to show people that it's best to use the same RAM in all the slots.

As Albert Einstein said, "I could have done so much more with a Big Al's Computer!".

I am glad I found this thread. But now I am worried that I am not fully utilizing all my ram.  Thank you bigal01 for all you do here.  

IMG_0064.jpeg

 

MSI X470 GAMING M7 AC, CPU: AMD Ryzen 7 5800X, 64 GB Corsair Vengeance RGB Pro 3600, Gigabyte RX 7600 OC, 980 PRO with Heatsink 2TB
0 Likes
YanEggplant
Journeyman III

Boys I have a news for ya but this will be tricky

so I unmatching sets of ram doesn't have to do with this problem since I have 16GB and an 8GB both clock at 2666mhz.. my total was supposedly 24gb but as you guys had it only shows 16gb and the rest of it being "hardware reserved" 

Remove the ram from the slot and try putting one if its working fine shut down and try putting another one in 
If its shows the full size (congrats you're done) but if it still the same thing.. you need to shut down and remove the CMOS battery and ony put 1 stick in.. it will definitely work .. Now shut down and put the other sticks in (don't put the CMOS battery in yet... just leave it for a while) 
Supposedly it will show the full amount being used if its not just repeat the process with a different stick (just keep swapping your main ram stick)
Once you get it to work with both stick and shows all the ram like mine 24GB total (without the CMOS battery) shut it down and put your CMOS battery in and turn on your pc... it will surely works 

END

btw I have discord, steam, brave browser, youtube, my webcam app, voicemeter potato running in the background 

Screenshot 2023-12-18 121919.png
PC specs
Ryzen 5 1500X
24GB DDR4 2666mhz
RX590 8GB
ASROCK A320M HDV R.4
Screenshot 2023-12-18 121607.png

The CMOS battery trick worked for me. 

1) Shutdown my PC.

2)Pulled CMOS battery.

3)Pulled the power plug (30sec)

4)Restarted the pc

5)Opened BIOS

6)Saved the default to be sure it cleared

7)shutdown

8)Put the CMOS battery back in.

9)Loaded the BIOS and Saved the default settings.

10) Reloaded Windows10 and now shows 32gb instead of 16.

 

Thank you YanEggplant for the tip!

bladon
Journeyman III

I had the same issue and resolved it. I'm running on a Tomahawk b350 motherboard. What worked for me was simply hitting f2 and using default settings or what not instead. Windows was reserving 16GB of RAM for no reason. I tried resetting CMOS and that didn't work, the issue wasn't that my windows capped itself at 16gb, it was simply something with BIOS.