cancel
Showing results for 
Search instead for 
Did you mean: 

Processors

plazmer
Journeyman III

Re: 2700X random freeze

My Ryzen 5 2600 was also freezing in the forum someone suggested setting the Power Supply Idle Control to typical current idle which helped with the freezing but idk if it's safe

I will also change the stock cooler to something else and see if that will help

raakaar
Journeyman III

Re: 2700X random freeze

I know this thread has been idle for a bit, but I have discovered another seemingly contributing BIOS annoyance that has seemed to rectify my freezing problems with my 2700X on an Asus Crosshair VII Hero (WiFi):

I tried all the other tweaks (VCORE LLC, manual RAM tuning, disable spread spectrum, et al)

I even found some settings that downclock your RAM (thanks AMD) and disabled those.  This only allowed me to get a stable 4.5GHz OC on all cores, but the random hangs persisted.  Usually lasting ~15 seconds to ~1 minute.

I then came across this thread and took another look.  Lo and behold phase control on CPU and VCORE were causing my issue.  The phase control settings introduce voltage variance to keep the VRM cooler.  When you buy premium parts you usually keep thermals in mind, or at least I do, so I don't understand the thought process in adding voltage instability to a voltage sensitive component.

Anyway, Set your CPU and VCORE SOC Phase control to Highest/Extreme/largest available value and your instabilities should be a thing of the past!

Cheers!

0 Likes
h0tr0d
Journeyman III

Re: 2700X random freeze

I wanted to add the solution that worked for me to this thread since it is one of the first ones that pops up when searching for the problem.  My symptoms were similar in that the computer would hang for several seconds up to a minute then catch up but the mouse was still able to move.  I was using the Ryzen Balanced power plan.

Ryzen 5 2600X

ASUS ROG STRIX X470-F Gaming 4207 BIOS

G.Skill TridentZ RGB DDR 4 3000 16GB

PNY 240GB SSD

Windows 10 Pro 1809 +All updates.

Latest drivers installed 2/25/2019

Event viewer was showing System event 129 "storeahci" warning.  It was basically sending a reset command to my SSD.

I had to use the registry hack found on this page to enable "AHCI Link Power Management" and to set it to "Active".

The option does not exist in the power scheme without the reg hack.

Windows 10 Help Forums 

I spent about 12 hours chasing my tail on the issue thinking it was bad memory or had to do with my OC or was a voltage issue.  The same SSD worked fine on W10 in my previous FX8350 build.

Good Luck!

0 Likes